Import Debian version 0.6+nmu2 master debian/0.6+nmu2
authorPhil Wyett <philwyett@kathenas.org>
Fri, 14 Jul 2017 03:43:06 +0000 (04:43 +0100)
committerSteve McIntyre <steve@einval.com>
Sun, 16 Jul 2017 22:37:36 +0000 (23:37 +0100)
live-wrapper (0.6+nmu2) unstable; urgency=medium

  * Non-maintainer upload.
  * Remove incorrect instance of converting to UTF-8.
  * Eliminate 'pyversions' warnings at build time.
  * Add 'python-requests' build dependency. Fixes docs build.
  * Add 'squashfs-tools' dependency. (Closes: #867282).

.gitignore [deleted file]
debian/changelog
debian/control
debian/rules
lwr/run.py

diff --git a/.gitignore b/.gitignore
deleted file mode 100644 (file)
index dc3250f..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-*.pyc
-*.swp
-doc/_build
-*.log
-local
-live_wrapper.egg-info
index 80292bd..17a6013 100644 (file)
@@ -1,9 +1,21 @@
-live-wrapper (0.6+nmu1) UNRELEASED; urgency=medium
+live-wrapper (0.6+nmu2) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * Remove incorrect instance of converting to UTF-8.
+  * Eliminate 'pyversions' warnings at build time.
+  * Add 'python-requests' build dependency. Fixes docs build.
+  * Add 'squashfs-tools' dependency. (Closes: #867282).
+
+ -- Phil Wyett <philwyett@kathenas.org>  Fri, 14 Jul 2017 04:43:06 +0100
+
+live-wrapper (0.6+nmu1) unstable; urgency=medium
 
   * Non-maintainer upload.
   * Add a dependency on python-pycurl, needed by lwr (closes: #861994)
+  * Add Build-Depends: python-apt, python-cliapp, vmdebootstrap needed to
+    completely build the lwr autodoc
 
- -- Florian Schlichting <fsfs@debian.org>  Tue, 16 May 2017 23:06:46 +0200
+ -- Florian Schlichting <fsfs@debian.org>  Tue, 16 May 2017 23:31:36 +0200
 
 live-wrapper (0.6) unstable; urgency=medium
 
index a77c9bc..d25f37e 100644 (file)
@@ -6,8 +6,12 @@ Priority: optional
 Build-Depends: debhelper (>= 9),
                dh-python,
                python-all,
+               python-apt,
+               python-cliapp,
+               python-requests,
                python-setuptools,
-               python-sphinx
+               python-sphinx,
+               vmdebootstrap
 Standards-Version: 3.9.8
 Vcs-Browser: https://anonscm.debian.org/cgit/debian-live/live-wrapper.git
 Vcs-Git: https://anonscm.debian.org/git/debian-live/live-wrapper.git
@@ -17,10 +21,11 @@ Package: live-wrapper
 Architecture: all
 Depends: ${misc:Depends},
          ${python:Depends},
-         xorriso,
-         isolinux,
          debian-archive-keyring,
-         python-distro-info
+         isolinux,
+         python-distro-info,
+         squashfs-tools,
+         xorriso
 Suggests: cmdtest
 Description: Wrapper for vmdebootstrap for creating live images
  live-wrapper is a wrapper around vmdebootstrap to install a live Debian
index f2fb895..61243fc 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 
 %:
-       dh $@ --with python2,sphinxdoc
+       dh $@ --with python2,sphinxdoc --buildsystem=pybuild
 
 override_dh_auto_build:
        dh_auto_build
index c235cf0..fd9f14c 100644 (file)
@@ -44,7 +44,7 @@ class LiveWrapper(cliapp.Application):
 
 
     def add_settings(self):
-        default_arch = subprocess.check_output(["dpkg", "--print-architecture"]).decode('utf-8').strip()
+        default_arch = subprocess.check_output(["dpkg", "--print-architecture"]).strip()
         self.settings.string(
             ['o', 'image_output'], 'Location for built image',
             metavar='/PATH/TO/FILE.ISO',