Move devscripts from a lot of packages to -recommended
authorPeter Palfrader <peter@palfrader.org>
Tue, 23 Dec 2014 15:28:17 +0000 (16:28 +0100)
committerPeter Palfrader <peter@palfrader.org>
Tue, 23 Dec 2014 15:28:17 +0000 (16:28 +0100)
debian/changelog
debian/control

index 9b8bceb..5b60e5e 100644 (file)
@@ -12,8 +12,9 @@ debian.org (56) UNRELEASED; urgency=medium
   * debian.org-recommended:
     + multitail
   * Move xz-utils dependency from various to -recommended.
+  * Move devscripts from a lot of packages to -recommended.
 
- -- Peter Palfrader <weasel@debian.org>  Thu, 04 Dec 2014 14:07:22 +0100
+ -- Peter Palfrader <weasel@debian.org>  Tue, 23 Dec 2014 16:27:56 +0100
 
 debian.org (55) unstable; urgency=low
 
index 278aac6..5930006 100644 (file)
@@ -40,6 +40,8 @@ Depends: debian.org,
        ,
        man-db
        ,
+       devscripts
+       ,
        subversion, rcs, git, bzr,
                git-svn,
                subversion-tools,
@@ -383,7 +385,6 @@ Depends: apt-utils,
        python-sqlalchemy,
        binutils-multiarch,
        build-essential,
-       devscripts,
        graphviz,
        ikiwiki,
        libdbd-pg-ruby,
@@ -429,7 +430,6 @@ Depends: edos-debcheck,
        python2.7,
        python2.7-dev,
        python-dev,
-       devscripts,
        wdiff,
        python-pygresql,
        python-libxslt1,
@@ -465,7 +465,6 @@ Depends: bittornado,
        fakeroot,
        dosfstools,
        libsoap-lite-perl,
-       devscripts,
        mtools
 Description: metapackage for cdbuilder
  This package depends on all the packages that are needed for a cdbuilder setup.
@@ -520,7 +519,6 @@ Description: metapackage for backports.debian.org
 Package: debian.org-qa.debian.org
 Architecture: all
 Depends: db4.8-util,
-       devscripts,
        gnuplot-nox,
        wml,
        libapt-pkg-perl,
@@ -649,7 +647,6 @@ Depends:   binutils,
        diffstat,
        dpkg-dev,
        debhelper,
-       devscripts,
        fakeroot,
        file,
        gettext,
@@ -836,7 +833,7 @@ Depends: debhelper,
        python-apt,
        python-distro-info,
        python-yaml,
-       devscripts, libsoap-lite-perl
+       libsoap-lite-perl
 Description: metapackage for piuparts-master.debian.org
  This package depends on all the packages that are needed for the
  master in the piuparts.debian.org setup.
@@ -913,7 +910,6 @@ Depends: gnuplot,
        graphviz,
        fonts-liberation,
        edos-distcheck,
-       devscripts,
        liburi-perl,
        edos-distcheck,
        aspell,
@@ -958,7 +954,6 @@ Description: metapackage for codesearch.debian.org
 Package: debian.org-dedup.debian.net
 Architecture: all
 Depends: curl,
-       devscripts,
        python,
        python-concurrent.futures,
        python-debian,
@@ -1044,7 +1039,6 @@ Depends: python,
          python-simplejson,
          python-yaml,
          dpkg-dev,
-         devscripts,
          patchutils,
          rsync,
          curl,