sso.d.o ported to python3, and cleaned old deps
authorEnrico Zini <enrico@enricozini.org>
Wed, 9 Aug 2017 15:54:11 +0000 (11:54 -0400)
committerLuca Filipozzi <lfilipoz@emyr.net>
Thu, 10 Aug 2017 04:44:27 +0000 (04:44 +0000)
Signed-off-by: Luca Filipozzi <lfilipoz@emyr.net>
debian/changelog
debian/control

index 9a84aac..2e3aeb1 100644 (file)
@@ -20,6 +20,13 @@ debian.org (63) UNRELEASED; urgency=medium
       python3-debiancontributors python3-tz python3-markdown
       python3-djangorestframework
     + python3-git
       python3-debiancontributors python3-tz python3-markdown
       python3-djangorestframework
     + python3-git
+  * debian.org-sso.debian.org:
+    - libcatalyst-modules-perl, libcatalyst-engine-apache-perl,
+      libapache2-mod-perl2, libapache2-reload-perl, libcatalyst-devel-perl,
+      libhtml-mason-perl
+    - python-django, python-lockfile
+    + libapache2-mod-wsgi-py3, python3-django, python3-lockfile,
+      python3-ldap3, python3-psycopg2, python3-openssl
 
  -- Aurelien Jarno <aurel32@debian.org>  Mon, 19 Jun 2017 16:08:08 +0200
 
 
  -- Aurelien Jarno <aurel32@debian.org>  Mon, 19 Jun 2017 16:08:08 +0200
 
index 57fd5f6..1ea4570 100644 (file)
@@ -815,15 +815,13 @@ Description: metapackages for debtags.debian.org dependencies
 
 Package: debian.org-sso.debian.org
 Architecture: all
 
 Package: debian.org-sso.debian.org
 Architecture: all
-Depends: libcatalyst-modules-perl,
-       libcatalyst-engine-apache-perl,
-       libapache2-mod-perl2,
-       libapache2-reload-perl,
-       libcatalyst-devel-perl,
-       libhtml-mason-perl,
+Depends: libapache2-mod-wsgi-py3,
        python3-requests,
        python3-requests,
-       python-django (>= 1.7),
-       python-lockfile,
+       python3-django,
+       python3-lockfile,
+       python3-ldap3,
+       python3-psycopg2,
+       python3-openssl,
        gnutls-bin
 Description: metapackages for sso.debian.org dependencies
  This package depends on everything that is needed for sso.debian.org.
        gnutls-bin
 Description: metapackages for sso.debian.org dependencies
  This package depends on everything that is needed for sso.debian.org.