ec67e034026710c354dda4926fcd7a642558d27a
[debian.org.git] / debian / control
1 Source: debian.org
2 Section: local/admin
3 Priority: required
4 Maintainer: Debian sysadmin Team <debian-admin@debian.org>
5 Uploaders: Peter Palfrader <weasel@debian.org>, Martin Zobel-Helas <zobel@debian.org>, Stephen Gran <sgran@debian.org>
6 Build-Depends: debhelper (>= 7)
7 Standards-Version: 3.8.1
8
9 Package: debian.org
10 Architecture: all
11 Depends: userdir-ldap, zsh, tcsh, pdksh, ksh, csh, ntp, locales-all, exim4-daemon-heavy | postfix, sudo, libpam-pwdfile, vim, munin-node, gnupg, bzip2, cacert-spi | ca-certificates (>> 20080411), ed, cron, dialog, libterm-readline-gnu-perl, logrotate, syslog-ng (>= 3.1), nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic
12 Recommends: debian.org-recommended
13 Conflicts: dchroot-dsa (<= 2:1)
14 Description: DSA's host metapackage
15  This package depends on packages that should be installed on every
16  debian.org host, and conflicts with packages that should never be
17  installed.
18
19 Package: debian.org-recommended-linux
20 Architecture: all
21 Depends: vlan, ifenslave, bridge-utils, iproute,
22         strace,
23         lsscsi
24 Description: metapackage to pull in recommended, but not essential tools for linux system
25  This package depends on packages that are recommended to  be installed on
26  every Linux debian.org host but are not essential.
27
28 Package: debian.org-recommended
29 Architecture: all
30 Depends: debian.org,
31         busybox-static,
32         debian.org-recommended-linux | not+gnu-linux,
33         molly-guard
34         ,
35         man-db
36         ,
37         subversion, rcs, git-core, bzr,
38                 git-svn,
39                 subversion-tools,
40                 mercurial,
41                 cvs
42         ,
43         mtr-tiny, tcpdump, tcptraceroute, ndisc6,
44         traceroute | not+gnu-linux,
45         iputils-tracepath | not+gnu-linux,
46         bind9-host, dnsutils, whois, unbound-host
47         ,
48         emacs23-nox | emacs23 | emacs22-nox | emacs22 | emacs21-nox | emacs21
49         ,
50         at, uptimed,
51         puppet,
52                 libaugeas-ruby,
53                 libaugeas-ruby1.8,
54                 libaugeas0,
55                 augeas-lenses (>= 0.7),
56         locate, dlocate
57         ,
58         dsa-nagios-checks
59         ,
60         lshw | not+gnu-linux,
61         dmidecode | not+amd64,
62         dmidecode | not+i386,
63         dmidecode | not+ia64
64         ,
65         ipython
66         ,
67         mcelog | not+amd64 | not+gnu-linux,
68         mcelog | not+i386 | not+gnu-linux,
69         ,
70         htop, psmisc,
71         lsof | not+gnu-linux,
72         ,
73         ncdu,
74         mc,
75                 genisoimage,
76         less,
77         rsync,
78         screen,
79         ldap-utils, ldapvi,
80         mmv,
81         moreutils,
82         patchutils,
83         diffstat,
84         netcat-openbsd, socat, telnet
85         ,
86         deborphan
87         ,
88         file
89         ,
90         buffer
91         ,
92         bsd-mailx
93         ,
94         timeout | coreutils (>= 8.0-1)
95         ,
96         wget, curl, lftp, ftp,
97         ,
98         dput
99         ,
100         uuid-runtime
101         ,
102         finger
103         ,
104         unzip
105         ,
106         w3m,
107         elinks,
108         mutt
109 Description: metapackage to pull in recommended, but not essential tools
110  This package depends on packages that are recommended to  be installed on
111  every debian.org host but are not essential.
112
113 Package: debian.org-bugs.debian.org
114 Architecture: all
115 Depends: graphviz,
116         libcgi-simple-perl,
117         libio-stringy-perl,
118         liblist-moreutils-perl,
119         libmime-tools-perl,
120         libmldbm-perl,
121         libparams-validate-perl,
122         libsafe-hole-perl,
123         libtext-template-perl,
124         liburi-perl,
125         libhtml-tree-perl,
126         libsoap-lite-perl,
127         libdbd-pg-perl,
128         python-pyinotify,
129         python-yaml
130 Description: metapackages for bugs.debian.org dependencies
131  This package depends on everything that is needed for a bugs.debian.org
132  mirror or (in the future) bugs-master.
133
134 Package: debian.org-bugs.debian.org-mx
135 Architecture: all
136 Depends: debian.org-bugs.debian.org,
137         spamassassin,
138         build-essential,
139         spamc,
140         libmail-spf-perl,
141         re2c,
142         libsys-syslog-perl,
143         libio-socket-inet6-perl,
144         libnet-ident-perl,
145         libdbi-perl,
146         pyzor,
147         libmail-dkim-perl,
148         libdbd-pg-perl
149 Description: metapackages for bugs.debian.org mail exchanger
150  This package depends on everything that is needed for a bugs.debian.org
151  MX.
152
153
154 Package: debian.org-packages.debian.org
155 Architecture: all
156 Depends: db4.6-util,
157         liblocale-maketext-lexicon-perl,
158         libi18n-acceptlanguage-perl,
159         libnumber-format-perl,
160         libcompress-zlib-perl,
161         libhtml-parser-perl,
162         libmldbm-perl,
163         libtext-iconv-perl,
164         libclass-accessor-perl,
165         liburi-perl,
166         libtemplate-perl,
167         liblingua-stem-perl,
168         libsearch-xapian-perl,
169         libtimedate-perl,
170         libapache2-mod-perl2,
171         libapache2-reload-perl
172 Description: metapackages for packages.debian.org dependencies
173  This package depends on everything that is needed for a packages.debian.org
174  mirror or (in the future) packages-master.
175
176 Package: debian.org-www-master.debian.org
177 Architecture: all
178 Depends: debiandoc-sgml,
179         asciidoc,
180         cm-super,
181         debhelper,
182         docbook,
183         docbook-dsssl,
184         docbook-xsl,
185         dpkg-dev,
186         gettext,
187         ghostscript,
188         imagemagick,
189         iso-codes,
190         isoquery,
191         jadetex,
192         kcc,
193         ko.tex-base,
194         latex-cjk-all,
195         latex-cjk-chinese,
196         ldap-utils,
197         libemail-address-perl,
198         libintl-perl,
199         libmime-lite-perl,
200         libnet-ldap-perl,
201         libsoap-lite-perl,
202         libtimedate-perl,
203         libwww-perl,
204         libxml2-utils,
205         libxml-rss-perl,
206         littex,
207         locales, locales-all,
208         maildrop,
209         openjade,
210         openjade1.3,
211         po4a,
212         poxml,
213         procmail,
214         python2.4,
215         python-xml,
216         texlive-fonts-recommended,
217         texlive-lang-cyrillic, texlive-lang-cyrillic, latex-cjk-japanese,
218         texlive-lang-czechslovak,
219         texlive-lang-finnish,
220         texlive-lang-french,
221         texlive-lang-german,
222         texlive-lang-greek,
223         texlive-lang-italian,
224         texlive-lang-other,
225         texlive-lang-portuguese,
226         texlive-lang-spanish,
227         texlive-lang-swedish,
228         texlive-lang-vietnamese,
229         texlive-latex-base,
230         texlive-latex-extra,
231         texlive-latex-recommended,
232         tidy,
233         time,
234         ttf-arphic-uming,
235         ttf-malayalam-fonts,
236         uni2ascii,
237         wml,
238         xmlroff, dblatex,
239         xplanet,
240         xplanet-images,
241         xsltproc,
242         libjson-perl
243 Description: metapackages for www-master.debian.org dependencies
244  This package depends on everything that is needed for a www-master.debian.org.
245
246
247 Package: debian.org-buildd.debian.org
248 Architecture: all
249 Depends: edos-distcheck,
250         ghostscript,
251         libcompress-bzip2-perl,
252         libcompress-zlib-perl,
253         libhash-merge-perl,
254         libmailtools-perl,
255         libdbi-perl,
256         libdbd-pg-perl,
257         libfile-spec-perl,
258         libstring-escape-perl,
259         libstring-format-perl,
260         libyaml-tiny-perl,
261         python-apt,
262         python-contract,
263         python-coverage,
264         python-debian,
265         python-psycopg2,
266         python-mako,
267         python-nose,
268         python-sqlalchemy,
269         r-base-core,
270         r-cran-lattice,
271         php5,
272         moreutils (>= 0.39~),
273         libdpkg-perl
274 Description: metapackages for buildd.debian.org dependencies
275  This package depends on everything that is needed for a buildd.debian.org.
276
277
278 Package: debian.org-patch-tracker.debian.org
279 Architecture: all
280 Depends: patchutils,
281         python,
282         python-cheetah,
283         python-pygments,
284         python-debian,
285         reprepro,
286         python-wsgiref,
287         python-simplejson,
288         python-pysqlite2,
289         diffstat
290 Description: metapackages for patch-tracker.debian.org dependencies
291  This package depends on everything that is needed for a patch-tracker.debian.org.
292
293 Package: debian.org-planet.debian.org
294 Architecture: all
295 Depends: libwww-perl,
296         timeout | coreutils (>= 8.0-1),
297         debianutils,
298         python-django,
299         python,
300         libdbi-perl, libdate-manip-perl, libdbd-sqlite3-perl
301 Description: metapackages for planet.debian.org dependencies
302  This package depends on everything that is needed for a planet.debian.org.
303
304 Package: debian.org-testing-security.debian.org
305 Architecture: all
306 Depends: libdbd-sqlite3-perl,
307         sqlite3,
308         python-apsw,
309         libterm-readline-gnu-perl,
310         python-apt
311 Description: metapackages for testing-security.debian.org dependencies
312  This package depends on everything that is needed for a testing-security.debian.org.
313
314 Package: debian.org-ftpmaster.debian.org
315 Architecture: all
316 Depends: apt-utils,
317         libapt-pkg-dev,
318         libemail-send-perl,
319         python-apt,
320         python-debianbts (>= 1.4~bpo50+1),
321         lintian,
322         python,
323         python-debian,
324         python-gnupginterface,
325         python-ldap,
326         python-psycopg2,
327         python-pygresql,
328         python-pyrss2gen,
329         python-yaml,
330         python-rrdtool,
331         python-sqlalchemy,
332         binutils-multiarch,
333         build-essential,
334         devscripts,
335         graphviz,
336         ikiwiki,
337         libdbd-pg-ruby,
338         python-epydoc,
339         python-numpy,
340         python-soappy,
341         r-base,
342         symlinks,
343         python-magic,
344         unp,
345         procmail,
346         cvs,
347         ruby,
348         lynx,
349         libxml-rss-perl,
350         ghostscript,
351         perforate,
352         wdiff,
353         xz-utils (>= 4.999.9beta+20100713-1~bpo50+1)
354 Description: metapackage for ftpmaster
355  This package depends on everything that is needed for an ftpmaster setup.
356
357 Package: debian.org-ftpmaster.debian.org-poneys
358 Architecture: all
359 Depends: bicyclerepair,
360         dpkg-dev-el,
361         easypg,
362         emacs-goodies-el,
363         pychecker,
364         pylint,
365         python-mode,
366         ruby-elisp,
367         gitstats,
368         colordiff
369 Description: metapackage for ftpmaster extras
370  Things not really needed needed.
371
372 Package: debian.org-release.debian.org
373 Architecture: all
374 Depends: edos-debcheck,
375         mutt,
376         subversion,
377         python2.5,
378         python2.5-dev,
379         python-dev,
380         devscripts,
381         wdiff,
382         python-pygresql,
383         python-libxslt1,
384         python-apt,
385         python-debian,
386         libapt-pkg-perl,
387         libapt-pkg-dev,
388         dpkg-dev,
389         procmail,
390         rrdtool,
391         python3.1,
392         python3.1-dev,
393         python3-apt,
394         picosat,
395         openjdk-6-jre-headless
396 Description: metapackage for release
397  This package depends on everything that is needed for a release.debian.org
398  setup.
399
400 Package: debian.org-cdbuilder.debian.org
401 Architecture: all
402 Depends: bittornado,
403         build-essential,
404         debhelper,
405         debian-cd,
406         jigit,
407         m4,
408         tofrodos,
409         zip,
410         zsync,
411         fakeroot,
412         dosfstools,
413         devscripts
414 Description: metapackage for cdbuilder
415  This package depends on all the packages that are needed for a cdbuilder setup.
416
417 Package: debian.org-cdimage-search.debian.org
418 Architecture: all
419 Depends: libconfigreader-simple-perl
420 Description: metapackage for cdimage-search.debian.org
421  This package depends on all the packages that are needed for the CD/DVD search CGI website
422
423 Package: debian.org-manpages.debian.org
424 Architecture: all
425 Depends: locales-all,
426         gs-common
427 Description: metapackage for manpages
428  This package depends on all the packages that are needed for manpages.d.o setup.
429
430 Package: debian.org-nm.debian.org
431 Architecture: all
432 Depends: libapache2-mod-php5, libapache2-mod-wsgi,
433         php5-cli,
434         php5-ldap, php5-pgsql,
435         wml,
436         mutt, mboxgrep,
437         python,
438         python-mako (>= 0.2.5), python-gnupginterface, python-ldap,
439         python-apt, python-beautifulsoup, python-debianbts, python-dns,
440         python-dnspython, python-egenix-mxdatetime, python-egenix-mxtools,
441         python-elementtree | python (>= 2.6), python-flup, python-libxml2,
442         python-lxml, python-psycopg2, python-soappy, python-virtualenv,
443         python-sqlalchemy (>= 0.6), python (>= 2.5.4-5~) | python-simplejson,
444         python-flask (>= 0.6), python-flaskext.wtf, python-wtforms,
445         python-xapian,
446         python-dateutil,
447         perl,
448         libdbi-perl, libdbd-pg-perl, libdbd-sqlite3-perl,
449         procmail,
450         moreutils
451 Description: metapackage for nm.debian.org
452  This package depends on all the packages that are needed for nm.debian.org setup.
453
454 Package: debian.org-backports.debian.org
455 Architecture: all
456 Depends: debian.org-ftpmaster.debian.org,
457         libdbi-perl, libdbd-pg-perl
458 Description: metapackage for backports.debian.org
459  This package depends on all the packages that are needed for backports.debian.org setup.
460
461 Package: debian.org-qa.debian.org
462 Architecture: all
463 Depends: db4.8-util,
464         gnuplot-nox,
465         wml,
466         libapt-pkg-perl,
467                 libdbd-pg-perl,
468                 libdate-manip-perl,
469                 libdpkg-perl,
470                 libmailtools-perl,
471                 libsoap-lite-perl,
472                 libtemplate-perl,
473                 libxml-simple-perl,
474                 libmail-sendmail-perl,
475                 libdate-calc-perl,
476                 libnet-ldap-perl,
477         php5, php5-cgi, php5-cli,
478                 php5-ldap, php5-pgsql,
479                 libapache2-mod-fcgid,
480         python-apt, python-psycopg2,
481         libdbd-pg-ruby,
482         rrdtool
483 Description: metapackage for qa.debian.org
484  This package depends on all the packages that are needed for qa.debian.org setup.
485
486 Package: debian.org-udd.debian.org
487 Architecture: all
488 Depends: graphviz,
489         libapt-pkg-dev,
490         libcgi-simple-perl,
491         libdbd-pg-ruby,
492         libdbi-ruby,
493         libjson-ruby,
494         liblist-moreutils-perl,
495         libmime-tools-perl,
496         libparams-validate-perl,
497         libperl-dev,
498         libmldbm-perl,
499         libsafe-hole-perl,
500         libtext-template-perl,
501         libyaml-syck-perl,
502         python-debian,
503         python-dev,
504         python-psycopg2,
505         python-yaml
506 Description: metapackage for udd.debian.org
507  This package depends on all the packages that are needed for udd.debian.org setup.
508
509 Package: debian.org-snapshot.debian.org
510 Architecture: all
511 Depends: ruby, libdbd-pg-ruby1.8, libbz2-ruby1.8, libbz2-ruby1.8, python-yaml, python-psycopg2, python-lockfile, fuse-utils, python-fuse, uuid-runtime,
512         python-dev, gcc,
513         python-pylons
514 Description: metapackage for snapshot.debian.org
515  This package depends on all the packages that are needed for snapshot.debian.org setup.
516
517 Package: debian.org-women.debian.org
518 Architecture: all
519 Depends: wml
520 Description: metapackages for women.debian.org dependencies
521  This package depends on everything that is needed for women.debian.org.
522
523
524 Package: debian.org-lintian.debian.org
525 Architecture: all
526 Depends:   binutils,
527         binutils-multiarch,
528         bzip2,
529         diffstat,
530         dpkg-dev,
531         debhelper,
532         fakeroot,
533         file,
534         gettext,
535         intltool-debian,
536         libapt-pkg-perl,
537         libclass-accessor-perl,
538         libdigest-sha-perl,
539         libdpkg-perl,
540         libemail-valid-perl,
541         libhtml-parser-perl,
542         libipc-run-perl,
543         libparse-debianchangelog-perl,
544         libtimedate-perl,
545         libtext-template-perl,
546         liburi-perl,
547         locales,
548         man-db,
549         perl,
550         unzip,
551         xz-utils
552         ,
553         docbook-utils,
554         docbook-xml
555 Description: metapackages for lintian.debian.org dependencies
556  This package depends on everything that is needed for lintian.debian.org.
557
558 Package: debian.org-popcon.debian.org
559 Architecture: all
560 Depends:  libchart-perl
561 Description: metapackages for popcon.debian.org dependencies
562  This package depends on everything that is needed for popcon.debian.org.
563
564 Package: debian.org-dde.debian.net
565 Architecture: all
566 Depends: python-apt,
567         python-debian,
568         python-debianbts,
569         python-feedparser,
570         python-flup,
571         python-nose,
572         python-paste,
573         python-psycopg2,
574         python-pyrss2gen,
575         python-soappy,
576         python-werkzeug,
577         python-xapian,
578         python-yaml
579 Description: metapackages for dde.debian.net dependencies
580  This package depends on everything that is needed for dde.debian.net.