release.debian.org: + postgresql-client
[debian.org.git] / debian / control
1 Source: debian.org
2 Section: local/admin
3 Priority: required
4 Maintainer: Debian sysadmin Team <debian-admin@debian.org>
5 Uploaders: Peter Palfrader <weasel@debian.org>, Martin Zobel-Helas <zobel@debian.org>, Stephen Gran <sgran@debian.org>, Luca Filipozzi <lfilipoz@debian.org>
6 Build-Depends: debhelper (>= 7)
7 Standards-Version: 3.8.1
8
9 Package: debian.org
10 Architecture: all
11 Depends: userdir-ldap, zsh, tcsh, pdksh, ksh, csh, ntp, locales-all, exim4-daemon-heavy | postfix, sudo, libpam-pwdfile, vim, nano, munin-node, gnupg, bzip2, cacert-spi | ca-certificates (>> 20080411), ed, cron, dialog, libterm-readline-gnu-perl, logrotate, syslog-ng (>= 3.1), nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic
12 Recommends: debian.org-recommended
13 Conflicts: dchroot-dsa (<= 2:1)
14 Description: DSA's host metapackage
15  This package depends on packages that should be installed on every
16  debian.org host, and conflicts with packages that should never be
17  installed.
18
19 Package: debian.org-recommended-linux
20 Architecture: all
21 Depends: vlan, ifenslave, bridge-utils, iproute,
22         strace,
23         lsscsi,
24         ethtool,
25         bwm-ng,
26         iputils-tracepath,
27         traceroute,
28         lshw,
29         lsof
30 Description: metapackage to pull in recommended, but not essential tools for linux system
31  This package depends on packages that are recommended to  be installed on
32  every Linux debian.org host but are not essential.
33
34 Package: debian.org-recommended
35 Architecture: any
36 Depends: debian.org,
37         busybox-static,
38         debian.org-recommended-linux [linux-any],
39         molly-guard
40         ,
41         man-db
42         ,
43         devscripts
44         ,
45         subversion, rcs, git, bzr,
46                 git-svn,
47                 subversion-tools,
48                 mercurial,
49                 cvs
50         ,
51         mtr-tiny, tcpdump, tcptraceroute, ndisc6,
52         bind9-host, dnsutils, whois, unbound-host
53         ,
54         emacs24-nox | emacs24 | emacs23-nox | emacs23 | emacs22-nox | emacs22 | emacs21-nox | emacs21,
55         vim-scripts, vim-addon-manager
56         ,
57         at, uptimed,
58         puppet,
59                 libaugeas-ruby,
60                 libaugeas-ruby1.8,
61                 libaugeas0,
62                 augeas-lenses (>= 0.7),
63         dlocate
64         ,
65         dsa-nagios-checks
66         ,
67         munin-plugins-extra
68         ,
69         dmidecode [amd64 i386 ia64],
70         edac-utils,
71         sg3-utils
72         ,
73         ipython
74         ,
75         mcelog [amd64 i386]
76         ,
77         htop, psmisc,
78         ,
79         ncdu,
80         mc,
81                 genisoimage,
82         less,
83         rsync,
84         screen,
85         tmux,
86         ldap-utils, ldapvi,
87         mmv,
88         moreutils,
89         patchutils,
90         diffstat,
91         bc,
92         netcat-openbsd, socat, telnet
93         ,
94         deborphan
95         ,
96         file
97         ,
98         buffer
99         ,
100         bsd-mailx
101         ,
102         timeout | coreutils (>= 8.0-1)
103         ,
104         wget, curl, lftp, ftp,
105         ,
106         dput
107         ,
108         uuid-runtime
109         ,
110         finger
111         ,
112         xz-utils,
113         pigz,
114         unzip
115         ,
116         w3m,
117         elinks,
118         mutt
119         ,
120         ccze,
121         multitail
122 Description: metapackage to pull in recommended, but not essential tools
123  This package depends on packages that are recommended to  be installed on
124  every debian.org host but are not essential.
125
126 Package: debian.org-bugs.debian.org
127 Architecture: all
128 Depends: graphviz,
129         libcgi-simple-perl,
130         libgravatar-url-perl,
131         libio-stringy-perl,
132         liblist-moreutils-perl,
133         libmail-rfc822-address-perl,
134         libmime-tools-perl,
135         libmldbm-perl,
136         libparams-validate-perl,
137         libsafe-hole-perl,
138         libtext-template-perl,
139         liburi-perl,
140         libhtml-tree-perl,
141         libsoap-lite-perl,
142         libtext-iconv-perl,
143         libdbd-pg-perl,
144         libfile-libmagic-perl,
145         libnet-dns-sec-perl,
146         python-pyinotify,
147         python-yaml,
148 # contributors.debian.org's data mining
149         python3-requests,
150         python3-debian,
151         python3-six
152 Description: metapackages for bugs.debian.org dependencies
153  This package depends on everything that is needed for a bugs.debian.org
154  mirror or (in the future) bugs-master.
155
156 Package: debian.org-bugs.debian.org-master
157 Architecture: all
158 Depends: debian.org-bugs.debian.org,
159         gnuplot,
160         ttf-liberation,
161         kgb-client-git,
162         lynx    
163 Description: metapackages for bugs-master.debian.org dependencies
164  This package depends on everything that is needed for a
165  bugs-master.debian.org
166
167 Package: debian.org-bugs.debian.org-search
168 Architecture: all
169 Depends: debian.org-bugs.debian.org,
170         hyperestraier,
171         libdate-manip-perl,
172         libsearch-estraier-perl
173 Description: metapackages for bugs-search.debian.org dependencies
174  This package depends on everything that is needed for a
175  bugs-search.debian.org
176
177 Package: debian.org-bugs.debian.org-mx
178 Architecture: all
179 Depends: debian.org-bugs.debian.org,
180         spamassassin,
181         build-essential,
182         spamc,
183         libmail-spf-perl,
184         re2c,
185         libsys-syslog-perl,
186         libio-socket-inet6-perl,
187         libnet-ident-perl,
188         libdbi-perl,
189         pyzor,
190         libmail-dkim-perl,
191         libdbd-pg-perl
192 Description: metapackages for bugs.debian.org mail exchanger
193  This package depends on everything that is needed for a bugs.debian.org
194  MX.
195
196
197 Package: debian.org-packages-master.debian.org
198 Architecture: all
199 Depends: debian.org-packages.debian.org,
200         procmail,
201         gettext,
202         libhtml-template-perl,
203         libxml-rss-perl,
204         libtimedate-perl,
205         libio-stringy-perl,
206         freecdb,
207         tig
208 Description: metapackages for packages.debian.org dependencies
209  This package depends on everything that is needed for a
210  packages-master.debian.org server.  For the mirrors all you need is the
211  debian.org-packages.debian.org package.
212
213 Package: debian.org-packages.debian.org
214 Architecture: all
215 Depends: liblocale-maketext-lexicon-perl,
216         libi18n-acceptlanguage-perl,
217         libnumber-format-perl,
218         libcompress-zlib-perl,
219         libhtml-parser-perl,
220         libmldbm-perl,
221         libtext-iconv-perl,
222         libclass-accessor-perl,
223         liburi-perl,
224         libtemplate-perl,
225         liblingua-stem-perl,
226         libsearch-xapian-perl,
227         libtimedate-perl,
228         libcgi-fast-perl,
229         libapache2-mod-fcgid,
230         dpkg-dev,
231         rsync
232 Description: metapackages for packages.debian.org dependencies
233  This package depends on everything that is needed for a packages.debian.org
234  mirror.  For packages-master install the debian.org-packages-master.debian.org
235  package.
236
237 Package: debian.org-www-master.debian.org
238 Architecture: all
239 Depends: debiandoc-sgml,
240         asciidoc,
241         cm-super,
242         debhelper,
243         docbook,
244         docbook-dsssl,
245         docbook-utils,
246         docbook-xsl,
247         dpkg-dev,
248         fonts-arphic-uming,
249         fonts-mlym,
250         gawk (>= 1:4.0.1),
251         gettext,
252         ghostscript,
253         imagemagick,
254         iso-codes,
255         isoquery,
256         jadetex,
257         kcc,
258         ko.tex-base,
259         latex-cjk-all,
260         latex-cjk-chinese,
261         ldap-utils,
262         libcgi-pm-perl,
263         libemail-address-perl,
264         libintl-perl,
265         libmime-lite-perl,
266         libnet-ldap-perl,
267         libsoap-lite-perl,
268         libtimedate-perl,
269         libwww-perl,
270         libxml2-utils,
271         libxml-rss-perl,
272         locales, locales-all,
273         lmodern,
274         maildrop,
275         opencc,
276         openjade,
277         openjade1.3,
278         po4a,
279         poxml,
280         procmail,
281         texlive-fonts-recommended,
282         texlive-lang-all,
283         latex-cjk-japanese,
284         texlive-latex-base,
285         texlive-latex-extra,
286         texlive-latex-recommended,
287         tidy,
288         time,
289         uni2ascii,
290         wml,
291         xmlroff, dblatex,
292         xplanet,
293         xplanet-images,
294         xsltproc,
295         libjson-perl,
296 Description: metapackages for www-master.debian.org dependencies
297  This package depends on everything that is needed for a www-master.debian.org.
298
299
300 Package: debian.org-buildd.debian.org
301 Architecture: all
302 Depends:
303         dose-builddebcheck,
304         dose-distcheck,
305         edos-distcheck,
306         ghostscript,
307         libcompress-bzip2-perl,
308         libcompress-zlib-perl,
309         libhash-merge-perl,
310         libmailtools-perl,
311         libdbi-perl,
312         libdbd-pg-perl,
313         libfile-spec-perl,
314         libstring-escape-perl,
315         libstring-format-perl,
316         libyaml-tiny-perl,
317         python-apt,
318         python-contract,
319         python-coverage,
320         python-debian,
321         python-psycopg2,
322         python-mako,
323         python-nose,
324         python-sqlalchemy,
325         r-base-core,
326         r-cran-lattice,
327         moreutils (>= 0.39~),
328         libdpkg-perl,
329         php5,
330         php5-cgi,
331         php5-pgsql,
332         libapache2-mod-fcgid,
333         libgmp10,
334         libyaml-libyaml-perl
335 Description: metapackages for buildd.debian.org dependencies
336  This package depends on everything that is needed for a buildd.debian.org.
337
338
339 Package: debian.org-patch-tracker.debian.org
340 Architecture: all
341 Depends: patchutils,
342         python,
343         python-cheetah,
344         python-pygments,
345         python-debian,
346         reprepro,
347         python-wsgiref,
348         python-simplejson,
349         python-pysqlite2,
350         diffstat
351 Description: metapackages for patch-tracker.debian.org dependencies
352  This package depends on everything that is needed for a patch-tracker.debian.org.
353
354 Package: debian.org-planet.debian.org
355 Architecture: all
356 Depends: libwww-perl,
357         timeout | coreutils (>= 8.0-1),
358         debianutils,
359         python-django,
360         python,
361         libdbi-perl, libdate-manip-perl, libdbd-sqlite3-perl
362 Description: metapackages for planet.debian.org dependencies
363  This package depends on everything that is needed for a planet.debian.org.
364
365 Package: debian.org-security-tracker.debian.org
366 Architecture: all
367 Depends: libdbd-sqlite3-perl,
368         sqlite3,
369         python-apsw,
370         libterm-readline-gnu-perl,
371         python-apt,
372         python-soappy
373 Description: metapackages for security-tracker.debian.org dependencies
374  This package depends on everything that is needed for a security-tracker.debian.org.
375
376 Package: debian.org-ftpmaster.debian.org
377 Architecture: all
378 Depends: apt-utils,
379         libapt-pkg-dev,
380         libemail-sender-perl,
381         libcgi-pm-perl,
382         python-apt,
383         python-debianbts (>= 1.4~bpo50+1),
384         lintian,
385         python,
386         python-debian,
387         python-ldap,
388         python-psycopg2,
389         python-pygresql,
390         python-pyrss2gen,
391         python-yaml,
392         python-rrdtool,
393         python-sqlalchemy,
394         binutils-multiarch,
395         build-essential,
396         graphviz,
397         ikiwiki,
398         libdbd-pg-ruby,
399         python-epydoc,
400         python-numpy,
401         python-soappy,
402         r-base,
403         symlinks,
404         python-magic,
405         unp,
406         procmail,
407         cvs,
408         ruby,
409         lynx,
410         libxml-rss-perl,
411         ghostscript,
412         perforate,
413         wdiff,
414         ruby-soap4r
415 Description: metapackage for ftpmaster
416  This package depends on everything that is needed for an ftpmaster setup.
417
418 Package: debian.org-ftpmaster.debian.org-poneys
419 Architecture: all
420 Depends: bicyclerepair,
421         dpkg-dev-el,
422         emacs-goodies-el,
423         pychecker,
424         pylint,
425         python-mode,
426         gitstats,
427         colordiff
428 Description: metapackage for ftpmaster extras
429  Things not really needed needed.
430
431 Package: debian.org-release.debian.org
432 Architecture: all
433 Depends:
434         dose-distcheck,
435         dose-builddebcheck,
436         mutt,
437         subversion,
438         python2.7,
439         python2.7-dev,
440         python-dev,
441         wdiff,
442         python-pygresql,
443         python-libxslt1,
444         python-apt,
445         python-debian,
446         python-six,
447         libapt-pkg-perl,
448         libapt-pkg-dev,
449         dpkg-dev,
450         procmail,
451         rrdtool,
452         python3-apt,
453         python3-debian,
454         python3-six,
455         python3-yaml,
456         picosat,
457         git-email,
458         python-networkx,
459         python-pygraphviz,
460         python-yaml,
461         postgresql-client,
462 Description: metapackage for release
463  This package depends on everything that is needed for a release.debian.org
464  setup.
465
466 Package: debian.org-cdbuilder.debian.org
467 Architecture: all
468 Depends: bittornado,
469         build-essential,
470         debhelper,
471         debian-cd,
472         jigit,
473         m4,
474         tofrodos,
475         zip,
476         zsync,
477         fakeroot,
478         dosfstools,
479         libsoap-lite-perl,
480         mtools
481 Description: metapackage for cdbuilder
482  This package depends on all the packages that are needed for a cdbuilder setup.
483
484 Package: debian.org-cdimage-search.debian.org
485 Architecture: all
486 Depends: libconfigreader-simple-perl
487 Description: metapackage for cdimage-search.debian.org
488  This package depends on all the packages that are needed for the CD/DVD search CGI website
489
490 Package: debian.org-manpages.debian.org
491 Architecture: all
492 Depends: locales-all,
493         ghostscript
494 Description: metapackage for manpages
495  This package depends on all the packages that are needed for manpages.d.o setup.
496
497 Package: debian.org-nm.debian.org
498 Architecture: all
499 Depends: libapache2-mod-wsgi,
500         mutt, mboxgrep,
501         python,
502         python-mako (>= 0.2.5), python-ldap,
503         python-apt, python-beautifulsoup, python-debianbts, python-dns,
504         python-dnspython, python-egenix-mxdatetime, python-egenix-mxtools,
505         python-elementtree | python (>= 2.6), python-flup, python-libxml2,
506         python-lxml, python-psycopg2, python-soappy,
507         python-xapian,
508         python-dateutil,
509         python-debian,
510         python-django (>= 1.8),
511         python-django-south,
512         python-debiancontributors,
513         python-tz,
514         python-markdown,
515         python-lzma,
516         python-requests (>= 2.0.0),
517         python3-requests,
518         python3-psycopg2,
519         procmail,
520         rrdtool,
521         moreutils,
522         libjs-jquery,
523         postgresql-client
524 Description: metapackage for nm.debian.org
525  This package depends on all the packages that are needed for nm.debian.org setup.
526
527 Package: debian.org-backports.debian.org
528 Architecture: all
529 Depends: debian.org-ftpmaster.debian.org,
530         libdbi-perl, libdbd-pg-perl
531 Description: metapackage for backports.debian.org
532  This package depends on all the packages that are needed for backports.debian.org setup.
533
534 Package: debian.org-qa.debian.org
535 Architecture: all
536 Depends: db-util,
537         devscripts (>= 2.15.9~),
538         gnuplot-nox,
539         wml,
540         libapt-pkg-perl,
541                 libcgi-pm-perl,
542                 libdbd-pg-perl,
543                 libdate-manip-perl,
544                 libdpkg-perl,
545                 libmailtools-perl,
546                 libsoap-lite-perl,
547                 libtemplate-perl,
548                 libxml-simple-perl,
549                 libmail-sendmail-perl,
550                 libdate-calc-perl,
551                 libnet-ldap-perl,
552                 libjson-perl,
553                 libyaml-syck-perl,
554         php5, php5-cgi, php5-cli,
555                 php5-ldap, php5-pgsql,
556                 libapache2-mod-fcgid,
557         python-apt, python-psycopg2, python-gpgme,
558         python3, python3-psycopg2,
559         postgresql-client,
560         libdbd-pg-ruby,
561         rrdtool,
562         raptor-utils | raptor2-utils,
563         dose-distcheck, dose-builddebcheck, python3-yaml, python3-debian
564 Description: metapackage for qa.debian.org
565  This package depends on all the packages that are needed for qa.debian.org setup.
566
567 Package: debian.org-packages.qa.debian.org
568 Architecture: all
569 Depends: db4.7-util,
570         libio-compress-perl,
571         libio-compress-lzma-perl,
572         libmailtools-perl,
573         libmime-tools-perl,
574         libmail-verp-perl,
575         xsltproc,
576         mhonarc,
577         python,
578         python-lxml,
579         python-soappy,
580         python-debian,
581         python-yaml,
582         python-zsi
583 Description: metapackage for packages.qa.debian.org
584  This package depends on all the packages that are needed for packages.qa.debian.org setup.
585
586 Package: debian.org-tracker.debian.org
587 Architecture: all
588 Depends:
589 # Runtime
590         daemon,
591         libapache2-mod-wsgi,
592         python-apt,
593         python-bs4,
594         python-debian,
595         python-django (>= 1.8),
596         python-django-jsonfield,
597         python-gpgme,
598         python-ldap,
599         python-lzma,
600         python-requests (>= 2),
601         python-soappy,
602         python-yaml,
603         python-pyinotify,
604         dpkg-dev,
605 # Database access
606         python-psycopg2,
607         postgresql-client,
608 # Test suite and docs
609         python-mock,
610         python-sphinx,
611 Description: metapackage for tracker.debian.org
612  This package depends on all the packages that are needed for tracker.debian.org.
613
614 Package: debian.org-udd.debian.org
615 Architecture: all
616 Depends: curl,
617         dpkg-dev,
618         graphviz,
619         libapt-pkg-dev,
620         libcrypt-ssleay-perl,
621         libcgi-simple-perl,
622         libdbd-pg-perl,
623         libdbd-pg-ruby,
624         libdbi-perl,
625         libdbi-ruby,
626         libdpkg-ruby,
627         libio-stringy-perl,
628         liblist-moreutils-perl,
629         libmime-tools-perl,
630         libmldbm-perl,
631         libparams-validate-perl,
632         libperl-dev,
633         libsafe-hole-perl,
634         libtext-template-perl,
635         libyaml-syck-perl,
636         postgresql-autodoc,
637         python-dateutil,
638         python-debian,
639         python-dev,
640         python-launchpadlib,
641         python-psycopg2,
642         python-yaml,
643         ruby-json,
644         ruby-oj,
645         vpim
646 Description: metapackage for udd.debian.org
647  This package depends on all the packages that are needed for udd.debian.org setup.
648
649 Package: debian.org-snapshot.debian.org
650 Architecture: all
651 Depends:
652         ruby,
653         ruby-dbd-pg,
654         python-yaml, python-psycopg2, python-lockfile, python-fuse, uuid-runtime,
655         python-dev, gcc,
656         python-pylons
657 Description: metapackage for snapshot.debian.org
658  This package depends on all the packages that are needed for snapshot.debian.org setup.
659
660 Package: debian.org-women.debian.org
661 Architecture: all
662 Depends: wml
663 Description: metapackages for women.debian.org dependencies
664  This package depends on everything that is needed for women.debian.org.
665
666
667 Package: debian.org-lintian.debian.org
668 Architecture: all
669 Depends:   binutils,
670         binutils-multiarch,
671         bzip2,
672         diffstat,
673         dpkg-dev,
674         debhelper,
675         fakeroot,
676         file,
677         gettext,
678         gnuplot-nox | gnuplot,
679         hardening-includes (>= 2.2~),
680         intltool-debian,
681         libapt-pkg-perl,
682         libarchive-zip-perl,
683         libclass-accessor-perl,
684         libclone-perl,
685         libdata-alias-perl,
686         libdigest-sha-perl,
687         libdpkg-perl,
688         libemail-valid-perl,
689         libfile-basedir-perl,
690         libhtml-parser-perl,
691         libipc-run-perl,
692         liblist-moreutils-perl,
693         libparse-debianchangelog-perl,
694         libperlio-gzip-perl,
695         libtimedate-perl,
696         libtext-levenshtein-perl,
697         libtext-template-perl,
698         liburi-perl,
699         libyaml-libyaml-perl,
700         locales,
701         man-db,
702         perl,
703         perl (>= 5.14~) | libautodie-perl (>= 2.10~),
704         t1utils,
705         unzip
706         ,
707         docbook-utils,
708         docbook-xml
709         ,
710 Description: metapackages for lintian.debian.org dependencies
711  This package depends on everything that is needed for lintian.debian.org.
712
713 Package: debian.org-popcon.debian.org
714 Architecture: all
715 Depends:
716         libchart-perl,
717         libcgi-pm-perl
718 Description: metapackages for popcon.debian.org dependencies
719  This package depends on everything that is needed for popcon.debian.org.
720
721 Package: debian.org-dde.debian.net
722 Architecture: all
723 Depends: python-apt,
724         python-debian,
725         python-debianbts,
726         python-feedparser,
727         python-flup,
728         python-nose,
729         python-paste,
730         python-psycopg2,
731         python-pyrss2gen,
732         python-soappy,
733         python-werkzeug,
734         python-xapian,
735         python-yaml
736 Description: metapackages for dde.debian.net dependencies
737  This package depends on everything that is needed for dde.debian.net.
738
739 Package: debian.org-debtags.debian.org
740 Architecture: all
741 Depends: python-apt,
742         python-debian,
743         python-django,
744         python-xapian (>= 1.2.7-1~bpo60+1),
745         python-psycopg2,
746         python-debiancontributors,
747         python-six,
748         postgresql-client,
749         g++,
750         libapt-pkg-dev
751 Description: metapackages for debtags.debian.org dependencies
752  This package depends on everything that is needed for debtags.debian.org.
753
754 Package: debian.org-sso.debian.org
755 Architecture: all
756 Depends: libcatalyst-modules-perl,
757         libcatalyst-engine-apache-perl,
758         libapache2-mod-perl2,
759         libapache2-reload-perl,
760         libcatalyst-devel-perl,
761         libhtml-mason-perl,
762         python3-requests,
763         python-django (>= 1.7),
764         python-lockfile,
765         gnutls-bin
766 Description: metapackages for sso.debian.org dependencies
767  This package depends on everything that is needed for sso.debian.org.
768
769 Package: debian.org-lists.debian.org
770 Architecture: all
771 Depends: xapian-tools,
772         xapian-omega,
773         smartlist,
774         procmail,
775         gnuplot,
776         rrdtool,
777         libdpkg-perl,
778         gettext,
779         grepmail,
780         libcompress-raw-zlib-perl,
781         libgcrypt20-dev,
782         libmoose-perl,
783         libnet-oauth2-perl,
784         carton,
785         amavisd-new,
786         amavis-lists,
787         zoo,
788         lha,
789         p7zip,
790         unrar-free,
791         ripole,
792         pfqueue,
793         pyzor,
794         razor,
795         mrtgutils,
796         pax,
797         pwgen,
798         rbldnsd,
799         rng-tools,
800         speedy-cgi-perl,
801         ccze,
802         pflogsumm
803 Description: metapackages for lists.debian.org dependencies
804  This package depends on everything that is needed for lists.debian.org.
805
806 Package: debian.org-ddtp.debian.org
807 Architecture: all
808 Depends: libalgorithm-diff-xs-perl,
809         libdbd-pg-perl,
810         libdbi-perl,
811         libmail-sender-perl,
812         libmime-tools-perl,
813         libtext-diff-perl,
814         libtext-iconv-perl
815         ,
816         gnuplot
817         ,
818         libapache2-mod-wsgi,
819         python-setuptools,
820         python-psycopg2,
821         python-django,
822         python-sqlalchemy
823         ,
824         tig,
825         postgresql-client-9.1
826 Description: metapackages for ddtp.debian.org dependencies
827  This package depends on everything that is needed for ddtp.debian.org.
828
829 Package: debian.org-i18n.debian.org
830 Architecture: all
831 Depends: gettext,
832         po-debconf
833         ,
834         liblocale-gettext-perl,
835         libmailtools-perl,
836         libsoap-lite-perl,
837         libtimedate-perl
838         ,
839         tig,
840         rrdtool
841 Description: metapackages for i18n.debian.org dependencies
842  This package depends on everything that is needed for i18n.debian.org.
843
844 Package: debian.org-l10n.debian.org
845 Architecture: all
846 Depends: gettext,
847         po-debconf
848         ,
849         liblocale-gettext-perl,
850         libmailtools-perl,
851         libsoap-lite-perl,
852         libtimedate-perl
853         ,
854         tig,
855         rrdtool
856 Description: metapackages for l10n.debian.org dependencies
857  This package depends on everything that is needed for l10n.debian.org.
858
859 Package: debian.org-piuparts-master.debian.org
860 Architecture: all
861 Depends: debhelper,
862         asciidoc,
863         git,
864         xmlto,
865         python-debianbts,
866         apache2,
867         ghostscript,
868         python-rpy2,
869         r-base-dev,
870         r-recommended,
871         tango-icon-theme,
872         screen,
873         python-apt,
874         python-distro-info,
875         python-lzma,
876         python-yaml,
877         libsoap-lite-perl
878 Description: metapackage for piuparts-master.debian.org
879  This package depends on all the packages that are needed for the
880  master in the piuparts.debian.org setup.
881
882 Package: debian.org-piuparts-slave.debian.org
883 Architecture: all
884 Depends: debhelper,
885         asciidoc,
886         git,
887         xmlto,
888         debootstrap (>= 1.0.60~bpo70),
889         debsums,
890         lsb-release,
891         screen,
892         python-debian,
893         python-apt,
894         python-distro-info,
895         python-lzma,
896         adequate
897 Description: metapackage for piuparts-slave.debian.org
898  This package depends on all the packages that are needed for the
899  slaves in the piuparts.debian.org setup.
900
901 Package: debian.org-wiki.debian.org
902 Architecture: all
903 Depends: libapache2-mod-wsgi,
904         libcgi-pm-perl,
905         libjson-perl,
906         python-moinmoin (>= 1.9.7-2~bpo7+1),
907         python-launchpadlib,
908         libsoap-lite-perl,
909         python-docutils
910 Description: metapackage for wiki.debian.org
911  This package depends on all the packages that are needed for the Debian wiki
912
913 Package: debian.org-vote.debian.org
914 Architecture: all
915 Depends: libparse-recdescent-perl,
916         libmime-tools-perl,
917         libnet-ldap-perl,
918         libgnupg-interface-perl,
919         libmail-gnupg-perl,
920         graphviz
921 Description: metapackage for vote.debian.org
922  This package depends on all the packages that are needed for DeVoteE
923
924 Package: debian.org-bits.debian.org
925 Architecture: all
926 Depends: pelican
927 Description: metapackage for bits.debian.org
928  This package depends on all the packages that are needed for the Debian
929  blog bits.debian.org
930
931 Package: debian.org-d-i.debian.org
932 Architecture: all
933 Depends: gnuplot,
934         libdate-manip-perl,
935         libemail-mime-perl,
936         libemail-sender-perl,
937         libfile-slurp-perl,
938         libgd-graph-perl,
939         libhtml-template-perl,
940         liblist-moreutils-perl,
941         libsort-versions-perl,
942         mr,
943         gettext,
944         graphviz,
945         fonts-liberation,
946         edos-distcheck,
947         liburi-perl,
948         edos-distcheck,
949         aspell,
950         libunicode-string-perl,
951         libxml-libxml-perl,
952 # Taken from d-i's manual (src:installation-guide)'s build-deps:
953         docbook,
954         docbook-xml,
955         docbook-xsl,
956         xsltproc,
957         gawk,
958         libhtml-parser-perl,
959         w3m,
960         poxml,
961         jadetex,
962         openjade | openjade1.3,
963         docbook-dsssl,
964         ghostscript,
965         texlive-lang-cyrillic,
966         texlive-lang-czechslovak,
967         texlive-lang-french,
968         texlive-lang-german,
969         texlive-lang-greek,
970         texlive-lang-italian,
971         texlive-lang-other,
972         texlive-lang-portuguese,
973         texlive-lang-spanish,
974         ko.tex-base,
975         cm-super,
976         po-debconf
977 Description: metapackage for d-i.debian.org
978  This package depends on all the packages that are needed for the
979  d-i.debian.org setup.
980
981 Package: debian.org-codesearch.debian.org
982 Architecture: all
983 Depends: dpkg-dev,
984         postgresql-client
985 Description: metapackage for codesearch.debian.org
986  This package depends on all the packages that are needed for the codesearch
987  setup.
988
989 Package: debian.org-dedup.debian.net
990 Architecture: all
991 Depends: curl,
992         python,
993         python-concurrent.futures,
994         python-debian,
995         python-imaging,
996         python-jinja2,
997         python-lzma,
998         python-pkg-resources,
999         python-werkzeug,
1000         python-yaml,
1001         python-sqlalchemy,
1002         python-ssdeep | base-files (<< 8),
1003         sqlite3
1004 Description: metapackage for dedup.debian.net
1005  This package depends on all packages that are required for operating the
1006  Debian duplication detector.
1007
1008 Package: debian.org-wnpp-by-tags.debian.net
1009 Architecture: all
1010 Depends: debtags, python-debian, python-beautifulsoup
1011 Description: metapackage for wnpp-by-tags.debian.net
1012  This package depends on all the packages that are needed for the wnpp-by-tags
1013  setup.
1014
1015 Package: debian.org-blends.debian.org
1016 Architecture: all
1017 Depends: python-genshi,
1018  python-markdown,
1019  python-docutils,
1020  python-debian,
1021  python-psutil,
1022  python-psycopg2,
1023  python-apt,
1024  python3-genshi,
1025  python3-markdown,
1026  python3-docutils,
1027  python3-debian,
1028  python3-psutil,
1029  python3-psycopg2,
1030  python3-apt,
1031  postgresql-client
1032 Description: metapackage for blends.debian.org
1033  This package depends on all the packages that are needed for the
1034  blends.debian.org setup.
1035
1036 Package: debian.org-pet.debian.net
1037 Architecture: all
1038 Depends: python-apt,
1039         python-argparse,
1040         python-debian,
1041         python-debianbts,
1042         python-inotifyx,
1043         python-paste,
1044         python-psycopg2,
1045         python-pyramid,
1046         python-sqlalchemy,
1047         python-subversion
1048 Description: metapackages for pet.debian.net dependencies
1049  This package depends on everything that is needed for the PET setup.
1050
1051 Package: debian.org-dsa.debian.org
1052 Architecture: all
1053 Depends: ikiwiki, libtext-wikicreole-perl, libtext-wikiformat-perl, libtext-multimarkdown-perl
1054 Description: metapackages for dsa.debian.org master dependencies
1055  This package depends on everything that is needed for the service
1056
1057 Package: debian.org-dns.debian.org
1058 Architecture: all
1059 Depends: perl-doc,
1060         nagios-nrpe-plugin,
1061         sqlite3,
1062         libdata-compare-perl,
1063         libnet-dns-perl,
1064         libnet-dns-sec-perl,
1065         python-dnspython,
1066         python-yaml,
1067         letsencrypt.sh,
1068 Description: metapackages for dns.debian.org master dependencies
1069  This package depends on everything that is needed for the service
1070
1071 Package: debian.org-nagios.debian.org
1072 Architecture: all
1073 Depends: icinga
1074 Description: metapackages for nagios.debian.org master dependencies
1075  This package depends on everything that is needed for the service and
1076  also provides the dpkg-diverts for the REMOTE_USER hack
1077
1078 Package: debian.org-deriv.debian.net
1079 Architecture: all
1080 Depends: python,
1081         python-apt,
1082         python-debian,
1083         python-imaging,
1084         python-psycopg2,
1085         python-requests,
1086         python-simplejson,
1087         python-yaml,
1088         libxml-feed-perl,
1089         apt-transport-https,
1090         dpkg-dev,
1091         patchutils,
1092         rsync,
1093         curl,
1094         make,
1095         lzip,
1096 Homepage: https://wiki.debian.org/Derivatives/Integration#Patches
1097 Description: metapackage for the derivatives census patch generation
1098  This package depends on everything that is needed for the service
1099
1100 Package: debian.org-httpredir.debian.org
1101 Architecture: all
1102 Depends: inoticoming,
1103         libanyevent-perl,
1104         libanyevent-http-perl,
1105         libev-perl,
1106         libtimedate-perl,
1107         libgeo-ip-perl,
1108         libwww-perl,
1109         liburi-perl,
1110         libplack-perl,
1111         starman
1112 Description: metapackage for http-redirector dependencies
1113  This package depends on everything that is needed for an instance of
1114  the http-redirector.
1115
1116 Package: debian.org-search.debian.org
1117 Architecture: all
1118 Depends: xapian-omega
1119 Description: metapackage for search.debian.org dependencies
1120  This package depends on everything that is needed for an instance of
1121  the www search engine (aka search.debian.org).
1122
1123 Package: debian.org-dgit.debian.org
1124 Architecture: all
1125 Depends: perl,
1126         libwww-perl,
1127         libdpkg-perl,
1128         git,
1129         devscripts,
1130         dpkg-dev,
1131         libdigest-sha-perl,
1132         dput,
1133         curl,
1134         libjson-perl,
1135         gpgv,
1136         chiark-utils-bin,
1137         libdbd-sqlite3-perl,
1138         sqlite3
1139 Description: metapackage for dgit.debian.org dependencies
1140  This package depends on everything that is needed for an instance of
1141  the dgit git server (aka dgit.debian.org).
1142  .
1143  (This is actually simply the dependencies of the dgit and
1144  dgit-infrastructure binary packages, but due to chicken-and-egg
1145  problems and for ease of maintenance we are running the dgit
1146  infrastructure out of a git tree.)
1147
1148 Package: debian.org-appstream.debian.org
1149 Architecture: all
1150 Depends: gir1.2-rsvg-2.0,
1151         python3-apt,
1152         python3-cairo,
1153         python3-gi,
1154         python3-gi-cairo,
1155         python3-jinja2,
1156         python3-lmdb,
1157         python3-lxml,
1158         python3-matplotlib,
1159         python3-pil,
1160         python3-pygments,
1161         python3-voluptuous,
1162         python3-yaml
1163 Description: metapackage for appstream.debian.org dependencies
1164  This package depends on everything that is needed for an instance of
1165  the DEP-11/AppStream metadata extractor.
1166
1167 Package: debian.org-debian-r.debian.org
1168 Architecture: all
1169 Depends: debian.org-ftpmaster.debian.org
1170 Description: metapackage for debian-r.debian.org dependencies
1171  This package depends on everything that is needed for the debian-r
1172  archive software (which is generally everything that is required by
1173  ftpmaster.debian.org).
1174
1175 Package: debian.org-ftpmaster.debian-ports.org
1176 Architecture: all
1177 Depends: apt-utils,
1178         git,
1179         gnupg
1180         python,
1181         python-debian,
1182         procmail,
1183         wget
1184 Description: metapackage for debian-ports ftpmaster
1185  This package depends on everything that is needed for a debian-ports
1186  ftpmaster setup (using mini-dak).