91a3be6cee3db65fcd8f5294bd10ef6a1602b9c8
[debian.org.git] / debian / control
1 Source: debian.org
2 Section: local/admin
3 Priority: required
4 Maintainer: Debian sysadmin Team <debian-admin@debian.org>
5 Uploaders: Peter Palfrader <weasel@debian.org>, Martin Zobel-Helas <zobel@debian.org>, Stephen Gran <sgran@debian.org>, Luca Filipozzi <lfilipoz@debian.org>
6 Build-Depends: debhelper (>= 7)
7 Standards-Version: 3.8.1
8
9 Package: debian.org
10 Architecture: all
11 Depends: userdir-ldap, zsh, tcsh, pdksh, ksh, csh, ntp, locales-all, exim4-daemon-heavy | postfix, sudo, libpam-pwdfile, vim, nano, munin-node, gnupg, bzip2, cacert-spi | ca-certificates (>> 20080411), ed, cron, dialog, libterm-readline-gnu-perl, logrotate, syslog-ng (>= 3.1), nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic
12 Recommends: debian.org-recommended
13 Conflicts: dchroot-dsa (<= 2:1)
14 Description: DSA's host metapackage
15  This package depends on packages that should be installed on every
16  debian.org host, and conflicts with packages that should never be
17  installed.
18
19 Package: debian.org-recommended-linux
20 Architecture: all
21 Depends: vlan, ifenslave, bridge-utils, iproute,
22         strace,
23         lsscsi,
24         ethtool,
25         bwm-ng,
26         iputils-tracepath,
27         traceroute,
28         lshw,
29         lsof
30 Description: metapackage to pull in recommended, but not essential tools for linux system
31  This package depends on packages that are recommended to  be installed on
32  every Linux debian.org host but are not essential.
33
34 Package: debian.org-recommended
35 Architecture: any
36 Depends: debian.org,
37         busybox-static,
38         debian.org-recommended-linux [linux-any],
39         molly-guard
40         ,
41         man-db
42         ,
43         devscripts
44         ,
45         subversion, rcs, git, bzr,
46                 git-svn,
47                 subversion-tools,
48                 mercurial,
49                 cvs
50         ,
51         mtr-tiny, tcpdump, tcptraceroute, ndisc6,
52         bind9-host, dnsutils, whois, unbound-host
53         ,
54         emacs24-nox | emacs24 | emacs23-nox | emacs23 | emacs22-nox | emacs22 | emacs21-nox | emacs21,
55         vim-scripts, vim-addon-manager
56         ,
57         at, uptimed,
58         puppet,
59                 libaugeas-ruby,
60                 libaugeas-ruby1.8,
61                 libaugeas0,
62                 augeas-lenses (>= 0.7),
63         locate, dlocate
64         ,
65         dsa-nagios-checks
66         ,
67         munin-plugins-extra
68         ,
69         dmidecode [amd64 i386 ia64],
70         edac-utils,
71         sg3-utils
72         ,
73         ipython
74         ,
75         mcelog [amd64 i386]
76         ,
77         htop, psmisc,
78         ,
79         ncdu,
80         mc,
81                 genisoimage,
82         less,
83         rsync,
84         screen,
85         tmux,
86         ldap-utils, ldapvi,
87         mmv,
88         moreutils,
89         patchutils,
90         diffstat,
91         bc,
92         netcat-openbsd, socat, telnet
93         ,
94         deborphan
95         ,
96         file
97         ,
98         buffer
99         ,
100         bsd-mailx
101         ,
102         timeout | coreutils (>= 8.0-1)
103         ,
104         wget, curl, lftp, ftp,
105         ,
106         dput
107         ,
108         uuid-runtime
109         ,
110         finger
111         ,
112         xz-utils,
113         pigz,
114         unzip
115         ,
116         w3m,
117         elinks,
118         mutt
119         ,
120         ccze,
121         multitail
122 Description: metapackage to pull in recommended, but not essential tools
123  This package depends on packages that are recommended to  be installed on
124  every debian.org host but are not essential.
125
126 Package: debian.org-bugs.debian.org
127 Architecture: all
128 Depends: graphviz,
129         libcgi-simple-perl,
130         libgravatar-url-perl,
131         libio-stringy-perl,
132         liblist-moreutils-perl,
133         libmail-rfc822-address-perl,
134         libmime-tools-perl,
135         libmldbm-perl,
136         libparams-validate-perl,
137         libsafe-hole-perl,
138         libtext-template-perl,
139         liburi-perl,
140         libhtml-tree-perl,
141         libsoap-lite-perl,
142         libtext-iconv-perl,
143         libdbd-pg-perl,
144         libfile-libmagic-perl,
145         libnet-dns-sec-perl,
146         python-pyinotify,
147         python-yaml
148 Description: metapackages for bugs.debian.org dependencies
149  This package depends on everything that is needed for a bugs.debian.org
150  mirror or (in the future) bugs-master.
151
152 Package: debian.org-bugs.debian.org-master
153 Architecture: all
154 Depends: debian.org-bugs.debian.org,
155         gnuplot,
156         ttf-liberation,
157         kgb-client-git,
158         lynx    
159 Description: metapackages for bugs-master.debian.org dependencies
160  This package depends on everything that is needed for a
161  bugs-master.debian.org
162
163 Package: debian.org-bugs.debian.org-search
164 Architecture: all
165 Depends: debian.org-bugs.debian.org,
166         hyperestraier,
167         libdate-manip-perl,
168         libsearch-estraier-perl
169 Description: metapackages for bugs-search.debian.org dependencies
170  This package depends on everything that is needed for a
171  bugs-search.debian.org
172
173 Package: debian.org-bugs.debian.org-mx
174 Architecture: all
175 Depends: debian.org-bugs.debian.org,
176         spamassassin,
177         build-essential,
178         spamc,
179         libmail-spf-perl,
180         re2c,
181         libsys-syslog-perl,
182         libio-socket-inet6-perl,
183         libnet-ident-perl,
184         libdbi-perl,
185         pyzor,
186         libmail-dkim-perl,
187         libdbd-pg-perl
188 Description: metapackages for bugs.debian.org mail exchanger
189  This package depends on everything that is needed for a bugs.debian.org
190  MX.
191
192
193 Package: debian.org-packages-master.debian.org
194 Architecture: all
195 Depends: debian.org-packages.debian.org,
196         procmail,
197         gettext,
198         libhtml-template-perl,
199         libxml-rss-perl,
200         libtimedate-perl,
201         libio-stringy-perl,
202         freecdb,
203         tig
204 Description: metapackages for packages.debian.org dependencies
205  This package depends on everything that is needed for a
206  packages-master.debian.org server.  For the mirrors all you need is the
207  debian.org-packages.debian.org package.
208
209 Package: debian.org-packages.debian.org
210 Architecture: all
211 Depends: liblocale-maketext-lexicon-perl,
212         libi18n-acceptlanguage-perl,
213         libnumber-format-perl,
214         libcompress-zlib-perl,
215         libhtml-parser-perl,
216         libmldbm-perl,
217         libtext-iconv-perl,
218         libclass-accessor-perl,
219         liburi-perl,
220         libtemplate-perl,
221         liblingua-stem-perl,
222         libsearch-xapian-perl,
223         libtimedate-perl,
224         libcgi-fast-perl,
225         libapache2-mod-fcgid,
226         dpkg-dev,
227         rsync
228 Description: metapackages for packages.debian.org dependencies
229  This package depends on everything that is needed for a packages.debian.org
230  mirror.  For packages-master install the debian.org-packages-master.debian.org
231  package.
232
233 Package: debian.org-www-master.debian.org
234 Architecture: all
235 Depends: debiandoc-sgml,
236         asciidoc,
237         cm-super,
238         debhelper,
239         docbook,
240         docbook-dsssl,
241         docbook-xsl,
242         dpkg-dev,
243         fonts-arphic-uming,
244         fonts-mlym,
245         gawk (>= 1:4.0.1),
246         gettext,
247         ghostscript,
248         imagemagick,
249         iso-codes,
250         isoquery,
251         jadetex,
252         kcc,
253         ko.tex-base,
254         latex-cjk-all,
255         latex-cjk-chinese,
256         ldap-utils,
257         libemail-address-perl,
258         libintl-perl,
259         libmime-lite-perl,
260         libnet-ldap-perl,
261         libsoap-lite-perl,
262         libtimedate-perl,
263         libwww-perl,
264         libxml2-utils,
265         libxml-rss-perl,
266         locales, locales-all,
267         lmodern,
268         maildrop,
269         opencc,
270         openjade,
271         openjade1.3,
272         po4a,
273         poxml,
274         procmail,
275         texlive-fonts-recommended,
276         texlive-lang-all,
277         latex-cjk-japanese,
278         texlive-latex-base,
279         texlive-latex-extra,
280         texlive-latex-recommended,
281         tidy,
282         time,
283         uni2ascii,
284         wml,
285         xmlroff, dblatex,
286         xplanet,
287         xplanet-images,
288         xsltproc,
289         libjson-perl,
290 Description: metapackages for www-master.debian.org dependencies
291  This package depends on everything that is needed for a www-master.debian.org.
292
293
294 Package: debian.org-buildd.debian.org
295 Architecture: all
296 Depends:
297         dose-builddebcheck,
298         dose-distcheck,
299         edos-distcheck,
300         ghostscript,
301         libcompress-bzip2-perl,
302         libcompress-zlib-perl,
303         libhash-merge-perl,
304         libmailtools-perl,
305         libdbi-perl,
306         libdbd-pg-perl,
307         libfile-spec-perl,
308         libstring-escape-perl,
309         libstring-format-perl,
310         libyaml-tiny-perl,
311         python-apt,
312         python-contract,
313         python-coverage,
314         python-debian,
315         python-psycopg2,
316         python-mako,
317         python-nose,
318         python-sqlalchemy,
319         r-base-core,
320         r-cran-lattice,
321         moreutils (>= 0.39~),
322         libdpkg-perl,
323         php5,
324         php5-cgi,
325         php5-pgsql,
326         libapache2-mod-fcgid,
327         libgmp10,
328         libyaml-libyaml-perl
329 Description: metapackages for buildd.debian.org dependencies
330  This package depends on everything that is needed for a buildd.debian.org.
331
332
333 Package: debian.org-patch-tracker.debian.org
334 Architecture: all
335 Depends: patchutils,
336         python,
337         python-cheetah,
338         python-pygments,
339         python-debian,
340         reprepro,
341         python-wsgiref,
342         python-simplejson,
343         python-pysqlite2,
344         diffstat
345 Description: metapackages for patch-tracker.debian.org dependencies
346  This package depends on everything that is needed for a patch-tracker.debian.org.
347
348 Package: debian.org-planet.debian.org
349 Architecture: all
350 Depends: libwww-perl,
351         timeout | coreutils (>= 8.0-1),
352         debianutils,
353         python-django,
354         python,
355         libdbi-perl, libdate-manip-perl, libdbd-sqlite3-perl
356 Description: metapackages for planet.debian.org dependencies
357  This package depends on everything that is needed for a planet.debian.org.
358
359 Package: debian.org-security-tracker.debian.org
360 Architecture: all
361 Depends: libdbd-sqlite3-perl,
362         sqlite3,
363         python-apsw,
364         libterm-readline-gnu-perl,
365         python-apt,
366         python-soappy
367 Description: metapackages for security-tracker.debian.org dependencies
368  This package depends on everything that is needed for a security-tracker.debian.org.
369
370 Package: debian.org-ftpmaster.debian.org
371 Architecture: all
372 Depends: apt-utils,
373         libapt-pkg-dev,
374         libemail-sender-perl,
375         libcgi-pm-perl,
376         python-apt,
377         python-debianbts (>= 1.4~bpo50+1),
378         lintian,
379         python,
380         python-debian,
381         python-ldap,
382         python-psycopg2,
383         python-pygresql,
384         python-pyrss2gen,
385         python-yaml,
386         python-rrdtool,
387         python-sqlalchemy,
388         binutils-multiarch,
389         build-essential,
390         graphviz,
391         ikiwiki,
392         libdbd-pg-ruby,
393         python-epydoc,
394         python-numpy,
395         python-soappy,
396         r-base,
397         symlinks,
398         python-magic,
399         unp,
400         procmail,
401         cvs,
402         ruby,
403         lynx,
404         libxml-rss-perl,
405         ghostscript,
406         perforate,
407         wdiff,
408         ruby-soap4r
409 Description: metapackage for ftpmaster
410  This package depends on everything that is needed for an ftpmaster setup.
411
412 Package: debian.org-ftpmaster.debian.org-poneys
413 Architecture: all
414 Depends: bicyclerepair,
415         dpkg-dev-el,
416         emacs-goodies-el,
417         pychecker,
418         pylint,
419         python-mode,
420         gitstats,
421         colordiff
422 Description: metapackage for ftpmaster extras
423  Things not really needed needed.
424
425 Package: debian.org-release.debian.org
426 Architecture: all
427 Depends:
428         dose-distcheck,
429         dose-builddebcheck,
430         mutt,
431         subversion,
432         python2.7,
433         python2.7-dev,
434         python-dev,
435         wdiff,
436         python-pygresql,
437         python-libxslt1,
438         python-apt,
439         python-debian,
440         libapt-pkg-perl,
441         libapt-pkg-dev,
442         dpkg-dev,
443         procmail,
444         rrdtool,
445         python3-apt,
446         python3-yaml,
447         picosat,
448         git-email,
449         python-networkx,
450         python-pygraphviz,
451         python-yaml,
452 Description: metapackage for release
453  This package depends on everything that is needed for a release.debian.org
454  setup.
455
456 Package: debian.org-cdbuilder.debian.org
457 Architecture: all
458 Depends: bittornado,
459         build-essential,
460         debhelper,
461         debian-cd,
462         jigit,
463         m4,
464         tofrodos,
465         zip,
466         zsync,
467         fakeroot,
468         dosfstools,
469         libsoap-lite-perl,
470         mtools
471 Description: metapackage for cdbuilder
472  This package depends on all the packages that are needed for a cdbuilder setup.
473
474 Package: debian.org-cdimage-search.debian.org
475 Architecture: all
476 Depends: libconfigreader-simple-perl
477 Description: metapackage for cdimage-search.debian.org
478  This package depends on all the packages that are needed for the CD/DVD search CGI website
479
480 Package: debian.org-manpages.debian.org
481 Architecture: all
482 Depends: locales-all,
483         ghostscript
484 Description: metapackage for manpages
485  This package depends on all the packages that are needed for manpages.d.o setup.
486
487 Package: debian.org-nm.debian.org
488 Architecture: all
489 Depends: libapache2-mod-wsgi,
490         mutt, mboxgrep,
491         python,
492         python-mako (>= 0.2.5), python-gnupginterface, python-ldap,
493         python-apt, python-beautifulsoup, python-debianbts, python-dns,
494         python-dnspython, python-egenix-mxdatetime, python-egenix-mxtools,
495         python-elementtree | python (>= 2.6), python-flup, python-libxml2,
496         python-lxml, python-psycopg2, python-soappy,
497         python-xapian,
498         python-dateutil,
499         python-debian,
500         python-django (>= 1.5),
501         python-django-south,
502         python-debiancontributors,
503         python-tz,
504         python-markdown,
505         python-lzma,
506         python-requests (>= 2.0.0),
507         procmail,
508         rrdtool,
509         moreutils,
510         libjs-jquery,
511         postgresql-client
512 Description: metapackage for nm.debian.org
513  This package depends on all the packages that are needed for nm.debian.org setup.
514
515 Package: debian.org-backports.debian.org
516 Architecture: all
517 Depends: debian.org-ftpmaster.debian.org,
518         libdbi-perl, libdbd-pg-perl
519 Description: metapackage for backports.debian.org
520  This package depends on all the packages that are needed for backports.debian.org setup.
521
522 Package: debian.org-qa.debian.org
523 Architecture: all
524 Depends: db-util,
525         gnuplot-nox,
526         wml,
527         libapt-pkg-perl,
528                 libcgi-pm-perl,
529                 libdbd-pg-perl,
530                 libdate-manip-perl,
531                 libdpkg-perl,
532                 libmailtools-perl,
533                 libsoap-lite-perl,
534                 libtemplate-perl,
535                 libxml-simple-perl,
536                 libmail-sendmail-perl,
537                 libdate-calc-perl,
538                 libnet-ldap-perl,
539                 libjson-perl,
540                 libyaml-syck-perl,
541         php5, php5-cgi, php5-cli,
542                 php5-ldap, php5-pgsql,
543                 libapache2-mod-fcgid,
544         python-apt, python-psycopg2, python-gpgme,
545         python3, python3-psycopg2,
546         postgresql-client,
547         libdbd-pg-ruby,
548         rrdtool,
549         raptor-utils | raptor2-utils,
550         dose-distcheck, dose-builddebcheck, python3-yaml, python3-debian
551 Description: metapackage for qa.debian.org
552  This package depends on all the packages that are needed for qa.debian.org setup.
553
554 Package: debian.org-packages.qa.debian.org
555 Architecture: all
556 Depends: db4.7-util,
557         libmailtools-perl,
558         libmime-tools-perl,
559         libmail-verp-perl,
560         xsltproc,
561         mhonarc,
562         python,
563         python-lxml,
564         python-soappy,
565         python-debian,
566         python-yaml,
567         python-zsi
568 Description: metapackage for packages.qa.debian.org
569  This package depends on all the packages that are needed for packages.qa.debian.org setup.
570
571 Package: debian.org-tracker.debian.org
572 Architecture: all
573 Depends:
574 # Runtime
575         libapache2-mod-wsgi,
576         python-apt,
577         python-bs4,
578         python-debian,
579         python-django (>= 1.6),
580         python-django-jsonfield,
581         python-django-south,
582         python-gpgme,
583         python-ldap,
584         python-lzma,
585         python-requests (>= 2),
586         python-soappy,
587         python-yaml,
588         dpkg-dev,
589 # Database access
590         python-psycopg2,
591         postgresql-client,
592 # Test suite and docs
593         python-mock,
594         python-sphinx,
595 Description: metapackage for tracker.debian.org
596  This package depends on all the packages that are needed for tracker.debian.org.
597
598 Package: debian.org-udd.debian.org
599 Architecture: all
600 Depends: curl,
601         dpkg-dev,
602         graphviz,
603         libapt-pkg-dev,
604         libcrypt-ssleay-perl,
605         libcgi-simple-perl,
606         libdbd-pg-perl,
607         libdbd-pg-ruby,
608         libdbi-perl,
609         libdbi-ruby,
610         libdpkg-ruby,
611         libio-stringy-perl,
612         liblist-moreutils-perl,
613         libmime-tools-perl,
614         libmldbm-perl,
615         libparams-validate-perl,
616         libperl-dev,
617         libsafe-hole-perl,
618         libtext-template-perl,
619         libyaml-syck-perl,
620         postgresql-autodoc,
621         python-dateutil,
622         python-debian,
623         python-dev,
624         python-launchpadlib,
625         python-psycopg2,
626         python-yaml,
627         ruby-json,
628         ruby-oj,
629         vpim
630 Description: metapackage for udd.debian.org
631  This package depends on all the packages that are needed for udd.debian.org setup.
632
633 Package: debian.org-snapshot.debian.org
634 Architecture: all
635 Depends:
636         ruby,
637         ruby-dbd-pg,
638         python-yaml, python-psycopg2, python-lockfile, python-fuse, uuid-runtime,
639         python-dev, gcc,
640         python-pylons
641 Description: metapackage for snapshot.debian.org
642  This package depends on all the packages that are needed for snapshot.debian.org setup.
643
644 Package: debian.org-women.debian.org
645 Architecture: all
646 Depends: wml
647 Description: metapackages for women.debian.org dependencies
648  This package depends on everything that is needed for women.debian.org.
649
650
651 Package: debian.org-lintian.debian.org
652 Architecture: all
653 Depends:   binutils,
654         binutils-multiarch,
655         bzip2,
656         diffstat,
657         dpkg-dev,
658         debhelper,
659         fakeroot,
660         file,
661         gettext,
662         gnuplot-nox | gnuplot,
663         hardening-includes (>= 2.2~),
664         intltool-debian,
665         libapt-pkg-perl,
666         libarchive-zip-perl,
667         libclass-accessor-perl,
668         libclone-perl,
669         libdigest-sha-perl,
670         libdpkg-perl,
671         libemail-valid-perl,
672         libfile-basedir-perl,
673         libhtml-parser-perl,
674         libipc-run-perl,
675         liblist-moreutils-perl,
676         libparse-debianchangelog-perl,
677         libperlio-gzip-perl,
678         libtimedate-perl,
679         libtext-levenshtein-perl,
680         libtext-template-perl,
681         liburi-perl,
682         libyaml-libyaml-perl,
683         locales,
684         man-db,
685         perl,
686         perl (>= 5.14~) | libautodie-perl (>= 2.10~),
687         t1utils,
688         unzip
689         ,
690         docbook-utils,
691         docbook-xml
692         ,
693 Description: metapackages for lintian.debian.org dependencies
694  This package depends on everything that is needed for lintian.debian.org.
695
696 Package: debian.org-popcon.debian.org
697 Architecture: all
698 Depends:  libchart-perl
699 Description: metapackages for popcon.debian.org dependencies
700  This package depends on everything that is needed for popcon.debian.org.
701
702 Package: debian.org-dde.debian.net
703 Architecture: all
704 Depends: python-apt,
705         python-debian,
706         python-debianbts,
707         python-feedparser,
708         python-flup,
709         python-nose,
710         python-paste,
711         python-psycopg2,
712         python-pyrss2gen,
713         python-soappy,
714         python-werkzeug,
715         python-xapian,
716         python-yaml
717 Description: metapackages for dde.debian.net dependencies
718  This package depends on everything that is needed for dde.debian.net.
719
720 Package: debian.org-debtags.debian.net
721 Architecture: all
722 Depends: python-apt,
723         python-debian,
724         python-django,
725         python-django-registration,
726         python-xapian (>= 1.2.7-1~bpo60+1),
727         python-psycopg2
728 Description: metapackages for debtags.debian.net dependencies
729  This package depends on everything that is needed for debtags.debian.net.
730
731 Package: debian.org-sso.debian.org
732 Architecture: all
733 Depends: libcatalyst-modules-perl,
734         libcatalyst-engine-apache-perl,
735         libapache2-mod-perl2,
736         libapache2-reload-perl,
737         libcatalyst-devel-perl,
738         libhtml-mason-perl,
739         python-django (>= 1.5),
740         python-django-south
741 Description: metapackages for sso.debian.org dependencies
742  This package depends on everything that is needed for sso.debian.org.
743
744 Package: debian.org-lists.debian.org
745 Architecture: all
746 Depends: xapian-tools,
747         xapian-omega,
748         smartlist,
749         procmail,
750         gnuplot,
751         rrdtool,
752         libdpkg-perl,
753         gettext,
754         grepmail,
755         libcompress-raw-zlib-perl,
756         libmoose-perl,
757         carton,
758         amavisd-new,
759         amavis-lists,
760         zoo,
761         lha,
762         p7zip,
763         unrar-free,
764         ripole,
765         pfqueue,
766         pyzor,
767         razor,
768         mrtgutils,
769         pax,
770         pwgen,
771         rbldnsd,
772         rng-tools,
773         speedy-cgi-perl,
774         ccze
775 Description: metapackages for lists.debian.org dependencies
776  This package depends on everything that is needed for lists.debian.org.
777
778 Package: debian.org-ddtp.debian.org
779 Architecture: all
780 Depends: libalgorithm-diff-xs-perl,
781         libdbd-pg-perl,
782         libdbi-perl,
783         libmail-sender-perl,
784         libmime-tools-perl,
785         libtext-diff-perl,
786         libtext-iconv-perl
787         ,
788         gnuplot
789         ,
790         libapache2-mod-wsgi,
791         python-setuptools,
792         python-psycopg2,
793         python-django,
794         python-sqlalchemy
795         ,
796         tig,
797         postgresql-client-9.1
798 Description: metapackages for ddtp.debian.org dependencies
799  This package depends on everything that is needed for ddtp.debian.org.
800
801 Package: debian.org-i18n.debian.org
802 Architecture: all
803 Depends: gettext,
804         po-debconf
805         ,
806         liblocale-gettext-perl,
807         libmailtools-perl,
808         libsoap-lite-perl,
809         libtimedate-perl
810         ,
811         tig,
812         rrdtool
813 Description: metapackages for i18n.debian.org dependencies
814  This package depends on everything that is needed for i18n.debian.org.
815
816 Package: debian.org-l10n.debian.org
817 Architecture: all
818 Depends: gettext,
819         po-debconf
820         ,
821         liblocale-gettext-perl,
822         libmailtools-perl,
823         libsoap-lite-perl,
824         libtimedate-perl
825         ,
826         tig,
827         rrdtool
828 Description: metapackages for l10n.debian.org dependencies
829  This package depends on everything that is needed for l10n.debian.org.
830
831 Package: debian.org-piuparts-master.debian.org
832 Architecture: all
833 Depends: debhelper,
834         asciidoc,
835         git,
836         xmlto,
837         python-debianbts,
838         apache2,
839         ghostscript,
840         python-rpy2,
841         r-base-dev,
842         r-recommended,
843         tango-icon-theme,
844         screen,
845         python-apt,
846         python-distro-info,
847         python-yaml,
848         libsoap-lite-perl
849 Description: metapackage for piuparts-master.debian.org
850  This package depends on all the packages that are needed for the
851  master in the piuparts.debian.org setup.
852
853 Package: debian.org-piuparts-slave.debian.org
854 Architecture: all
855 Depends: debhelper,
856         asciidoc,
857         git,
858         xmlto,
859         debootstrap (>= 1.0.60~bpo70),
860         debsums,
861         lsb-release,
862         screen,
863         python-debian,
864         python-apt,
865         python-distro-info,
866         adequate
867 Description: metapackage for piuparts-slave.debian.org
868  This package depends on all the packages that are needed for the
869  slaves in the piuparts.debian.org setup.
870
871 Package: debian.org-wiki.debian.org
872 Architecture: all
873 Depends: libapache2-mod-wsgi,
874         libcgi-pm-perl,
875         libjson-perl,
876         python-moinmoin (>= 1.9.7-2~bpo7+1),
877         python-launchpadlib,
878         libsoap-lite-perl,
879         python-docutils
880 Description: metapackage for wiki.debian.org
881  This package depends on all the packages that are needed for the Debian wiki
882
883 Package: debian.org-vote.debian.org
884 Architecture: all
885 Depends: libparse-recdescent-perl,
886         libmime-tools-perl,
887         libnet-ldap-perl,
888         libgnupg-interface-perl,
889         libmail-gnupg-perl,
890         graphviz
891 Description: metapackage for vote.debian.org
892  This package depends on all the packages that are needed for DeVoteE
893
894 Package: debian.org-bits.debian.org
895 Architecture: all
896 Depends: python-unidecode,
897         python-jinja2,
898         python-pygments,
899         python-docutils,
900         python-markdown,
901         python-tz,
902         python-typogrify,
903         python-six
904 # Also needed, to add when they are available in Debian and can be backported:
905 # feedgenerator (#702229), blinker (#702231), pelican (#702222)
906 Description: metapackage for bits.debian.org
907  This package depends on all the packages that are needed for the Debian
908  blog bits.debian.org
909
910 Package: debian.org-d-i.debian.org
911 Architecture: all
912 Depends: gnuplot,
913         libdate-manip-perl,
914         libemail-mime-perl,
915         libemail-sender-perl,
916         libfile-slurp-perl,
917         libgd-graph-perl,
918         libhtml-template-perl,
919         liblist-moreutils-perl,
920         libsort-versions-perl,
921         mr,
922         gettext,
923         graphviz,
924         fonts-liberation,
925         edos-distcheck,
926         liburi-perl,
927         edos-distcheck,
928         aspell,
929         libunicode-string-perl,
930 # Taken from d-i's manual (src:installation-guide)'s build-deps:
931         docbook,
932         docbook-xml,
933         docbook-xsl,
934         xsltproc,
935         gawk,
936         libhtml-parser-perl,
937         w3m,
938         poxml,
939         jadetex,
940         openjade | openjade1.3,
941         docbook-dsssl,
942         ghostscript,
943         texlive-lang-cyrillic,
944         texlive-lang-czechslovak,
945         texlive-lang-french,
946         texlive-lang-german,
947         texlive-lang-greek,
948         texlive-lang-italian,
949         texlive-lang-other,
950         texlive-lang-portuguese,
951         texlive-lang-spanish,
952         ko.tex-base,
953         cm-super,
954         po-debconf
955 Description: metapackage for d-i.debian.org
956  This package depends on all the packages that are needed for the
957  d-i.debian.org setup.
958
959 Package: debian.org-codesearch.debian.org
960 Architecture: all
961 Depends: dpkg-dev,
962         postgresql-client
963 Description: metapackage for codesearch.debian.org
964  This package depends on all the packages that are needed for the codesearch
965  setup.
966
967 Package: debian.org-dedup.debian.net
968 Architecture: all
969 Depends: curl,
970         python,
971         python-concurrent.futures,
972         python-debian,
973         python-imaging,
974         python-jinja2,
975         python-lzma,
976         python-pkg-resources,
977         python-werkzeug,
978         python-yaml,
979         python-sqlalchemy,
980         python-ssdeep | base-files (<< 8),
981         sqlite3
982 Description: metapackage for dedup.debian.net
983  This package depends on all packages that are required for operating the
984  Debian duplication detector.
985
986 Package: debian.org-wnpp-by-tags.debian.net
987 Architecture: all
988 Depends: debtags, python-debian, python-beautifulsoup
989 Description: metapackage for wnpp-by-tags.debian.net
990  This package depends on all the packages that are needed for the wnpp-by-tags
991  setup.
992
993 Package: debian.org-blends.debian.org
994 Architecture: all
995 Depends: python-genshi,
996  python-markdown,
997  python-docutils,
998  python-debian,
999  python-psutil,
1000  python-psycopg2,
1001  python-apt,
1002  postgresql-client
1003 Description: metapackage for blends.debian.org
1004  This package depends on all the packages that are needed for the
1005  blends.debian.org setup.
1006
1007 Package: debian.org-pet.debian.net
1008 Architecture: all
1009 Depends: python-apt,
1010          python-argparse,
1011          python-debian,
1012          python-debianbts,
1013          python-inotifyx,
1014          python-paste,
1015          python-psycopg2,
1016          python-pyramid,
1017          python-sqlalchemy,
1018          python-subversion
1019 Description: metapackages for pet.debian.net dependencies
1020  This package depends on everything that is needed for the PET setup.
1021
1022 Package: debian.org-dsa.debian.org
1023 Architecture: all
1024 Depends: ikiwiki, libtext-wikicreole-perl, libtext-wikiformat-perl, libtext-multimarkdown-perl
1025 Description: metapackages for dsa.debian.org master dependencies
1026  This package depends on everything that is needed for the service
1027
1028 Package: debian.org-dns.debian.org
1029 Architecture: all
1030 Depends: perl-doc,
1031         nagios-nrpe-plugin,
1032         sqlite3,
1033         libdata-compare-perl,
1034         libnet-dns-perl,
1035         libnet-dns-sec-perl,
1036         python-dnspython,
1037         python-yaml
1038 Description: metapackages for dns.debian.org master dependencies
1039  This package depends on everything that is needed for the service
1040
1041 Package: debian.org-nagios.debian.org
1042 Architecture: all
1043 Depends: icinga
1044 Description: metapackages for nagios.debian.org master dependencies
1045  This package depends on everything that is needed for the service and
1046  also provides the dpkg-diverts for the REMOTE_USER hack
1047
1048 Package: debian.org-deriv.debian.net
1049 Architecture: all
1050 Depends: python,
1051          python-apt,
1052          python-debian,
1053          python-imaging,
1054          python-psycopg2,
1055          python-requests,
1056          python-simplejson,
1057          python-yaml,
1058          libxml-feed-perl,
1059          dpkg-dev,
1060          patchutils,
1061          rsync,
1062          curl,
1063          make,
1064          lzip,
1065 Homepage: https://wiki.debian.org/Derivatives/Integration#Patches
1066 Description: metapackage for the derivatives census patch generation
1067  This package depends on everything that is needed for the service
1068
1069 Package: debian.org-httpredir.debian.org
1070 Architecture: all
1071 Depends: inoticoming,
1072          libanyevent-perl,
1073          libanyevent-http-perl,
1074          libev-perl,
1075          libtimedate-perl,
1076          libgeo-ip-perl,
1077          libwww-perl,
1078          liburi-perl,
1079          libplack-perl,
1080          starman
1081 Description: metapackage for http-redirector dependencies
1082  This package depends on everything that is needed for an instance of
1083  the http-redirector.
1084
1085 Package: debian.org-search.debian.org
1086 Architecture: all
1087 Depends: xapian-omega
1088 Description: metapackage for search.debian.org dependencies
1089  This package depends on everything that is needed for an instance of
1090  the www search engine (aka search.debian.org).