601294548154ca7edad0ed8d8e80c11ee547f8cc
[debian.org.git] / debian / control
1 Source: debian.org
2 Section: local/admin
3 Priority: required
4 Maintainer: Debian sysadmin Team <debian-admin@debian.org>
5 Uploaders: Peter Palfrader <weasel@debian.org>, Martin Zobel-Helas <zobel@debian.org>, Stephen Gran <sgran@debian.org>
6 Build-Depends: debhelper (>= 7)
7 Standards-Version: 3.8.1
8
9 Package: debian.org
10 Architecture: all
11 Depends: userdir-ldap, zsh, tcsh, pdksh, ksh, csh, ntp, locales-all, exim4-daemon-heavy | postfix, sudo, libpam-pwdfile, vim, munin-node, gnupg, bzip2, cacert-spi | ca-certificates (>> 20080411), ed, cron, dialog, libterm-readline-gnu-perl, logrotate, syslog-ng (>= 3.1), nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic
12 Recommends: debian.org-recommended
13 Conflicts: dchroot-dsa (<= 2:1)
14 Description: DSA's host metapackage
15  This package depends on packages that should be installed on every
16  debian.org host, and conflicts with packages that should never be
17  installed.
18
19 Package: debian.org-recommended-linux
20 Architecture: all
21 Depends: vlan, ifenslave, bridge-utils, iproute,
22         strace,
23         lsscsi
24 Description: metapackage to pull in recommended, but not essential tools for linux system
25  This package depends on packages that are recommended to  be installed on
26  every Linux debian.org host but are not essential.
27
28 Package: debian.org-recommended
29 Architecture: all
30 Depends: debian.org,
31         busybox-static,
32         debian.org-recommended-linux | not+gnu-linux,
33         molly-guard
34         ,
35         man-db
36         ,
37         subversion, rcs, git-core, bzr,
38                 git-svn,
39                 subversion-tools,
40                 mercurial,
41                 cvs
42         ,
43         mtr-tiny, tcpdump, tcptraceroute, ndisc6,
44         traceroute | not+gnu-linux,
45         iputils-tracepath | not+gnu-linux,
46         bind9-host, dnsutils, whois, unbound-host
47         ,
48         emacs23-nox | emacs23 | emacs22-nox | emacs22 | emacs21-nox | emacs21
49         ,
50         at, uptimed,
51         puppet,
52                 libaugeas-ruby,
53                 libaugeas-ruby1.8,
54                 libaugeas0,
55                 augeas-lenses (>= 0.7),
56         locate, dlocate
57         ,
58         dsa-nagios-checks
59         ,
60         lshw | not+gnu-linux,
61         dmidecode | not+amd64,
62         dmidecode | not+i386,
63         dmidecode | not+ia64
64         ,
65         ipython
66         ,
67         mcelog | not+amd64 | not+gnu-linux,
68         mcelog | not+i386 | not+gnu-linux,
69         ,
70         htop, psmisc,
71         lsof | not+gnu-linux,
72         ,
73         mc,
74                 genisoimage,
75         less,
76         rsync,
77         screen,
78         ldap-utils, ldapvi,
79         mmv,
80         moreutils,
81         patchutils,
82         diffstat,
83         netcat-openbsd, socat, telnet
84         ,
85         deborphan
86         ,
87         file
88         ,
89         buffer
90         ,
91         bsd-mailx
92         ,
93         timeout | coreutils (>= 8.0-1)
94         ,
95         wget, curl, lftp, ftp,
96         ,
97         dput
98         ,
99         uuid-runtime
100         ,
101         finger
102         ,
103         unzip
104         ,
105         w3m,
106         elinks,
107         mutt
108 Description: metapackage to pull in recommended, but not essential tools
109  This package depends on packages that are recommended to  be installed on
110  every debian.org host but are not essential.
111
112 Package: debian.org-bugs.debian.org
113 Architecture: all
114 Depends: graphviz,
115         libcgi-simple-perl,
116         libio-stringy-perl,
117         liblist-moreutils-perl,
118         libmime-tools-perl,
119         libmldbm-perl,
120         libparams-validate-perl,
121         libsafe-hole-perl,
122         libtext-template-perl,
123         liburi-perl,
124         libhtml-tree-perl,
125         libsoap-lite-perl,
126         libdbd-pg-perl,
127         python-pyinotify,
128         python-yaml
129 Description: metapackages for bugs.debian.org dependencies
130  This package depends on everything that is needed for a bugs.debian.org
131  mirror or (in the future) bugs-master.
132
133 Package: debian.org-bugs.debian.org-mx
134 Architecture: all
135 Depends: debian.org-bugs.debian.org,
136         spamassassin,
137         build-essential,
138         spamc,
139         libmail-spf-perl,
140         re2c,
141         libsys-syslog-perl,
142         libio-socket-inet6-perl,
143         libnet-ident-perl,
144         libdbi-perl,
145         pyzor,
146         libmail-dkim-perl,
147         libdbd-pg-perl
148 Description: metapackages for bugs.debian.org mail exchanger
149  This package depends on everything that is needed for a bugs.debian.org
150  MX.
151
152
153 Package: debian.org-packages.debian.org
154 Architecture: all
155 Depends: db4.6-util,
156         liblocale-maketext-lexicon-perl,
157         libi18n-acceptlanguage-perl,
158         libnumber-format-perl,
159         libcompress-zlib-perl,
160         libhtml-parser-perl,
161         libmldbm-perl,
162         libtext-iconv-perl,
163         libclass-accessor-perl,
164         liburi-perl,
165         libtemplate-perl,
166         liblingua-stem-perl,
167         libsearch-xapian-perl,
168         libtimedate-perl,
169         libapache2-mod-perl2,
170         libapache2-reload-perl
171 Description: metapackages for packages.debian.org dependencies
172  This package depends on everything that is needed for a packages.debian.org
173  mirror or (in the future) packages-master.
174
175 Package: debian.org-www-master.debian.org
176 Architecture: all
177 Depends: debiandoc-sgml,
178         asciidoc,
179         cm-super,
180         debhelper,
181         docbook,
182         docbook-dsssl,
183         docbook-xsl,
184         dpkg-dev,
185         gettext,
186         ghostscript,
187         imagemagick,
188         iso-codes,
189         isoquery,
190         jadetex,
191         kcc,
192         ko.tex-base,
193         latex-cjk-all,
194         latex-cjk-chinese,
195         ldap-utils,
196         libemail-address-perl,
197         libintl-perl,
198         libmime-lite-perl,
199         libnet-ldap-perl,
200         libsoap-lite-perl,
201         libtimedate-perl,
202         libwww-perl,
203         libxml2-utils,
204         libxml-rss-perl,
205         littex,
206         locales, locales-all,
207         maildrop,
208         openjade,
209         openjade1.3,
210         po4a,
211         poxml,
212         procmail,
213         python2.4,
214         python-xml,
215         texlive-fonts-recommended,
216         texlive-lang-cyrillic, texlive-lang-cyrillic, latex-cjk-japanese,
217         texlive-lang-czechslovak,
218         texlive-lang-finnish,
219         texlive-lang-french,
220         texlive-lang-german,
221         texlive-lang-greek,
222         texlive-lang-italian,
223         texlive-lang-other,
224         texlive-lang-portuguese,
225         texlive-lang-spanish,
226         texlive-lang-swedish,
227         texlive-lang-vietnamese,
228         texlive-latex-base,
229         texlive-latex-extra,
230         texlive-latex-recommended,
231         tidy,
232         time,
233         ttf-arphic-uming,
234         ttf-malayalam-fonts,
235         uni2ascii,
236         wml,
237         xmlroff, dblatex,
238         xplanet,
239         xplanet-images,
240         xsltproc,
241         libjson-perl
242 Description: metapackages for www-master.debian.org dependencies
243  This package depends on everything that is needed for a www-master.debian.org.
244
245
246 Package: debian.org-buildd.debian.org
247 Architecture: all
248 Depends: edos-distcheck,
249         ghostscript,
250         libcompress-bzip2-perl,
251         libcompress-zlib-perl,
252         libhash-merge-perl,
253         libmailtools-perl,
254         libdbi-perl,
255         libdbd-pg-perl,
256         libfile-spec-perl,
257         libstring-escape-perl,
258         libstring-format-perl,
259         libyaml-tiny-perl,
260         python-apt,
261         python-contract,
262         python-coverage,
263         python-debian,
264         python-psycopg2,
265         python-mako,
266         python-nose,
267         python-sqlalchemy,
268         r-base-core,
269         r-cran-lattice,
270         php5,
271         moreutils (>= 0.39~),
272         libdpkg-perl
273 Description: metapackages for buildd.debian.org dependencies
274  This package depends on everything that is needed for a buildd.debian.org.
275
276
277 Package: debian.org-patch-tracker.debian.org
278 Architecture: all
279 Depends: patchutils,
280         python,
281         python-cheetah,
282         python-pygments,
283         python-debian,
284         reprepro,
285         python-wsgiref,
286         python-simplejson,
287         python-pysqlite2,
288         diffstat
289 Description: metapackages for patch-tracker.debian.org dependencies
290  This package depends on everything that is needed for a patch-tracker.debian.org.
291
292 Package: debian.org-planet.debian.org
293 Architecture: all
294 Depends: libwww-perl,
295         timeout | coreutils (>= 8.0-1),
296         debianutils,
297         python-django,
298         python,
299         libdbi-perl, libdate-manip-perl, libdbd-sqlite3-perl
300 Description: metapackages for planet.debian.org dependencies
301  This package depends on everything that is needed for a planet.debian.org.
302
303 Package: debian.org-testing-security.debian.org
304 Architecture: all
305 Depends: libdbd-sqlite3-perl,
306         sqlite3,
307         python-apsw,
308         libterm-readline-gnu-perl,
309         python-apt
310 Description: metapackages for testing-security.debian.org dependencies
311  This package depends on everything that is needed for a testing-security.debian.org.
312
313 Package: debian.org-ftpmaster.debian.org
314 Architecture: all
315 Depends: apt-utils,
316         libapt-pkg-dev,
317         libemail-send-perl,
318         python-apt,
319         python-debianbts (>= 1.4~bpo50+1),
320         lintian,
321         python,
322         python-debian,
323         python-gnupginterface,
324         python-ldap,
325         python-psycopg2,
326         python-pygresql,
327         python-pyrss2gen,
328         python-yaml,
329         python-rrdtool,
330         python-sqlalchemy,
331         binutils-multiarch,
332         build-essential,
333         devscripts,
334         graphviz,
335         ikiwiki,
336         libdbd-pg-ruby,
337         python-epydoc,
338         python-numpy,
339         python-soappy,
340         r-base,
341         symlinks,
342         python-magic,
343         unp,
344         procmail,
345         cvs,
346         ruby,
347         lynx,
348         libxml-rss-perl,
349         ghostscript,
350         perforate,
351         wdiff,
352         xz-utils (>= 4.999.9beta+20100713-1~bpo50+1)
353 Description: metapackage for ftpmaster
354  This package depends on everything that is needed for an ftpmaster setup.
355
356 Package: debian.org-ftpmaster.debian.org-poneys
357 Architecture: all
358 Depends: bicyclerepair,
359         dpkg-dev-el,
360         easypg,
361         emacs-goodies-el,
362         pychecker,
363         pylint,
364         python-mode,
365         ruby-elisp,
366         gitstats,
367         colordiff
368 Description: metapackage for ftpmaster extras
369  Things not really needed needed.
370
371 Package: debian.org-release.debian.org
372 Architecture: all
373 Depends: edos-debcheck,
374         mutt,
375         subversion,
376         python2.5,
377         python2.5-dev,
378         python-dev,
379         devscripts,
380         wdiff,
381         python-pygresql,
382         python-libxslt1,
383         python-apt,
384         python-debian,
385         libapt-pkg-perl,
386         libapt-pkg-dev,
387         dpkg-dev,
388         procmail,
389         rrdtool
390 Description: metapackage for release
391  This package depends on everything that is needed for a release.debian.org
392  setup.
393
394 Package: debian.org-cdbuilder.debian.org
395 Architecture: all
396 Depends: bittornado,
397         build-essential,
398         debhelper,
399         debian-cd,
400         jigit,
401         m4,
402         tofrodos,
403         zip,
404         zsync,
405         fakeroot,
406         dosfstools
407 Description: metapackage for cdbuilder
408  This package depends on all the packages that are needed for a cdbuilder setup.
409
410 Package: debian.org-cdimage-search.debian.org
411 Architecture: all
412 Depends: libconfigreader-simple-perl
413 Description: metapackage for cdimage-search.debian.org
414  This package depends on all the packages that are needed for the CD/DVD search CGI website
415
416 Package: debian.org-manpages.debian.org
417 Architecture: all
418 Depends: locales-all,
419         gs-common
420 Description: metapackage for manpages
421  This package depends on all the packages that are needed for manpages.d.o setup.
422
423 Package: debian.org-nm.debian.org
424 Architecture: all
425 Depends: libapache2-mod-php5, libapache2-mod-wsgi,
426         php5-cli,
427         php5-ldap, php5-pgsql,
428         wml,
429         mutt, mboxgrep,
430         python,
431         python-mako (>= 0.2.5), python-gnupginterface, python-ldap,
432         python-apt, python-beautifulsoup, python-debianbts, python-dns,
433         python-dnspython, python-egenix-mxdatetime, python-egenix-mxtools,
434         python-elementtree | python (>= 2.6), python-flup, python-libxml2,
435         python-lxml, python-psycopg2, python-soappy, python-virtualenv,
436         python-sqlalchemy (>= 0.6), python (>= 2.5.4-5~) | python-simplejson,
437         python-flask (>= 0.6), python-flaskext.wtf, python-wtforms,
438         python-xapian,
439         python-dateutil,
440         perl,
441         libdbi-perl, libdbd-pg-perl, libdbd-sqlite3-perl,
442         procmail,
443         moreutils
444 Description: metapackage for nm.debian.org
445  This package depends on all the packages that are needed for nm.debian.org setup.
446
447 Package: debian.org-backports.debian.org
448 Architecture: all
449 Depends: debian.org-ftpmaster.debian.org,
450         libdbi-perl, libdbd-pg-perl
451 Description: metapackage for backports.debian.org
452  This package depends on all the packages that are needed for backports.debian.org setup.
453
454 Package: debian.org-qa.debian.org
455 Architecture: all
456 Depends: db4.8-util,
457         gnuplot-nox,
458         wml,
459         libapt-pkg-perl,
460                 libdbd-pg-perl,
461                 libdate-manip-perl,
462                 libdpkg-perl,
463                 libmailtools-perl,
464                 libsoap-lite-perl,
465                 libtemplate-perl,
466                 libxml-simple-perl,
467                 libmail-sendmail-perl,
468                 libdate-calc-perl,
469                 libnet-ldap-perl,
470         php5, php5-cgi, php5-cli,
471                 php5-ldap, php5-pgsql,
472                 libapache2-mod-fcgid,
473         python-apt, python-psycopg2,
474         libdbd-pg-ruby,
475         rrdtool
476 Description: metapackage for qa.debian.org
477  This package depends on all the packages that are needed for qa.debian.org setup.
478
479 Package: debian.org-udd.debian.org
480 Architecture: all
481 Depends: graphviz,
482         libapt-pkg-dev,
483         libcgi-simple-perl,
484         libdbd-pg-ruby,
485         libdbi-ruby,
486         libjson-ruby,
487         liblist-moreutils-perl,
488         libmime-tools-perl,
489         libparams-validate-perl,
490         libperl-dev,
491         libmldbm-perl,
492         libsafe-hole-perl,
493         libtext-template-perl,
494         libyaml-syck-perl,
495         python-debian,
496         python-dev,
497         python-psycopg2,
498         python-yaml
499 Description: metapackage for udd.debian.org
500  This package depends on all the packages that are needed for udd.debian.org setup.
501
502 Package: debian.org-snapshot.debian.org
503 Architecture: all
504 Depends: ruby, libdbd-pg-ruby1.8, libbz2-ruby1.8, libbz2-ruby1.8, python-yaml, python-psycopg2, python-lockfile, fuse-utils, python-fuse, uuid-runtime,
505         python-dev, gcc,
506         python-pylons
507 Description: metapackage for snapshot.debian.org
508  This package depends on all the packages that are needed for snapshot.debian.org setup.
509
510 Package: debian.org-women.debian.org
511 Architecture: all
512 Depends: wml
513 Description: metapackages for women.debian.org dependencies
514  This package depends on everything that is needed for women.debian.org.
515
516
517 Package: debian.org-lintian.debian.org
518 Architecture: all
519 Depends:   binutils,
520         binutils-multiarch,
521         bzip2,
522         diffstat,
523         dpkg-dev,
524         fakeroot,
525         file,
526         gettext,
527         intltool-debian,
528         libapt-pkg-perl,
529         libclass-accessor-perl,
530         libdigest-sha-perl,
531         libdpkg-perl,
532         libemail-valid-perl,
533         libhtml-parser-perl,
534         libipc-run-perl,
535         libparse-debianchangelog-perl,
536         libtimedate-perl,
537         libtext-template-perl,
538         liburi-perl,
539         locales,
540         man-db,
541         perl,
542         unzip,
543         xz-utils
544         ,
545         docbook-utils,
546         docbook-xml
547 Description: metapackages for lintian.debian.org dependencies
548  This package depends on everything that is needed for lintian.debian.org.
549
550 Package: debian.org-popcon.debian.org
551 Architecture: all
552 Depends:  libchart-perl
553 Description: metapackages for popcon.debian.org dependencies
554  This package depends on everything that is needed for popcon.debian.org.
555
556 Package: debian.org-dde.debian.net
557 Architecture: all
558 Depends: python-apt,
559         python-debian,
560         python-debianbts,
561         python-feedparser,
562         python-flup,
563         python-nose,
564         python-paste,
565         python-psycopg2,
566         python-pyrss2gen,
567         python-soappy,
568         python-werkzeug,
569         python-xapian,
570         python-yaml
571 Description: metapackages for dde.debian.net dependencies
572  This package depends on everything that is needed for dde.debian.net.