Add missing dependencies for release.d.o
[debian.org.git] / debian / control
1 Source: debian.org
2 Section: local/admin
3 Priority: required
4 Maintainer: Debian sysadmin Team <debian-admin@debian.org>
5 Uploaders: Peter Palfrader <weasel@debian.org>, Martin Zobel-Helas <zobel@debian.org>, Stephen Gran <sgran@debian.org>, Luca Filipozzi <lfilipoz@debian.org>
6 Build-Depends: debhelper (>= 7)
7 Standards-Version: 3.8.1
8
9 Package: debian.org
10 Architecture: all
11 Depends: userdir-ldap, zsh, tcsh, pdksh, ksh, csh, ntp, locales-all, exim4-daemon-heavy | postfix, sudo, libpam-pwdfile, vim, nano, munin-node, gnupg, bzip2, cacert-spi | ca-certificates (>> 20080411), ed, cron, dialog, libterm-readline-gnu-perl, logrotate, syslog-ng (>= 3.1), nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic
12 Recommends: debian.org-recommended
13 Conflicts: dchroot-dsa (<= 2:1)
14 Description: DSA's host metapackage
15  This package depends on packages that should be installed on every
16  debian.org host, and conflicts with packages that should never be
17  installed.
18
19 Package: debian.org-recommended-linux
20 Architecture: all
21 Depends: vlan, ifenslave, bridge-utils, iproute,
22         strace,
23         lsscsi,
24         ethtool,
25         bwm-ng,
26         iputils-tracepath,
27         traceroute,
28         lshw,
29         lsof
30 Description: metapackage to pull in recommended, but not essential tools for linux system
31  This package depends on packages that are recommended to  be installed on
32  every Linux debian.org host but are not essential.
33
34 Package: debian.org-recommended
35 Architecture: any
36 Depends: debian.org,
37         busybox-static,
38         debian.org-recommended-linux [linux-any],
39         molly-guard
40         ,
41         man-db
42         ,
43         devscripts
44         ,
45         subversion, rcs, git, bzr,
46                 git-svn,
47                 subversion-tools,
48                 mercurial,
49                 cvs
50         ,
51         mtr-tiny, tcpdump, tcptraceroute, ndisc6,
52         bind9-host, dnsutils, whois, unbound-host
53         ,
54         emacs24-nox | emacs24 | emacs23-nox | emacs23 | emacs22-nox | emacs22 | emacs21-nox | emacs21,
55         vim-scripts, vim-addon-manager
56         ,
57         at, uptimed,
58         puppet,
59                 libaugeas-ruby,
60                 libaugeas-ruby1.8,
61                 libaugeas0,
62                 augeas-lenses (>= 0.7),
63         dlocate
64         ,
65         dsa-nagios-checks
66         ,
67         munin-plugins-extra
68         ,
69         dmidecode [amd64 i386 ia64],
70         edac-utils,
71         sg3-utils
72         ,
73         ipython
74         ,
75         mcelog [amd64 i386]
76         ,
77         htop, psmisc,
78         ,
79         ncdu,
80         mc,
81                 genisoimage,
82         less,
83         rsync,
84         screen,
85         tmux,
86         ldap-utils, ldapvi,
87         mmv,
88         moreutils,
89         patchutils,
90         diffstat,
91         bc,
92         netcat-openbsd, socat, telnet
93         ,
94         deborphan
95         ,
96         file
97         ,
98         buffer
99         ,
100         bsd-mailx
101         ,
102         timeout | coreutils (>= 8.0-1)
103         ,
104         wget, curl, lftp, ftp,
105         ,
106         dput
107         ,
108         uuid-runtime
109         ,
110         finger
111         ,
112         xz-utils,
113         pigz,
114         unzip
115         ,
116         w3m,
117         elinks,
118         mutt
119         ,
120         ccze,
121         multitail
122 Description: metapackage to pull in recommended, but not essential tools
123  This package depends on packages that are recommended to  be installed on
124  every debian.org host but are not essential.
125
126 Package: debian.org-bugs.debian.org
127 Architecture: all
128 Depends: graphviz,
129         libcgi-simple-perl,
130         libgravatar-url-perl,
131         libio-stringy-perl,
132         liblist-moreutils-perl,
133         libmail-rfc822-address-perl,
134         libmime-tools-perl,
135         libmldbm-perl,
136         libparams-validate-perl,
137         libsafe-hole-perl,
138         libtext-template-perl,
139         liburi-perl,
140         libhtml-tree-perl,
141         libsoap-lite-perl,
142         libtext-iconv-perl,
143         libdbd-pg-perl,
144         libfile-libmagic-perl,
145         libnet-dns-sec-perl,
146         python-pyinotify,
147         python-yaml,
148 # contributors.debian.org's data mining
149         python3-requests,
150         python3-debian,
151         python3-six
152 Description: metapackages for bugs.debian.org dependencies
153  This package depends on everything that is needed for a bugs.debian.org
154  mirror or (in the future) bugs-master.
155
156 Package: debian.org-bugs.debian.org-master
157 Architecture: all
158 Depends: debian.org-bugs.debian.org,
159         gnuplot,
160         ttf-liberation,
161         kgb-client-git,
162         lynx    
163 Description: metapackages for bugs-master.debian.org dependencies
164  This package depends on everything that is needed for a
165  bugs-master.debian.org
166
167 Package: debian.org-bugs.debian.org-search
168 Architecture: all
169 Depends: debian.org-bugs.debian.org,
170         hyperestraier,
171         libdate-manip-perl,
172         libsearch-estraier-perl
173 Description: metapackages for bugs-search.debian.org dependencies
174  This package depends on everything that is needed for a
175  bugs-search.debian.org
176
177 Package: debian.org-bugs.debian.org-mx
178 Architecture: all
179 Depends: debian.org-bugs.debian.org,
180         spamassassin,
181         build-essential,
182         spamc,
183         libmail-spf-perl,
184         re2c,
185         libsys-syslog-perl,
186         libio-socket-inet6-perl,
187         libnet-ident-perl,
188         libdbi-perl,
189         pyzor,
190         libmail-dkim-perl,
191         libdbd-pg-perl
192 Description: metapackages for bugs.debian.org mail exchanger
193  This package depends on everything that is needed for a bugs.debian.org
194  MX.
195
196
197 Package: debian.org-packages-master.debian.org
198 Architecture: all
199 Depends: debian.org-packages.debian.org,
200         procmail,
201         gettext,
202         libhtml-template-perl,
203         libxml-rss-perl,
204         libtimedate-perl,
205         libio-stringy-perl,
206         freecdb,
207         tig
208 Description: metapackages for packages.debian.org dependencies
209  This package depends on everything that is needed for a
210  packages-master.debian.org server.  For the mirrors all you need is the
211  debian.org-packages.debian.org package.
212
213 Package: debian.org-packages.debian.org
214 Architecture: all
215 Depends: liblocale-maketext-lexicon-perl,
216         libi18n-acceptlanguage-perl,
217         libnumber-format-perl,
218         libcompress-zlib-perl,
219         libhtml-parser-perl,
220         libmldbm-perl,
221         libtext-iconv-perl,
222         libclass-accessor-perl,
223         liburi-perl,
224         libtemplate-perl,
225         liblingua-stem-perl,
226         libsearch-xapian-perl,
227         libtimedate-perl,
228         libcgi-fast-perl,
229         libapache2-mod-fcgid,
230         dpkg-dev,
231         rsync
232 Description: metapackages for packages.debian.org dependencies
233  This package depends on everything that is needed for a packages.debian.org
234  mirror.  For packages-master install the debian.org-packages-master.debian.org
235  package.
236
237 Package: debian.org-www-master.debian.org
238 Architecture: all
239 Depends: debiandoc-sgml,
240         asciidoc,
241         cm-super,
242         debhelper,
243         docbook,
244         docbook-dsssl,
245         docbook-utils,
246         docbook-xsl,
247         dpkg-dev,
248         fonts-arphic-uming,
249         fonts-mlym,
250         gawk (>= 1:4.0.1),
251         gettext,
252         ghostscript,
253         imagemagick,
254         iso-codes,
255         isoquery,
256         jadetex,
257         kcc,
258         ko.tex-base,
259         latex-cjk-all,
260         latex-cjk-chinese,
261         ldap-utils,
262         libcgi-pm-perl,
263         libemail-address-perl,
264         libintl-perl,
265         libmime-lite-perl,
266         libnet-ldap-perl,
267         libsoap-lite-perl,
268         libtimedate-perl,
269         libwww-perl,
270         libxml2-utils,
271         libxml-rss-perl,
272         locales, locales-all,
273         lmodern,
274         maildrop,
275         opencc,
276         openjade,
277         openjade1.3,
278         po4a,
279         poxml,
280         procmail,
281         texlive-fonts-recommended,
282         texlive-lang-all,
283         latex-cjk-japanese,
284         texlive-latex-base,
285         texlive-latex-extra,
286         texlive-latex-recommended,
287         tidy,
288         time,
289         uni2ascii,
290         wml,
291         xmlroff, dblatex,
292         xplanet,
293         xplanet-images,
294         xsltproc,
295         libjson-perl,
296 Description: metapackages for www-master.debian.org dependencies
297  This package depends on everything that is needed for a www-master.debian.org.
298
299
300 Package: debian.org-buildd.debian.org
301 Architecture: all
302 Depends:
303         dose-builddebcheck,
304         dose-distcheck,
305         edos-distcheck,
306         ghostscript,
307         libcompress-bzip2-perl,
308         libcompress-zlib-perl,
309         libhash-merge-perl,
310         libmailtools-perl,
311         libdbi-perl,
312         libdbd-pg-perl,
313         libfile-spec-perl,
314         libstring-escape-perl,
315         libstring-format-perl,
316         libyaml-tiny-perl,
317         python-apt,
318         python-contract,
319         python-coverage,
320         python-debian,
321         python-psycopg2,
322         python-mako,
323         python-nose,
324         python-sqlalchemy,
325         r-base-core,
326         r-cran-lattice,
327         moreutils (>= 0.39~),
328         libdpkg-perl,
329         php5,
330         php5-cgi,
331         php5-pgsql,
332         libapache2-mod-fcgid,
333         libgmp10,
334         libyaml-libyaml-perl
335 Description: metapackages for buildd.debian.org dependencies
336  This package depends on everything that is needed for a buildd.debian.org.
337
338
339 Package: debian.org-patch-tracker.debian.org
340 Architecture: all
341 Depends: patchutils,
342         python,
343         python-cheetah,
344         python-pygments,
345         python-debian,
346         reprepro,
347         python-wsgiref,
348         python-simplejson,
349         python-pysqlite2,
350         diffstat
351 Description: metapackages for patch-tracker.debian.org dependencies
352  This package depends on everything that is needed for a patch-tracker.debian.org.
353
354 Package: debian.org-planet.debian.org
355 Architecture: all
356 Depends: libwww-perl,
357         timeout | coreutils (>= 8.0-1),
358         debianutils,
359         python-django,
360         python,
361         libdbi-perl, libdate-manip-perl, libdbd-sqlite3-perl
362 Description: metapackages for planet.debian.org dependencies
363  This package depends on everything that is needed for a planet.debian.org.
364
365 Package: debian.org-security-tracker.debian.org
366 Architecture: all
367 Depends: libdbd-sqlite3-perl,
368         sqlite3,
369         python-apsw,
370         libterm-readline-gnu-perl,
371         python-apt,
372         python-soappy
373 Description: metapackages for security-tracker.debian.org dependencies
374  This package depends on everything that is needed for a security-tracker.debian.org.
375
376 Package: debian.org-ftpmaster.debian.org
377 Architecture: all
378 Depends: apt-utils,
379         libapt-pkg-dev,
380         libemail-sender-perl,
381         libcgi-pm-perl,
382         python-apt,
383         python-debianbts (>= 1.4~bpo50+1),
384         lintian,
385         python,
386         python-debian,
387         python-ldap,
388         python-psycopg2,
389         python-pygresql,
390         python-pyrss2gen,
391         python-yaml,
392         python-rrdtool,
393         python-sqlalchemy,
394         binutils-multiarch,
395         build-essential,
396         graphviz,
397         ikiwiki,
398         libdbd-pg-ruby,
399         python-epydoc,
400         python-numpy,
401         python-soappy,
402         r-base,
403         symlinks,
404         python-magic,
405         unp,
406         procmail,
407         cvs,
408         ruby,
409         lynx,
410         libxml-rss-perl,
411         ghostscript,
412         perforate,
413         wdiff,
414         ruby-soap4r
415 Description: metapackage for ftpmaster
416  This package depends on everything that is needed for an ftpmaster setup.
417
418 Package: debian.org-ftpmaster.debian.org-poneys
419 Architecture: all
420 Depends: bicyclerepair,
421         dpkg-dev-el,
422         emacs-goodies-el,
423         pychecker,
424         pylint,
425         python-mode,
426         gitstats,
427         colordiff
428 Description: metapackage for ftpmaster extras
429  Things not really needed needed.
430
431 Package: debian.org-release.debian.org
432 Architecture: all
433 Depends:
434         dose-distcheck,
435         dose-builddebcheck,
436         mutt,
437         subversion,
438         python2.7,
439         python2.7-dev,
440         python-dev,
441         wdiff,
442         python-pygresql,
443         python-libxslt1,
444         python-apt,
445         python-debian,
446         python-six,
447         libapt-pkg-perl,
448         libapt-pkg-dev,
449         dpkg-dev,
450         procmail,
451         rrdtool,
452         python3-apt,
453         python3-debian,
454         python3-six,
455         python3-yaml,
456         picosat,
457         git-email,
458         python-networkx,
459         python-pygraphviz,
460         python-yaml,
461         postgresql-client,
462         python-psycopg2,
463         python3-psycopg2,
464         python-sqlalchemy,
465         libdbd-pg-perl,
466 Description: metapackage for release
467  This package depends on everything that is needed for a release.debian.org
468  setup.
469
470 Package: debian.org-cdbuilder.debian.org
471 Architecture: all
472 Depends: bittornado,
473         build-essential,
474         debhelper,
475         debian-cd,
476         jigit,
477         m4,
478         tofrodos,
479         zip,
480         zsync,
481         fakeroot,
482         dosfstools,
483         libsoap-lite-perl,
484         mtools
485 Description: metapackage for cdbuilder
486  This package depends on all the packages that are needed for a cdbuilder setup.
487
488 Package: debian.org-cdimage-search.debian.org
489 Architecture: all
490 Depends: libconfigreader-simple-perl
491 Description: metapackage for cdimage-search.debian.org
492  This package depends on all the packages that are needed for the CD/DVD search CGI website
493
494 Package: debian.org-manpages.debian.org
495 Architecture: all
496 Depends: locales-all,
497         ghostscript
498 Description: metapackage for manpages
499  This package depends on all the packages that are needed for manpages.d.o setup.
500
501 Package: debian.org-nm.debian.org
502 Architecture: all
503 Depends: libapache2-mod-wsgi,
504         mutt, mboxgrep,
505         python,
506         python-mako (>= 0.2.5), python-ldap,
507         python-apt, python-beautifulsoup, python-debianbts, python-dns,
508         python-dnspython, python-egenix-mxdatetime, python-egenix-mxtools,
509         python-elementtree | python (>= 2.6), python-flup, python-libxml2,
510         python-lxml, python-psycopg2, python-soappy,
511         python-xapian,
512         python-dateutil,
513         python-debian,
514         python-django (>= 1.8),
515         python-django-south,
516         python-debiancontributors,
517         python-tz,
518         python-markdown,
519         python-lzma,
520         python-requests (>= 2.0.0),
521         python3-requests,
522         python3-psycopg2,
523         procmail,
524         rrdtool,
525         moreutils,
526         libjs-jquery,
527         postgresql-client
528 Description: metapackage for nm.debian.org
529  This package depends on all the packages that are needed for nm.debian.org setup.
530
531 Package: debian.org-backports.debian.org
532 Architecture: all
533 Depends: debian.org-ftpmaster.debian.org,
534         libdbi-perl, libdbd-pg-perl
535 Description: metapackage for backports.debian.org
536  This package depends on all the packages that are needed for backports.debian.org setup.
537
538 Package: debian.org-qa.debian.org
539 Architecture: all
540 Depends: db-util,
541         devscripts (>= 2.15.9~),
542         gnuplot-nox,
543         wml,
544         libapt-pkg-perl,
545                 libcgi-pm-perl,
546                 libdbd-pg-perl,
547                 libdate-manip-perl,
548                 libdpkg-perl,
549                 libmailtools-perl,
550                 libsoap-lite-perl,
551                 libtemplate-perl,
552                 libxml-simple-perl,
553                 libmail-sendmail-perl,
554                 libdate-calc-perl,
555                 libnet-ldap-perl,
556                 libjson-perl,
557                 libyaml-syck-perl,
558         php5, php5-cgi, php5-cli,
559                 php5-ldap, php5-pgsql,
560                 libapache2-mod-fcgid,
561         python-apt, python-psycopg2, python-gpgme,
562         python3, python3-psycopg2,
563         postgresql-client,
564         libdbd-pg-ruby,
565         rrdtool,
566         raptor-utils | raptor2-utils,
567         dose-distcheck, dose-builddebcheck, python3-yaml, python3-debian
568 Description: metapackage for qa.debian.org
569  This package depends on all the packages that are needed for qa.debian.org setup.
570
571 Package: debian.org-packages.qa.debian.org
572 Architecture: all
573 Depends: db4.7-util,
574         libio-compress-perl,
575         libio-compress-lzma-perl,
576         libmailtools-perl,
577         libmime-tools-perl,
578         libmail-verp-perl,
579         xsltproc,
580         mhonarc,
581         python,
582         python-lxml,
583         python-soappy,
584         python-debian,
585         python-yaml,
586         python-zsi
587 Description: metapackage for packages.qa.debian.org
588  This package depends on all the packages that are needed for packages.qa.debian.org setup.
589
590 Package: debian.org-tracker.debian.org
591 Architecture: all
592 Depends:
593 # Runtime
594         daemon,
595         libapache2-mod-wsgi,
596         python-apt,
597         python-bs4,
598         python-debian,
599         python-django (>= 1.8),
600         python-django-jsonfield,
601         python-gpgme,
602         python-ldap,
603         python-lzma,
604         python-requests (>= 2),
605         python-soappy,
606         python-yaml,
607         python-pyinotify,
608         dpkg-dev,
609 # Database access
610         python-psycopg2,
611         postgresql-client,
612 # Test suite and docs
613         python-mock,
614         python-sphinx,
615 Description: metapackage for tracker.debian.org
616  This package depends on all the packages that are needed for tracker.debian.org.
617
618 Package: debian.org-udd.debian.org
619 Architecture: all
620 Depends: curl,
621         dpkg-dev,
622         graphviz,
623         libapt-pkg-dev,
624         libcrypt-ssleay-perl,
625         libcgi-simple-perl,
626         libdbd-pg-perl,
627         libdbd-pg-ruby,
628         libdbi-perl,
629         libdbi-ruby,
630         libdpkg-ruby,
631         libio-stringy-perl,
632         liblist-moreutils-perl,
633         libmime-tools-perl,
634         libmldbm-perl,
635         libparams-validate-perl,
636         libperl-dev,
637         libsafe-hole-perl,
638         libtext-template-perl,
639         libyaml-syck-perl,
640         postgresql-autodoc,
641         python-dateutil,
642         python-debian,
643         python-dev,
644         python-launchpadlib,
645         python-psycopg2,
646         python-yaml,
647         ruby-json,
648         ruby-oj,
649         vpim
650 Description: metapackage for udd.debian.org
651  This package depends on all the packages that are needed for udd.debian.org setup.
652
653 Package: debian.org-snapshot.debian.org
654 Architecture: all
655 Depends:
656         ruby,
657         ruby-dbd-pg,
658         python-yaml, python-psycopg2, python-lockfile, python-fuse, uuid-runtime,
659         python-dev, gcc,
660         python-pylons
661 Description: metapackage for snapshot.debian.org
662  This package depends on all the packages that are needed for snapshot.debian.org setup.
663
664 Package: debian.org-women.debian.org
665 Architecture: all
666 Depends: wml
667 Description: metapackages for women.debian.org dependencies
668  This package depends on everything that is needed for women.debian.org.
669
670
671 Package: debian.org-lintian.debian.org
672 Architecture: all
673 Depends:   binutils,
674         binutils-multiarch,
675         bzip2,
676         diffstat,
677         dpkg-dev,
678         debhelper,
679         fakeroot,
680         file,
681         gettext,
682         gnuplot-nox | gnuplot,
683         hardening-includes (>= 2.2~),
684         intltool-debian,
685         libapt-pkg-perl,
686         libarchive-zip-perl,
687         libclass-accessor-perl,
688         libclone-perl,
689         libdata-alias-perl,
690         libdigest-sha-perl,
691         libdpkg-perl,
692         libemail-valid-perl,
693         libfile-basedir-perl,
694         libhtml-parser-perl,
695         libipc-run-perl,
696         liblist-moreutils-perl,
697         libparse-debianchangelog-perl,
698         libperlio-gzip-perl,
699         libtimedate-perl,
700         libtext-levenshtein-perl,
701         libtext-template-perl,
702         liburi-perl,
703         libyaml-libyaml-perl,
704         locales,
705         man-db,
706         perl,
707         perl (>= 5.14~) | libautodie-perl (>= 2.10~),
708         t1utils,
709         unzip
710         ,
711         docbook-utils,
712         docbook-xml
713         ,
714 Description: metapackages for lintian.debian.org dependencies
715  This package depends on everything that is needed for lintian.debian.org.
716
717 Package: debian.org-popcon.debian.org
718 Architecture: all
719 Depends:
720         libchart-perl,
721         libcgi-pm-perl
722 Description: metapackages for popcon.debian.org dependencies
723  This package depends on everything that is needed for popcon.debian.org.
724
725 Package: debian.org-dde.debian.net
726 Architecture: all
727 Depends: python-apt,
728         python-debian,
729         python-debianbts,
730         python-feedparser,
731         python-flup,
732         python-nose,
733         python-paste,
734         python-psycopg2,
735         python-pyrss2gen,
736         python-soappy,
737         python-werkzeug,
738         python-xapian,
739         python-yaml
740 Description: metapackages for dde.debian.net dependencies
741  This package depends on everything that is needed for dde.debian.net.
742
743 Package: debian.org-debtags.debian.org
744 Architecture: all
745 Depends: python-apt,
746         python-debian,
747         python-django,
748         python-xapian (>= 1.2.7-1~bpo60+1),
749         python-psycopg2,
750         python-debiancontributors,
751         python-six,
752         postgresql-client,
753         g++,
754         libapt-pkg-dev
755 Description: metapackages for debtags.debian.org dependencies
756  This package depends on everything that is needed for debtags.debian.org.
757
758 Package: debian.org-sso.debian.org
759 Architecture: all
760 Depends: libcatalyst-modules-perl,
761         libcatalyst-engine-apache-perl,
762         libapache2-mod-perl2,
763         libapache2-reload-perl,
764         libcatalyst-devel-perl,
765         libhtml-mason-perl,
766         python3-requests,
767         python-django (>= 1.7),
768         python-lockfile,
769         gnutls-bin
770 Description: metapackages for sso.debian.org dependencies
771  This package depends on everything that is needed for sso.debian.org.
772
773 Package: debian.org-lists.debian.org
774 Architecture: all
775 Depends: xapian-tools,
776         xapian-omega,
777         smartlist,
778         procmail,
779         gnuplot,
780         rrdtool,
781         libdpkg-perl,
782         gettext,
783         grepmail,
784         libcompress-raw-zlib-perl,
785         libgcrypt20-dev,
786         libmoose-perl,
787         libnet-oauth2-perl,
788         carton,
789         amavisd-new,
790         amavis-lists,
791         zoo,
792         lha,
793         p7zip,
794         unrar-free,
795         ripole,
796         pfqueue,
797         pyzor,
798         razor,
799         mrtgutils,
800         pax,
801         pwgen,
802         rbldnsd,
803         rng-tools,
804         speedy-cgi-perl,
805         ccze,
806         pflogsumm
807 Description: metapackages for lists.debian.org dependencies
808  This package depends on everything that is needed for lists.debian.org.
809
810 Package: debian.org-ddtp.debian.org
811 Architecture: all
812 Depends: libalgorithm-diff-xs-perl,
813         libdbd-pg-perl,
814         libdbi-perl,
815         libmail-sender-perl,
816         libmime-tools-perl,
817         libtext-diff-perl,
818         libtext-iconv-perl
819         ,
820         gnuplot
821         ,
822         libapache2-mod-wsgi,
823         python-setuptools,
824         python-psycopg2,
825         python-django,
826         python-sqlalchemy
827         ,
828         tig,
829         postgresql-client-9.1
830 Description: metapackages for ddtp.debian.org dependencies
831  This package depends on everything that is needed for ddtp.debian.org.
832
833 Package: debian.org-i18n.debian.org
834 Architecture: all
835 Depends: gettext,
836         po-debconf
837         ,
838         liblocale-gettext-perl,
839         libmailtools-perl,
840         libsoap-lite-perl,
841         libtimedate-perl
842         ,
843         tig,
844         rrdtool
845 Description: metapackages for i18n.debian.org dependencies
846  This package depends on everything that is needed for i18n.debian.org.
847
848 Package: debian.org-l10n.debian.org
849 Architecture: all
850 Depends: gettext,
851         po-debconf
852         ,
853         liblocale-gettext-perl,
854         libmailtools-perl,
855         libsoap-lite-perl,
856         libtimedate-perl
857         ,
858         tig,
859         rrdtool
860 Description: metapackages for l10n.debian.org dependencies
861  This package depends on everything that is needed for l10n.debian.org.
862
863 Package: debian.org-piuparts-master.debian.org
864 Architecture: all
865 Depends: debhelper,
866         asciidoc,
867         git,
868         xmlto,
869         python-debianbts,
870         apache2,
871         ghostscript,
872         python-rpy2,
873         r-base-dev,
874         r-recommended,
875         tango-icon-theme,
876         screen,
877         python-apt,
878         python-distro-info,
879         python-lzma,
880         python-yaml,
881         libsoap-lite-perl
882 Description: metapackage for piuparts-master.debian.org
883  This package depends on all the packages that are needed for the
884  master in the piuparts.debian.org setup.
885
886 Package: debian.org-piuparts-slave.debian.org
887 Architecture: all
888 Depends: debhelper,
889         asciidoc,
890         git,
891         xmlto,
892         debootstrap (>= 1.0.60~bpo70),
893         debsums,
894         lsb-release,
895         screen,
896         python-debian,
897         python-apt,
898         python-distro-info,
899         python-lzma,
900         adequate
901 Description: metapackage for piuparts-slave.debian.org
902  This package depends on all the packages that are needed for the
903  slaves in the piuparts.debian.org setup.
904
905 Package: debian.org-wiki.debian.org
906 Architecture: all
907 Depends: libapache2-mod-wsgi,
908         libcgi-pm-perl,
909         libjson-perl,
910         python-moinmoin (>= 1.9.7-2~bpo7+1),
911         python-launchpadlib,
912         libsoap-lite-perl,
913         python-docutils
914 Description: metapackage for wiki.debian.org
915  This package depends on all the packages that are needed for the Debian wiki
916
917 Package: debian.org-vote.debian.org
918 Architecture: all
919 Depends: libparse-recdescent-perl,
920         libmime-tools-perl,
921         libnet-ldap-perl,
922         libgnupg-interface-perl,
923         libmail-gnupg-perl,
924         graphviz
925 Description: metapackage for vote.debian.org
926  This package depends on all the packages that are needed for DeVoteE
927
928 Package: debian.org-bits.debian.org
929 Architecture: all
930 Depends: pelican
931 Description: metapackage for bits.debian.org
932  This package depends on all the packages that are needed for the Debian
933  blog bits.debian.org
934
935 Package: debian.org-d-i.debian.org
936 Architecture: all
937 Depends: gnuplot,
938         libdate-manip-perl,
939         libemail-mime-perl,
940         libemail-sender-perl,
941         libfile-slurp-perl,
942         libgd-graph-perl,
943         libhtml-template-perl,
944         liblist-moreutils-perl,
945         libsort-versions-perl,
946         mr,
947         gettext,
948         graphviz,
949         fonts-liberation,
950         edos-distcheck,
951         liburi-perl,
952         edos-distcheck,
953         aspell,
954         libunicode-string-perl,
955         libxml-libxml-perl,
956 # Taken from d-i's manual (src:installation-guide)'s build-deps:
957         docbook,
958         docbook-xml,
959         docbook-xsl,
960         xsltproc,
961         gawk,
962         libhtml-parser-perl,
963         w3m,
964         poxml,
965         jadetex,
966         openjade | openjade1.3,
967         docbook-dsssl,
968         ghostscript,
969         texlive-lang-cyrillic,
970         texlive-lang-czechslovak,
971         texlive-lang-french,
972         texlive-lang-german,
973         texlive-lang-greek,
974         texlive-lang-italian,
975         texlive-lang-other,
976         texlive-lang-portuguese,
977         texlive-lang-spanish,
978         ko.tex-base,
979         cm-super,
980         po-debconf
981 Description: metapackage for d-i.debian.org
982  This package depends on all the packages that are needed for the
983  d-i.debian.org setup.
984
985 Package: debian.org-codesearch.debian.org
986 Architecture: all
987 Depends: dpkg-dev,
988         postgresql-client
989 Description: metapackage for codesearch.debian.org
990  This package depends on all the packages that are needed for the codesearch
991  setup.
992
993 Package: debian.org-dedup.debian.net
994 Architecture: all
995 Depends: curl,
996         python,
997         python-concurrent.futures,
998         python-debian,
999         python-imaging,
1000         python-jinja2,
1001         python-lzma,
1002         python-pkg-resources,
1003         python-werkzeug,
1004         python-yaml,
1005         python-sqlalchemy,
1006         python-ssdeep | base-files (<< 8),
1007         sqlite3
1008 Description: metapackage for dedup.debian.net
1009  This package depends on all packages that are required for operating the
1010  Debian duplication detector.
1011
1012 Package: debian.org-wnpp-by-tags.debian.net
1013 Architecture: all
1014 Depends: debtags, python-debian, python-beautifulsoup
1015 Description: metapackage for wnpp-by-tags.debian.net
1016  This package depends on all the packages that are needed for the wnpp-by-tags
1017  setup.
1018
1019 Package: debian.org-blends.debian.org
1020 Architecture: all
1021 Depends: python-genshi,
1022  python-markdown,
1023  python-docutils,
1024  python-debian,
1025  python-psutil,
1026  python-psycopg2,
1027  python-apt,
1028  python3-genshi,
1029  python3-markdown,
1030  python3-docutils,
1031  python3-debian,
1032  python3-psutil,
1033  python3-psycopg2,
1034  python3-apt,
1035  postgresql-client
1036 Description: metapackage for blends.debian.org
1037  This package depends on all the packages that are needed for the
1038  blends.debian.org setup.
1039
1040 Package: debian.org-pet.debian.net
1041 Architecture: all
1042 Depends: python-apt,
1043         python-argparse,
1044         python-debian,
1045         python-debianbts,
1046         python-inotifyx,
1047         python-paste,
1048         python-psycopg2,
1049         python-pyramid,
1050         python-sqlalchemy,
1051         python-subversion
1052 Description: metapackages for pet.debian.net dependencies
1053  This package depends on everything that is needed for the PET setup.
1054
1055 Package: debian.org-dsa.debian.org
1056 Architecture: all
1057 Depends: ikiwiki, libtext-wikicreole-perl, libtext-wikiformat-perl, libtext-multimarkdown-perl
1058 Description: metapackages for dsa.debian.org master dependencies
1059  This package depends on everything that is needed for the service
1060
1061 Package: debian.org-dns.debian.org
1062 Architecture: all
1063 Depends: perl-doc,
1064         nagios-nrpe-plugin,
1065         sqlite3,
1066         libdata-compare-perl,
1067         libnet-dns-perl,
1068         libnet-dns-sec-perl,
1069         python-dnspython,
1070         python-yaml,
1071         letsencrypt.sh,
1072 Description: metapackages for dns.debian.org master dependencies
1073  This package depends on everything that is needed for the service
1074
1075 Package: debian.org-nagios.debian.org
1076 Architecture: all
1077 Depends: icinga
1078 Description: metapackages for nagios.debian.org master dependencies
1079  This package depends on everything that is needed for the service and
1080  also provides the dpkg-diverts for the REMOTE_USER hack
1081
1082 Package: debian.org-deriv.debian.net
1083 Architecture: all
1084 Depends: python,
1085         python-apt,
1086         python-debian,
1087         python-imaging,
1088         python-psycopg2,
1089         python-requests,
1090         python-simplejson,
1091         python-yaml,
1092         libxml-feed-perl,
1093         apt-transport-https,
1094         dpkg-dev,
1095         patchutils,
1096         rsync,
1097         curl,
1098         make,
1099         lzip,
1100 Homepage: https://wiki.debian.org/Derivatives/Integration#Patches
1101 Description: metapackage for the derivatives census patch generation
1102  This package depends on everything that is needed for the service
1103
1104 Package: debian.org-httpredir.debian.org
1105 Architecture: all
1106 Depends: inoticoming,
1107         libanyevent-perl,
1108         libanyevent-http-perl,
1109         libev-perl,
1110         libtimedate-perl,
1111         libgeo-ip-perl,
1112         libwww-perl,
1113         liburi-perl,
1114         libplack-perl,
1115         starman
1116 Description: metapackage for http-redirector dependencies
1117  This package depends on everything that is needed for an instance of
1118  the http-redirector.
1119
1120 Package: debian.org-search.debian.org
1121 Architecture: all
1122 Depends: xapian-omega
1123 Description: metapackage for search.debian.org dependencies
1124  This package depends on everything that is needed for an instance of
1125  the www search engine (aka search.debian.org).
1126
1127 Package: debian.org-dgit.debian.org
1128 Architecture: all
1129 Depends: perl,
1130         libwww-perl,
1131         libdpkg-perl,
1132         git,
1133         devscripts,
1134         dpkg-dev,
1135         libdigest-sha-perl,
1136         dput,
1137         curl,
1138         libjson-perl,
1139         gpgv,
1140         chiark-utils-bin,
1141         libdbd-sqlite3-perl,
1142         sqlite3
1143 Description: metapackage for dgit.debian.org dependencies
1144  This package depends on everything that is needed for an instance of
1145  the dgit git server (aka dgit.debian.org).
1146  .
1147  (This is actually simply the dependencies of the dgit and
1148  dgit-infrastructure binary packages, but due to chicken-and-egg
1149  problems and for ease of maintenance we are running the dgit
1150  infrastructure out of a git tree.)
1151
1152 Package: debian.org-appstream.debian.org
1153 Architecture: all
1154 Depends: gir1.2-rsvg-2.0,
1155         python3-apt,
1156         python3-cairo,
1157         python3-gi,
1158         python3-gi-cairo,
1159         python3-jinja2,
1160         python3-lmdb,
1161         python3-lxml,
1162         python3-matplotlib,
1163         python3-pil,
1164         python3-pygments,
1165         python3-voluptuous,
1166         python3-yaml
1167         ,
1168         cmake,
1169         intltool,
1170         libglib2.0-dev,
1171         libxml2-dev,
1172         libgirepository1.0-dev,
1173         libxapian-dev,
1174         libyaml-dev,
1175         xmlto,
1176         gobject-introspection,
1177         libprotobuf-dev,
1178         protobuf-compiler,
1179         gdc,
1180         libgdk-pixbuf2.0-dev,
1181         libarchive-dev,
1182         librsvg2-dev,
1183         liblmdb-dev
1184 Description: metapackage for appstream.debian.org dependencies
1185  This package depends on everything that is needed for an instance of
1186  the DEP-11/AppStream metadata extractor.
1187
1188 Package: debian.org-debian-r.debian.org
1189 Architecture: all
1190 Depends: debian.org-ftpmaster.debian.org
1191 Description: metapackage for debian-r.debian.org dependencies
1192  This package depends on everything that is needed for the debian-r
1193  archive software (which is generally everything that is required by
1194  ftpmaster.debian.org).
1195
1196 Package: debian.org-ftpmaster.debian-ports.org
1197 Architecture: all
1198 Depends: apt-utils,
1199         git,
1200         gnupg,
1201         python,
1202         python-debian,
1203         procmail,
1204         wget
1205 Description: metapackage for debian-ports ftpmaster
1206  This package depends on everything that is needed for a debian-ports
1207  ftpmaster setup (using mini-dak).