add dosfstools for cdbuilder
[debian.org.git] / debian / control
1 Source: debian.org
2 Section: local/admin
3 Priority: required
4 Maintainer: Debian sysadmin Team <debian-admin@debian.org>
5 Uploaders: Peter Palfrader <weasel@debian.org>, Martin Zobel-Helas <zobel@debian.org>, Stephen Gran <sgran@debian.org>
6 Build-Depends: debhelper (>= 7)
7 Standards-Version: 3.8.1
8
9 Package: debian.org
10 Architecture: all
11 Depends: userdir-ldap, zsh, tcsh, pdksh, ksh, csh, ntp, locales-all, exim4-daemon-heavy | postfix, sudo, libpam-pwdfile, vim, munin-node, gnupg, bzip2, cacert-spi | ca-certificates (>> 20080411), ed, cron, dialog, libterm-readline-gnu-perl, logrotate, syslog-ng (>= 3.1)
12 Recommends: debian.org-recommended
13 Conflicts: dchroot-dsa (<= 2:1)
14 Description: DSA's host metapackage
15  This package depends on packages that should be installed on every
16  debian.org host, and conflicts with packages that should never be
17  installed.
18
19 Package: debian.org-recommended-linux
20 Architecture: all
21 Depends: vlan, ifenslave, bridge-utils, iproute,
22         strace
23 Description: metapackage to pull in recommended, but not essential tools for linux system
24  This package depends on packages that are recommended to  be installed on
25  every Linux debian.org host but are not essential.
26
27 Package: debian.org-recommended
28 Architecture: all
29 Depends: debian.org,
30         busybox-static,
31         debian.org-recommended-linux | not+gnu-linux,
32         molly-guard
33         ,
34         man-db
35         ,
36         subversion, rcs, git-core, bzr,
37                 git-svn,
38                 subversion-tools,
39                 mercurial,
40         ,
41         mtr-tiny, tcpdump, tcptraceroute, ndisc6,
42         traceroute | not+gnu-linux,
43         bind9-host, dnsutils, whois
44         ,
45         emacs23-nox | emacs23 | emacs22-nox | emacs22 | emacs21-nox | emacs21
46         ,
47         at, uptimed,
48         puppet,
49                 libaugeas-ruby,
50                 libaugeas-ruby1.8,
51                 libaugeas0,
52                 augeas-lenses (>= 0.7),
53         locate, dlocate
54         ,
55         dsa-nagios-checks
56         ,
57         lshw | not+gnu-linux,
58         dmidecode | not+amd64,
59         dmidecode | not+i386,
60         dmidecode | not+ia64
61         ,
62         ipython
63         ,
64         mcelog | not+amd64 | not+gnu-linux,
65         mcelog | not+i386 | not+gnu-linux,
66         lsscsi
67         ,
68         htop, psmisc,
69         lsof | not+gnu-linux,
70         ,
71         mc,
72                 genisoimage,
73         less,
74         rsync,
75         screen,
76         ldap-utils, ldapvi,
77         mmv,
78         moreutils,
79         patchutils,
80         netcat-openbsd, socat, telnet
81         ,
82         deborphan
83         ,
84         file
85         ,
86         buffer
87         ,
88         bsd-mailx
89         ,
90         timeout | coreutils (>= 8.0-1)
91         ,
92         wget, curl, lftp, ftp,
93         ,
94         dput
95         ,
96         uuid-runtime
97         ,
98         finger
99         ,
100         unzip
101         ,
102         w3m,
103         elinks,
104         mutt
105 Description: metapackage to pull in recommended, but not essential tools
106  This package depends on packages that are recommended to  be installed on
107  every debian.org host but are not essential.
108
109 Package: debian.org-bugs.debian.org
110 Architecture: all
111 Depends: graphviz,
112         libcgi-simple-perl,
113         libio-stringy-perl,
114         liblist-moreutils-perl,
115         libmime-tools-perl,
116         libmldbm-perl,
117         libparams-validate-perl,
118         libsafe-hole-perl,
119         libtext-template-perl,
120         liburi-perl,
121         libhtml-tree-perl,
122         libsoap-lite-perl,
123         libdbd-pg-perl,
124         python-pyinotify,
125         python-yaml
126 Description: metapackages for bugs.debian.org dependencies
127  This package depends on everything that is needed for a bugs.debian.org
128  mirror or (in the future) bugs-master.
129
130 Package: debian.org-bugs.debian.org-mx
131 Architecture: all
132 Depends: debian.org-bugs.debian.org,
133         spamassassin,
134         build-essential,
135         spamc,
136         libmail-spf-perl,
137         re2c,
138         libsys-syslog-perl,
139         libio-socket-inet6-perl,
140         libnet-ident-perl,
141         libdbi-perl,
142         pyzor,
143         libmail-dkim-perl,
144         libdbd-pg-perl
145 Description: metapackages for bugs.debian.org mail exchanger
146  This package depends on everything that is needed for a bugs.debian.org
147  MX.
148
149
150 Package: debian.org-packages.debian.org
151 Architecture: all
152 Depends: db4.6-util,
153         liblocale-maketext-lexicon-perl,
154         libi18n-acceptlanguage-perl,
155         libnumber-format-perl,
156         libcompress-zlib-perl,
157         libhtml-parser-perl,
158         libmldbm-perl,
159         libtext-iconv-perl,
160         libclass-accessor-perl,
161         liburi-perl,
162         libtemplate-perl,
163         liblingua-stem-perl,
164         libsearch-xapian-perl,
165         libtimedate-perl,
166         libapache2-mod-perl2,
167         libapache2-reload-perl
168 Description: metapackages for packages.debian.org dependencies
169  This package depends on everything that is needed for a packages.debian.org
170  mirror or (in the future) packages-master.
171
172 Package: debian.org-www-master.debian.org
173 Architecture: all
174 Depends: debiandoc-sgml,
175         asciidoc,
176         cm-super,
177         debhelper,
178         docbook,
179         docbook-dsssl,
180         docbook-xsl,
181         dpkg-dev,
182         gettext,
183         ghostscript,
184         jadetex,
185         kcc,
186         ko.tex-base,
187         latex-cjk-all,
188         latex-cjk-chinese,
189         ldap-utils,
190         libnet-ldap-perl,
191         libtimedate-perl,
192         libwww-perl,
193         libxml2-utils,
194         libxml-rss-perl,
195         littex,
196         locales, locales-all,
197         maildrop,
198         openjade,
199         openjade1.3,
200         po4a,
201         poxml,
202         procmail,
203         python2.4,
204         python-xml,
205         texlive-fonts-recommended,
206         texlive-lang-cyrillic, texlive-lang-cyrillic, latex-cjk-japanese,
207         texlive-lang-czechslovak,
208         texlive-lang-finnish,
209         texlive-lang-french,
210         texlive-lang-german,
211         texlive-lang-greek,
212         texlive-lang-italian,
213         texlive-lang-other,
214         texlive-lang-portuguese,
215         texlive-lang-spanish,
216         texlive-lang-swedish,
217         texlive-lang-vietnamese,
218         texlive-latex-base,
219         texlive-latex-extra,
220         texlive-latex-recommended,
221         tidy,
222         time,
223         ttf-arphic-uming,
224         ttf-malayalam-fonts,
225         wml,
226         xmlroff, dblatex,
227         xplanet,
228         xplanet-images,
229         xsltproc
230 Description: metapackages for www-master.debian.org dependencies
231  This package depends on everything that is needed for a www-master.debian.org.
232
233
234 Package: debian.org-buildd.debian.org
235 Architecture: all
236 Depends: edos-distcheck,
237         db4.8-util,
238         ghostscript,
239         libcompress-bzip2-perl,
240         libcompress-zlib-perl,
241         libhash-merge-perl,
242         libmailtools-perl,
243         libdbi-perl,
244         libdbd-pg-perl,
245         libfile-spec-perl,
246         libstring-escape-perl,
247         libstring-format-perl,
248         libyaml-tiny-perl,
249         python-apt,
250         python-contract,
251         python-coverage,
252         python-coverage-test-runner,
253         python-debian,
254         python-psycopg2,
255         python-mako,
256         python-nose,
257         python-sqlalchemy (>= 0.5),
258         python-sqlalchemy (<< 0.6),
259         quinn-diff,
260         r-base-core,
261         r-cran-lattice,
262         postgresql-8.4, postgresql-8.4-debversion,
263         php5,
264         moreutils (>= 0.39~)
265 Description: metapackages for buildd.debian.org dependencies
266  This package depends on everything that is needed for a buildd.debian.org.
267
268
269 Package: debian.org-patch-tracker.debian.org
270 Architecture: all
271 Depends: patchutils,
272         python,
273         python-cheetah,
274         python-pygments,
275         python-debian,
276         reprepro,
277         python-wsgiref,
278         python-simplejson,
279         python-pysqlite2,
280         diffstat
281 Description: metapackages for patch-tracker.debian.org dependencies
282  This package depends on everything that is needed for a patch-tracker.debian.org.
283
284 Package: debian.org-planet.debian.org
285 Architecture: all
286 Depends: libwww-perl,
287         timeout,
288         debianutils,
289         python-django,
290         python
291 Description: metapackages for planet.debian.org dependencies
292  This package depends on everything that is needed for a planet.debian.org.
293
294 Package: debian.org-testing-security.debian.org
295 Architecture: all
296 Depends: libdbd-sqlite3-perl,
297         sqlite3,
298         python-apsw,
299         libterm-readline-gnu-perl,
300         python-apt
301 Description: metapackages for testing-security.debian.org dependencies
302  This package depends on everything that is needed for a testing-security.debian.org.
303
304 Package: debian.org-ftpmaster.debian.org
305 Architecture: all
306 Depends: apt-utils,
307         libapt-pkg-dev,
308         python-apt,
309         python-debianbts (>= 1.4~bpo50+1),
310         lintian,
311         python,
312         python-debian,
313         python-gnupginterface,
314         python-ldap,
315         python-psycopg2,
316         python-pygresql,
317         python-pyrss2gen,
318         python-yaml,
319         python-sqlalchemy (>= 0.5), python-sqlalchemy (<< 0.6),
320         binutils-multiarch,
321         build-essential,
322         devscripts,
323         graphviz,
324         ikiwiki,
325         libdbd-pg-ruby,
326         python-epydoc,
327         python-numpy,
328         python-soappy,
329         r-base,
330         symlinks,
331         python-magic,
332         unp,
333         procmail,
334         cvs,
335         ruby,
336         irb,
337         lynx,
338         libxml-rss-perl,
339         ghostscript,
340         perforate,
341         wdiff,
342         xz-utils (>= 4.999.9beta+20100713-1~bpo50+1)
343 Description: metapackage for ftpmaster
344  This package depends on everything that is needed for an ftpmaster setup.
345
346 Package: debian.org-release.debian.org
347 Architecture: all
348 Depends: mutt,
349         subversion,
350         python2.5,
351         devscripts,
352         wdiff,
353         python-pygresql,
354         python-libxslt1,
355         python-apt,
356         python-debian,
357         libapt-pkg-perl,
358         procmail
359 Description: metapackage for release
360  This package depends on everything that is needed for a release.debian.org
361  setup.
362
363 Package: debian.org-cdbuilder.debian.org
364 Architecture: all
365 Depends: bittornado,
366         build-essential,
367         debhelper,
368         debian-cd,
369         jigit,
370         m4,
371         tofrodos,
372         zip,
373         zsync,
374         fakeroot,
375         dosfstools
376 Description: metapackage for cdbuilder
377  This package depends on all the packages that are needed for a cdbuilder setup.
378
379 Package: debian.org-manpages.debian.org
380 Architecture: all
381 Depends: locales-all,
382         gs-common
383 Description: metapackage for manpages
384  This package depends on all the packages that are needed for manpages.d.o setup.
385
386 Package: debian.org-nm.debian.org
387 Architecture: all
388 Depends: libapache2-mod-php5, libapache2-mod-wsgi,
389         php5-cli,
390         php5-ldap, php5-pgsql,
391         wml,
392         mutt, mboxgrep,
393         python,
394         python-mako (>= 0.2.5), python-gnupginterface, python-ldap,
395         python-apt, python-beautifulsoup, python-debianbts, python-dns,
396         python-dnspython, python-egenix-mxdatetime, python-egenix-mxtools,
397         python-elementtree | python (>= 2.6), python-flup, python-libxml2,
398         python-lxml, python-psycopg2, python-soappy, python-virtualenv,
399         python-sqlalchemy (>= 0.6), python (>= 2.5.4-5~) | python-simplejson,
400         python-flask (>= 0.6), python-flaskext.wtf, python-wtforms,
401         perl,
402         libdbi-perl, libdbd-pg-perl, libdbd-sqlite3-perl,
403         procmail,
404         moreutils
405 Description: metapackage for nm.debian.org
406  This package depends on all the packages that are needed for nm.debian.org setup.
407
408 Package: debian.org-backports.debian.org
409 Architecture: all
410 Depends: debian.org-ftpmaster.debian.org,
411         libdbi-perl, libdbd-pg-perl
412 Description: metapackage for backports.debian.org
413  This package depends on all the packages that are needed for backports.debian.org setup.
414
415 Package: debian.org-qa.debian.org
416 Architecture: all
417 Depends: db4.8-util,
418         gnuplot-nox,
419         wml,
420         libapt-pkg-perl,
421                 libdbd-pg-perl,
422                 libdate-manip-perl,
423                 libdpkg-perl,
424                 libmailtools-perl,
425                 libsoap-lite-perl,
426                 libtemplate-perl,
427                 libxml-simple-perl,
428                 libmail-sendmail-perl,
429                 libdate-calc-perl,
430                 libnet-ldap-perl,
431         php5, php5-cgi, php5-cli,
432                 php5-ldap, php5-pgsql,
433                 libapache2-mod-fcgid,
434         python-apt, python-psycopg2,
435         libdbd-pg-ruby,
436         rrdtool
437 Description: metapackage for qa.debian.org
438  This package depends on all the packages that are needed for qa.debian.org setup.