891214d482958fcc493e6511e8c9f1313b3912d5
[debian.org.git] / debian / changelog
1 debian.org (4XXX) Xnstable; urgency=low
2
3   [ Peter Palfrader ]
4   * recommended:
5     - iputils-tracepath
6     - unbound-host
7   * planet:
8     - Fix timeout dependency ( | coreutils >> somethingorother)
9     - add libdbi-perl
10     - add libdate-manip-perl
11     - add libdbd-sqlite3-perl
12   * apt-in-chroot: "fix" bashism.
13   * add women.d.o
14   * buildd:
15     - remove db4.8-util
16     - remove quinn-diff
17     - remove python-coverage-test-runner
18     - add libdpkg-perl
19   * ftpmaster-poneys:
20     - add colordiff
21   * add lintan.d.o
22   * add popcon.d.o
23   * add dde.d.n
24   * release:
25     - add rrdtool
26
27   [ Steve McIntyre ]
28   * cdimage-search.debian.org
29     - add cdimage-search metapackage
30
31   [ Simon Paillard ]
32   * www-master:
33     - add libsoap-lite-perl (RT#3117, Bug#574550)
34
35   [ David Prévot ]
36   * www-master:
37     - add iso-codes
38     - add isoquery (Bug#624150)
39     - add uni2ascii (Bug#625650)
40     - add libemail-address-perl
41     - add libmime-lite-perl (Bug#541839)
42
43   [ Stephen Gran ]
44   * Update apt-in-chroot to work with dash
45   * add imagemagick to depends for www-master
46
47  -- Peter Palfrader <weasel@debian.org>  Fri, 17 Jun 2011 12:23:45 +0200
48
49 debian.org (43.3) unstable; urgency=low
50
51   * Add debian.org-udd.debian.org.
52   * Add debian.org-snapshot.debian.org.
53
54  -- Peter Palfrader <weasel@debian.org>  Sat, 26 Mar 2011 22:28:16 +0100
55
56 debian.org (43.2) unstable; urgency=low
57
58   [ Stephen Gran ]
59   * debian.org:
60     - add nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic for
61       check_mailq
62
63   [ Peter Palfrader ]
64   * release
65     - needs edos-debcheck, not edos-distcheck.
66     - python-dev
67   * ftp-poneys
68     - gitstats
69
70  -- Peter Palfrader <weasel@debian.org>  Mon, 21 Mar 2011 22:28:16 +0100
71
72 debian.org (43.1) unstable; urgency=low
73
74   * release:
75     - add edos-distcheck
76     - add python2.5-dev
77     - add libapt-pkg-dev
78     - add dpkg-dev
79     - remove obsolete python-simplejson | python (>= 2.6)
80   * Add debian.org-ftpmaster.debian.org-poneys package.
81
82  -- Peter Palfrader <weasel@debian.org>  Sun, 20 Mar 2011 00:36:33 +0100
83
84 debian.org (43) unstable; urgency=low
85
86   * buildd.debian.org:
87     - remove dependency on postgresql-8.4 - we do not depend on db servers in
88       debian.org metapackages.
89   * Move lsscsi from -recommended to -recommended-linux as it does not exist
90     on the BSDs.
91
92  -- Peter Palfrader <weasel@debian.org>  Sat, 19 Mar 2011 23:54:49 +0100
93
94 debian.org (42) unstable; urgency=low
95
96   [ Steve McIntyre ]
97   * cdbuilder.debian.org
98     - add dosfstools
99
100   [ Joerg Jaspert ]
101   * debian.org-ftpmaster.debian.org: Add xz-utils (bpo or higher version)
102   * use python-debianbts instead of python-btsutils
103
104   [ Peter Palfrader ]
105   * Add debian.org-qa.debian.org.
106   * -recommended:
107     - add busybox-static
108     - add lsscsi
109     - add cvs (yes, really)
110   * www-master:
111     - add ttf-malayalam-fonts
112     - add tidy
113     - add libjson-perl
114   * ftp-master:
115     - add python-simplejson || python (>= 2.6)
116     - dependency on python-sqlalchemy is no longer versioned
117     - remove irb (now provided by ruby)
118   * buildd.debian.org:
119     - dependency on python-sqlalchemy is no longer versioned
120
121   [ Bernd Zeimetz ]
122   * nm.d.o:
123     - make dependency on python-sqlalchemy versioned (>= 0.6),
124     - python (>= 2.5.4-5~) also works instead of python-simplejson,
125     - new dependencies: python-flask (>= 0.6), python-flaskext.wtf,
126       python-wtforms.
127
128   [ Martin Zobel-Helas ]
129   * add ipython to -recommended.
130   * add diffstat to -recommended
131
132   [ Stephen Gran ]
133   * Add wheezy chroots to upgrade-porter-chroots
134
135   [ Francesca Ciceri ]
136   * debian.org-www-master.debian.org:
137     - add libintl-perl
138
139  -- Peter Palfrader <weasel@debian.org>  Sat, 19 Mar 2011 23:34:04 +0100
140
141 debian.org (41.1) stable; urgency=low
142
143   * -recommended:
144     - Fix typo/copy error.
145     - lshw isn't available on *bsd either.
146
147  -- Peter Palfrader <weasel@debian.org>  Fri, 10 Sep 2010 20:32:07 +0200
148
149 debian.org (41) stable; urgency=low
150
151   * debian.org-buildd.debian.org: Fix the moreutils versioned dependency.
152   * Split -recommended-linux off of -recommended, so we can install
153     the latter on kfreebsd hosts.  Also keep a few tools in -recommended
154     that do not yet exist on freebsd but might eventually (have not+gnu-linux
155     as an alternative for them for now).
156
157  -- Peter Palfrader <weasel@debian.org>  Fri, 10 Sep 2010 20:22:55 +0200
158
159 debian.org (40) stable; urgency=low
160
161   * Remove acpid from debian.org-recommended.  >= 2.0 doesn't exist in
162     stable.
163
164  -- Peter Palfrader <weasel@debian.org>  Thu, 09 Sep 2010 20:56:24 +0200
165
166 debian.org (39) stable; urgency=low
167
168   [ Joerg Jaspert ]
169   * More updates for the ftpmaster package.
170
171   [ Martin Zobel-Helas ]
172   * add syslog-ng (>= 3.1) to debian.org.
173   * add acpid (>= 2.0) to debian.org-recommended.
174   * start new package debian.org-nm.debian.org
175   * add wdiff dependency to ftpmaster package.
176
177   [ Philipp Kern ]
178   * add mutt to debian.org-recommended
179   * add debian.org-release.debian.org metapackage
180   * add python-mako to debian.org-buildd.debian.org
181   * add moreutils (>= 0.39) to debian.org-buildd.debian.org
182     (for a fixed parallel)
183
184   [ Peter Palfrader ]
185   * A new debian.org-backports.debian.org package.
186   * debian.org-recommended updates for squeeze:
187     - Dependency on timeout can also be satisfied by coreutils >= 8.0-1.
188     - Dependency on emacs* can also be satisfied by emacs23.
189
190  -- Peter Palfrader <weasel@debian.org>  Thu, 09 Sep 2010 17:10:31 +0200
191
192 debian.org (38) stable; urgency=low
193
194   * Update python-sqlalchemy dependency for ftpmaster metapackage to version > 0.5 << 0.6
195
196  -- Joerg Jaspert <joerg@debian.org>  Thu, 01 Jul 2010 21:55:14 +0200
197
198 debian.org (37) stable; urgency=low
199
200   [ Martin Zobel-Helas ]
201   * add mercurial to -recommended
202
203   [ Stephen Gran ]
204   * Remove etch from upgrade-porter-chroots
205
206  -- Stephen Gran <sgran@debian.org>  Thu, 01 Jul 2010 23:59:13 +0100
207
208 debian.org (36) stable; urgency=low
209
210   * buildd.debian.org:
211     - depend on db4.8-util instead of 4.7.
212   * buildd-reboot: change shutdown time to 1 minute from 15.
213
214  -- Peter Palfrader <weasel@debian.org>  Mon, 14 Jun 2010 17:53:41 +0200
215
216 debian.org (35) stable; urgency=low
217
218   [ Peter Palfrader ]
219   * -recommended: puppet now wants augeas, so add it to dependencies:
220     - libaugeas-ruby
221     - libaugeas-ruby1.8
222     - libaugeas0 (/lenny-backports)
223     - augeas-lenses (/lenny-backports == >= 0.7)
224
225   [ Martin Zobel-Helas ]
226   * do proper input validation
227     With the current code APTCMD was parsed for the valid subcomands, but if
228     it was invalid, it just printed it but worked nevertheless. Now we exit
229     if the subcommand is invalid.
230
231  -- Martin Zobel-Helas <zobel@debian.org>  Wed, 28 Apr 2010 16:08:59 +0200
232
233 debian.org (34) stable; urgency=low
234
235   [ Peter Palfrader ]
236   * buildd.debian.org
237     - add python-nose and php5
238     - depend on edos-distcheck instead of edos-debcheck
239   * bugs.debian.org: libdbd-pg-perl python-pyinotify python-yaml
240   * -recommended: remove irqbalance
241
242   [ Andreas Barth ]
243   * buildd.debian.org
244     - add libfile-spec-perl
245
246   [ Steve McIntyre ]
247   * cdbuilder.debian.org
248     - add zip
249
250  -- Peter Palfrader <weasel@debian.org>  Fri, 23 Apr 2010 18:44:55 +0200
251
252 debian.org (33) stable; urgency=low
253
254   [ Joerg Jaspert]
255   * Update the planet.debian.org metapackage, adding timeout,
256     debianutils, python-django, python as dependencies.
257   * Add an ftpmaster metapackage
258
259   [ Andreas Barth]
260   * Update buildd.debian.org metapackage:
261     + add libhash-merge-perl and libyaml-tiny-perl
262     + add libstring-escape-perl and libstring-format-perl
263     + add postgresql-8.4-debversion
264     + add python-sqlalchemy (>= 0.5), python-sqlalchemy (<< 0.6)
265
266   [ Steve McIntyre ]
267   * Add a cdbuilder metapackage
268
269   [ Peter Palfrader ]
270   * portforwarder-ssh-wrap: Do not linger around on half-closed TCP
271     sessions, i.e. use -q 600 as an option to nc(1).
272
273   [ Martin Zobel-Helas ]
274   * Add the manpages.debian.org metapackage
275
276   [ Philipp Kern ]
277   * buildd.debian.org: replace libmldbm-perl with libdbi-perl and
278     libdbd-pg-perl
279
280  -- Peter Palfrader <weasel@debian.org>  Mon, 22 Mar 2010 19:31:29 +0100
281
282 debian.org (32) stable; urgency=low
283
284   * Fix install target of Makefile to deal with usr/bin.
285
286  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Feb 2010 17:22:03 +0100
287
288 debian.org (31) stable; urgency=low
289
290   [ Martin Zobel-Helas ]
291   * New dependencies of debian.org-www-master:
292     - ttf-arphic-uming
293
294   [ Peter Palfrader ]
295   * Add portforwarder-ssh-wrap script.
296
297  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Feb 2010 16:56:06 +0100
298
299 debian.org (30) stable; urgency=low
300
301   [ Martin Zobel-Helas ]
302   * New dependencies of debian.org-recommended:
303     - whois
304   * New dependencies of debian.org-www-master:
305     - locales
306     - locales-all
307     - latex-cjk-all
308     - dblatex
309     - xmlroff
310     - debhelper
311     - docbook
312     - jadetex
313     - openjade
314     - openjade1.3
315     - docbook-dsssl
316     - texlive-lang-czechslovak
317     - texlive-lang-finnish
318     - texlive-lang-french
319     - texlive-lang-german
320     - texlive-lang-greek
321     - texlive-lang-italian
322     - texlive-lang-other
323     - texlive-lang-portuguese
324     - texlive-lang-spanish
325     - texlive-lang-swedish
326     - texlive-lang-vietnamese
327     - ko.tex-base
328     - cm-super
329
330   [ Peter Palfrader ]
331   * New dependencies of debian.org-packages.debian.org:
332     - libtimedate-perl
333   * New dependencies of debian.org-recommended:
334     - ftp
335   * apache2-vhost-update: Show differences of vhost config being committed.
336
337  -- Martin Zobel-Helas <zobel@debian.org>  Sun, 24 Jan 2010 21:05:50 +0100
338
339 debian.org (29) stable; urgency=low
340
341   * New dependencies of debian.org-recommended:
342     - traceroute
343     - ndisc6
344     - file
345     - buffer
346     - w3m (from www-master)
347     - elinks
348     - lftp
349     - dput
350   * Add debian.org-bugs.debian.org-mx package.
351
352  -- Peter Palfrader <weasel@debian.org>  Wed, 09 Dec 2009 20:43:08 +0100
353
354 debian.org (28) stable; urgency=low
355
356   * buildd-reboot: Write 'delete-on-reboot' to no-daemon-please only
357     when the buildd has stopped cleanly.  Write
358     waiting-for-clean-shutdown while we are waiting.
359
360  -- Peter Palfrader <weasel@debian.org>  Mon, 26 Oct 2009 09:38:46 +0100
361
362 debian.org (27) stable; urgency=low
363
364   * buildd-reboot: Only touch no-daemon-please if there is currently a
365     buildd.pid.
366
367  -- Peter Palfrader <weasel@debian.org>  Sat, 24 Oct 2009 20:29:32 +0200
368
369 debian.org (26) stable; urgency=low
370
371   * *sigh*
372
373  -- Peter Palfrader <weasel@debian.org>  Fri, 23 Oct 2009 20:25:53 +0200
374
375 debian.org (25) stable; urgency=low
376
377   * Why is it always the featurs that you add and can't possibly break
378     that break?
379
380  -- Peter Palfrader <weasel@debian.org>  Fri, 23 Oct 2009 20:17:34 +0200
381
382 debian.org (24) stable; urgency=low
383
384   * New dependencies of debian.org-recommended:
385     - man-db
386     - unzip
387     - vlan, ifenslave, bridge-utils
388     - genisoimage (mc needs it to read .iso files)
389   * New dependencies of debian.org-testing-security.debian.org:
390     - python-apt
391   * New dependencies of debian.org-buildd.debian.org:
392     - r-cran-lattice
393   * Add buildd-reboot script.
394
395  -- Peter Palfrader <weasel@debian.org>  Fri, 23 Oct 2009 19:56:43 +0200
396
397 debian.org (23) stable; urgency=low
398
399   * Fix package name: patch-planet -> planet
400
401  -- Peter Palfrader <weasel@debian.org>  Mon, 28 Sep 2009 11:13:16 +0200
402
403 debian.org (22) stable; urgency=low
404
405   * New dependencies of debian.org-www-master:
406     - asciidoc
407     - libxml2-utils
408   * New dependencies of debian.org-buildd.debian.org:
409     - python-contract
410   * Add a debian.org-patch-tracker.debian.org.
411   * Add a debian.org-planet.debian.org.
412   * Add a debian.org-testing-security.debian.org.
413   * New dependencies of debian.org-recommended:
414     - git-svn
415     - subversion-tools
416
417  -- Peter Palfrader <weasel@debian.org>  Mon, 28 Sep 2009 11:10:33 +0200
418
419 debian.org (21) stable; urgency=low
420
421   * Fix a typo for www-master: -littlex +littex.
422
423  -- Peter Palfrader <weasel@debian.org>  Fri, 14 Aug 2009 11:29:15 +0200
424
425 debian.org (20) stable; urgency=low
426
427   * New dependencies of debian.org-recommended:
428     - tcptraceroute
429     - uuid-runtime
430     - finger
431   * New dependencies of debian.org-www-master:
432     - procmail (bin/lockfile)
433     - ldap-utils
434   * New debian.org-buildd.debian.org package.
435
436  -- Peter Palfrader <weasel@debian.org>  Fri, 14 Aug 2009 11:24:28 +0200
437
438 debian.org (19) stable; urgency=low
439
440   * Move dialog to debian.org (for debconf).
441   * New dependencies of debian.org:
442     - libterm-readline-gnu-perl (for readline debconf)
443     - logrotate
444   * New dependencies of debian.org-recommended:
445     - netcat-openbsd, socat, telnet
446     - irqbalance
447     - strace
448     - wget, curl
449   * Start a debian.org-www-master.debian.org.
450
451  -- Peter Palfrader <weasel@debian.org>  Thu, 23 Jul 2009 11:23:14 +0200
452
453 debian.org (18) stable; urgency=low
454
455   * I wanted psmisc, not psutils.
456
457  -- Peter Palfrader <weasel@debian.org>  Sat, 27 Jun 2009 03:21:06 +0200
458
459 debian.org (17) stable; urgency=low
460
461   * Recommends depends deborphan, dialog.
462   * Recommends depends dsa-nagios-checks.
463   * Recommends depends bsd-mailx.
464   * Recommends depends timeout.
465   * Recommends depends bzr.
466   * Recommends depends mmv.
467   * Recommends depends moreutils.
468   * Recommends depends patchutils.
469   * Recommends depends psutils.
470
471  -- Peter Palfrader <weasel@debian.org>  Sat, 27 Jun 2009 03:10:49 +0200
472
473 debian.org (16.1) stable; urgency=low
474
475   * Packages need an Arch in debian/control.
476
477  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Jun 2009 16:53:01 +0200
478
479 debian.org (16) stable; urgency=low
480
481   * Make debian.org-recommended depend on mcelog on archs that provide it.
482   * Add debian.org-bugs.debian.org.
483   * Add debian.org-packages.debian.org.
484
485  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Jun 2009 16:51:43 +0200
486
487 debian.org (15) stable; urgency=low
488
489   * dmidecode only exists on amd64, i386, ia64.
490
491  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Jun 2009 15:09:34 +0200
492
493 debian.org (14) stable; urgency=low
494
495   * upgrade-porter-chroots: Do the chroots on pergolesi also.
496   * upgrade-porter-chroots: Print which chroot we're working on.
497   * Add debian.org-recommended meta package.
498   * Remove neuro from Uploaders.
499   * Switch to debhelper.
500   * Change descriptions a bit so lintian shuts up.
501   * Standards-Version: 3.7.2 -> 3.8.1.
502   * Add molly-guard to recommended packages list.
503   * Remove Recommends: on dsa-nagios-nrpe-config.
504
505  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Jun 2009 14:37:55 +0200
506
507 debian.org (13) stable; urgency=low
508
509   * upgrade-porter-chroots: Spell testing differently.
510
511  -- Peter Palfrader <weasel@debian.org>  Mon, 16 Mar 2009 21:28:46 +0100
512
513 debian.org (12) stable; urgency=low
514
515   * emacs22 and emacs22-nox are perfectly fine emacsen.
516
517  -- Peter Palfrader <weasel@debian.org>  Tue, 10 Mar 2009 23:25:10 +0100
518
519 debian.org (11) stable; urgency=low
520
521   * Fix comment in apache2-vhost-update.
522
523  -- Peter Palfrader <weasel@debian.org>  Sat, 10 Jan 2009 16:27:55 +0100
524
525 debian.org (10) stable; urgency=low
526
527   * Do not allow include statements.
528
529  -- Peter Palfrader <weasel@debian.org>  Sat, 10 Jan 2009 14:54:34 +0100
530
531 debian.org (9) stable; urgency=low
532
533   * Make restart-apache way more powerful.
534   * Rename restart-apache to apache2-vhost-update.
535
536  -- Peter Palfrader <weasel@debian.org>  Sat, 10 Jan 2009 14:42:52 +0100
537
538 debian.org (8) stable; urgency=low
539
540   * Install restart-apache script.
541
542  -- Martin Zobel-Helas <zobel@debian.org>  Sun, 07 Dec 2008 15:35:45 +0100
543
544 debian.org (7) stable; urgency=low
545
546   * Depend on libpam-pwdfile.
547   * Install upgrade-porter-chroots script.
548
549  -- Peter Palfrader <weasel@debian.org>  Wed, 17 Sep 2008 00:23:38 +0200
550
551 debian.org (6) stable; urgency=low
552
553   * Instead of cacert-spi we can also have ca-certificates (>> 20080411).
554     That's required for lenny.
555
556  -- Peter Palfrader <weasel@debian.org>  Fri, 29 Aug 2008 00:01:03 +0200
557
558 debian.org (5) stable; urgency=low
559
560   * Depend on ed.  We like ed.
561
562  -- Peter Palfrader <weasel@debian.org>  Sun, 13 Jul 2008 10:51:40 +0200
563
564 debian.org (4) stable; urgency=low
565
566   * No longer install spi's CA into /etc/ssl/certs,
567   * instead depend on the cacert-spi package.
568
569  -- Peter Palfrader <weasel@debian.org>  Sun, 25 May 2008 19:46:20 +0200
570
571 debian.org (3) stable; urgency=low
572
573   * Add bzip2 and less to depends.
574
575  -- Peter Palfrader <weasel@debian.org>  Sun, 25 May 2008 00:48:58 +0200
576
577 debian.org (2) stable; urgency=low
578
579   * Get rid of ssh (>= 10:3) dependency.
580   * Add myself to uploaders.
581   * Remove bind9 and famke from Recommends.
582   * Remove vile, clamav-freshclam, clamav-daemon from Depends.
583   * Recommend dsa-nagios-nrpe-config.
584   * Change section to local/admin.
585   * Install spi's CA into /etc/ssl/certs
586
587  -- Peter Palfrader <weasel@debian.org>  Sun, 25 May 2008 00:30:01 +0200
588
589 debian.org (0.1) stable; urgency=low
590
591   * Initial creation of metapackage.
592
593  -- Ryan Murray <rmurray@debian.org>  Fri,  9 Nov 2007 15:55:26 -0700