add cdimage-search metapackage
[debian.org.git] / debian / changelog
1 debian.org (4XXX) Xnstable; urgency=low
2
3   * planet:
4     - Fix timeout dependency ( | coreutils >> somethingorother)
5     - add libdbi-perl
6     - add libdate-manip-perl
7     - add libdbd-sqlite3-perl
8   * apt-in-chroot: "fix" bashism.
9
10   [ Steve McIntyre ]
11   * cdimage-search.debian.org
12     - add cdimage-search metapackage
13
14  -- Peter Palfrader <weasel@debian.org>  Fri, 01 Apr 2011 22:55:17 +0200
15
16 debian.org (43.3) unstable; urgency=low
17
18   * Add debian.org-udd.debian.org.
19   * Add debian.org-snapshot.debian.org.
20
21  -- Peter Palfrader <weasel@debian.org>  Sat, 26 Mar 2011 22:28:16 +0100
22
23 debian.org (43.2) unstable; urgency=low
24
25   [ Stephen Gran ]
26   * debian.org:
27     - add nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic for
28       check_mailq
29
30   [ Peter Palfrader ]
31   * release
32     - needs edos-debcheck, not edos-distcheck.
33     - python-dev
34   * ftp-poneys
35     - gitstats
36
37  -- Peter Palfrader <weasel@debian.org>  Mon, 21 Mar 2011 22:28:16 +0100
38
39 debian.org (43.1) unstable; urgency=low
40
41   * release:
42     - add edos-distcheck
43     - add python2.5-dev
44     - add libapt-pkg-dev
45     - add dpkg-dev
46     - remove obsolete python-simplejson | python (>= 2.6)
47   * Add debian.org-ftpmaster.debian.org-poneys package.
48
49  -- Peter Palfrader <weasel@debian.org>  Sun, 20 Mar 2011 00:36:33 +0100
50
51 debian.org (43) unstable; urgency=low
52
53   * buildd.debian.org:
54     - remove dependency on postgresql-8.4 - we do not depend on db servers in
55       debian.org metapackages.
56   * Move lsscsi from -recommended to -recommended-linux as it does not exist
57     on the BSDs.
58
59  -- Peter Palfrader <weasel@debian.org>  Sat, 19 Mar 2011 23:54:49 +0100
60
61 debian.org (42) unstable; urgency=low
62
63   [ Steve McIntyre ]
64   * cdbuilder.debian.org
65     - add dosfstools
66
67   [ Joerg Jaspert ]
68   * debian.org-ftpmaster.debian.org: Add xz-utils (bpo or higher version)
69   * use python-debianbts instead of python-btsutils
70
71   [ Peter Palfrader ]
72   * Add debian.org-qa.debian.org.
73   * -recommended:
74     - add busybox-static
75     - add lsscsi
76     - add cvs (yes, really)
77   * www-master:
78     - add ttf-malayalam-fonts
79     - add tidy
80     - add libjson-perl
81   * ftp-master:
82     - add python-simplejson || python (>= 2.6)
83     - dependency on python-sqlalchemy is no longer versioned
84     - remove irb (now provided by ruby)
85   * buildd.debian.org:
86     - dependency on python-sqlalchemy is no longer versioned
87
88   [ Bernd Zeimetz ]
89   * nm.d.o:
90     - make dependency on python-sqlalchemy versioned (>= 0.6),
91     - python (>= 2.5.4-5~) also works instead of python-simplejson,
92     - new dependencies: python-flask (>= 0.6), python-flaskext.wtf,
93       python-wtforms.
94
95   [ Martin Zobel-Helas ]
96   * add ipython to -recommended.
97   * add diffstat to -recommended
98
99   [ Stephen Gran ]
100   * Add wheezy chroots to upgrade-porter-chroots
101
102   [ Francesca Ciceri ]
103   * debian.org-www-master.debian.org:
104     - add libintl-perl
105
106  -- Peter Palfrader <weasel@debian.org>  Sat, 19 Mar 2011 23:34:04 +0100
107
108 debian.org (41.1) stable; urgency=low
109
110   * -recommended:
111     - Fix typo/copy error.
112     - lshw isn't available on *bsd either.
113
114  -- Peter Palfrader <weasel@debian.org>  Fri, 10 Sep 2010 20:32:07 +0200
115
116 debian.org (41) stable; urgency=low
117
118   * debian.org-buildd.debian.org: Fix the moreutils versioned dependency.
119   * Split -recommended-linux off of -recommended, so we can install
120     the latter on kfreebsd hosts.  Also keep a few tools in -recommended
121     that do not yet exist on freebsd but might eventually (have not+gnu-linux
122     as an alternative for them for now).
123
124  -- Peter Palfrader <weasel@debian.org>  Fri, 10 Sep 2010 20:22:55 +0200
125
126 debian.org (40) stable; urgency=low
127
128   * Remove acpid from debian.org-recommended.  >= 2.0 doesn't exist in
129     stable.
130
131  -- Peter Palfrader <weasel@debian.org>  Thu, 09 Sep 2010 20:56:24 +0200
132
133 debian.org (39) stable; urgency=low
134
135   [ Joerg Jaspert ]
136   * More updates for the ftpmaster package.
137
138   [ Martin Zobel-Helas ]
139   * add syslog-ng (>= 3.1) to debian.org.
140   * add acpid (>= 2.0) to debian.org-recommended.
141   * start new package debian.org-nm.debian.org
142   * add wdiff dependency to ftpmaster package.
143
144   [ Philipp Kern ]
145   * add mutt to debian.org-recommended
146   * add debian.org-release.debian.org metapackage
147   * add python-mako to debian.org-buildd.debian.org
148   * add moreutils (>= 0.39) to debian.org-buildd.debian.org
149     (for a fixed parallel)
150
151   [ Peter Palfrader ]
152   * A new debian.org-backports.debian.org package.
153   * debian.org-recommended updates for squeeze:
154     - Dependency on timeout can also be satisfied by coreutils >= 8.0-1.
155     - Dependency on emacs* can also be satisfied by emacs23.
156
157  -- Peter Palfrader <weasel@debian.org>  Thu, 09 Sep 2010 17:10:31 +0200
158
159 debian.org (38) stable; urgency=low
160
161   * Update python-sqlalchemy dependency for ftpmaster metapackage to version > 0.5 << 0.6
162
163  -- Joerg Jaspert <joerg@debian.org>  Thu, 01 Jul 2010 21:55:14 +0200
164
165 debian.org (37) stable; urgency=low
166
167   [ Martin Zobel-Helas ]
168   * add mercurial to -recommended
169
170   [ Stephen Gran ]
171   * Remove etch from upgrade-porter-chroots
172
173  -- Stephen Gran <sgran@debian.org>  Thu, 01 Jul 2010 23:59:13 +0100
174
175 debian.org (36) stable; urgency=low
176
177   * buildd.debian.org:
178     - depend on db4.8-util instead of 4.7.
179   * buildd-reboot: change shutdown time to 1 minute from 15.
180
181  -- Peter Palfrader <weasel@debian.org>  Mon, 14 Jun 2010 17:53:41 +0200
182
183 debian.org (35) stable; urgency=low
184
185   [ Peter Palfrader ]
186   * -recommended: puppet now wants augeas, so add it to dependencies:
187     - libaugeas-ruby
188     - libaugeas-ruby1.8
189     - libaugeas0 (/lenny-backports)
190     - augeas-lenses (/lenny-backports == >= 0.7)
191
192   [ Martin Zobel-Helas ]
193   * do proper input validation
194     With the current code APTCMD was parsed for the valid subcomands, but if
195     it was invalid, it just printed it but worked nevertheless. Now we exit
196     if the subcommand is invalid.
197
198  -- Martin Zobel-Helas <zobel@debian.org>  Wed, 28 Apr 2010 16:08:59 +0200
199
200 debian.org (34) stable; urgency=low
201
202   [ Peter Palfrader ]
203   * buildd.debian.org
204     - add python-nose and php5
205     - depend on edos-distcheck instead of edos-debcheck
206   * bugs.debian.org: libdbd-pg-perl python-pyinotify python-yaml
207   * -recommended: remove irqbalance
208
209   [ Andreas Barth ]
210   * buildd.debian.org
211     - add libfile-spec-perl
212
213   [ Steve McIntyre ]
214   * cdbuilder.debian.org
215     - add zip
216
217  -- Peter Palfrader <weasel@debian.org>  Fri, 23 Apr 2010 18:44:55 +0200
218
219 debian.org (33) stable; urgency=low
220
221   [ Joerg Jaspert]
222   * Update the planet.debian.org metapackage, adding timeout,
223     debianutils, python-django, python as dependencies.
224   * Add an ftpmaster metapackage
225
226   [ Andreas Barth]
227   * Update buildd.debian.org metapackage:
228     + add libhash-merge-perl and libyaml-tiny-perl
229     + add libstring-escape-perl and libstring-format-perl
230     + add postgresql-8.4-debversion
231     + add python-sqlalchemy (>= 0.5), python-sqlalchemy (<< 0.6)
232
233   [ Steve McIntyre ]
234   * Add a cdbuilder metapackage
235
236   [ Peter Palfrader ]
237   * portforwarder-ssh-wrap: Do not linger around on half-closed TCP
238     sessions, i.e. use -q 600 as an option to nc(1).
239
240   [ Martin Zobel-Helas ]
241   * Add the manpages.debian.org metapackage
242
243   [ Philipp Kern ]
244   * buildd.debian.org: replace libmldbm-perl with libdbi-perl and
245     libdbd-pg-perl
246
247  -- Peter Palfrader <weasel@debian.org>  Mon, 22 Mar 2010 19:31:29 +0100
248
249 debian.org (32) stable; urgency=low
250
251   * Fix install target of Makefile to deal with usr/bin.
252
253  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Feb 2010 17:22:03 +0100
254
255 debian.org (31) stable; urgency=low
256
257   [ Martin Zobel-Helas ]
258   * New dependencies of debian.org-www-master:
259     - ttf-arphic-uming
260
261   [ Peter Palfrader ]
262   * Add portforwarder-ssh-wrap script.
263
264  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Feb 2010 16:56:06 +0100
265
266 debian.org (30) stable; urgency=low
267
268   [ Martin Zobel-Helas ]
269   * New dependencies of debian.org-recommended:
270     - whois
271   * New dependencies of debian.org-www-master:
272     - locales
273     - locales-all
274     - latex-cjk-all
275     - dblatex
276     - xmlroff
277     - debhelper
278     - docbook
279     - jadetex
280     - openjade
281     - openjade1.3
282     - docbook-dsssl
283     - texlive-lang-czechslovak
284     - texlive-lang-finnish
285     - texlive-lang-french
286     - texlive-lang-german
287     - texlive-lang-greek
288     - texlive-lang-italian
289     - texlive-lang-other
290     - texlive-lang-portuguese
291     - texlive-lang-spanish
292     - texlive-lang-swedish
293     - texlive-lang-vietnamese
294     - ko.tex-base
295     - cm-super
296
297   [ Peter Palfrader ]
298   * New dependencies of debian.org-packages.debian.org:
299     - libtimedate-perl
300   * New dependencies of debian.org-recommended:
301     - ftp
302   * apache2-vhost-update: Show differences of vhost config being committed.
303
304  -- Martin Zobel-Helas <zobel@debian.org>  Sun, 24 Jan 2010 21:05:50 +0100
305
306 debian.org (29) stable; urgency=low
307
308   * New dependencies of debian.org-recommended:
309     - traceroute
310     - ndisc6
311     - file
312     - buffer
313     - w3m (from www-master)
314     - elinks
315     - lftp
316     - dput
317   * Add debian.org-bugs.debian.org-mx package.
318
319  -- Peter Palfrader <weasel@debian.org>  Wed, 09 Dec 2009 20:43:08 +0100
320
321 debian.org (28) stable; urgency=low
322
323   * buildd-reboot: Write 'delete-on-reboot' to no-daemon-please only
324     when the buildd has stopped cleanly.  Write
325     waiting-for-clean-shutdown while we are waiting.
326
327  -- Peter Palfrader <weasel@debian.org>  Mon, 26 Oct 2009 09:38:46 +0100
328
329 debian.org (27) stable; urgency=low
330
331   * buildd-reboot: Only touch no-daemon-please if there is currently a
332     buildd.pid.
333
334  -- Peter Palfrader <weasel@debian.org>  Sat, 24 Oct 2009 20:29:32 +0200
335
336 debian.org (26) stable; urgency=low
337
338   * *sigh*
339
340  -- Peter Palfrader <weasel@debian.org>  Fri, 23 Oct 2009 20:25:53 +0200
341
342 debian.org (25) stable; urgency=low
343
344   * Why is it always the featurs that you add and can't possibly break
345     that break?
346
347  -- Peter Palfrader <weasel@debian.org>  Fri, 23 Oct 2009 20:17:34 +0200
348
349 debian.org (24) stable; urgency=low
350
351   * New dependencies of debian.org-recommended:
352     - man-db
353     - unzip
354     - vlan, ifenslave, bridge-utils
355     - genisoimage (mc needs it to read .iso files)
356   * New dependencies of debian.org-testing-security.debian.org:
357     - python-apt
358   * New dependencies of debian.org-buildd.debian.org:
359     - r-cran-lattice
360   * Add buildd-reboot script.
361
362  -- Peter Palfrader <weasel@debian.org>  Fri, 23 Oct 2009 19:56:43 +0200
363
364 debian.org (23) stable; urgency=low
365
366   * Fix package name: patch-planet -> planet
367
368  -- Peter Palfrader <weasel@debian.org>  Mon, 28 Sep 2009 11:13:16 +0200
369
370 debian.org (22) stable; urgency=low
371
372   * New dependencies of debian.org-www-master:
373     - asciidoc
374     - libxml2-utils
375   * New dependencies of debian.org-buildd.debian.org:
376     - python-contract
377   * Add a debian.org-patch-tracker.debian.org.
378   * Add a debian.org-planet.debian.org.
379   * Add a debian.org-testing-security.debian.org.
380   * New dependencies of debian.org-recommended:
381     - git-svn
382     - subversion-tools
383
384  -- Peter Palfrader <weasel@debian.org>  Mon, 28 Sep 2009 11:10:33 +0200
385
386 debian.org (21) stable; urgency=low
387
388   * Fix a typo for www-master: -littlex +littex.
389
390  -- Peter Palfrader <weasel@debian.org>  Fri, 14 Aug 2009 11:29:15 +0200
391
392 debian.org (20) stable; urgency=low
393
394   * New dependencies of debian.org-recommended:
395     - tcptraceroute
396     - uuid-runtime
397     - finger
398   * New dependencies of debian.org-www-master:
399     - procmail (bin/lockfile)
400     - ldap-utils
401   * New debian.org-buildd.debian.org package.
402
403  -- Peter Palfrader <weasel@debian.org>  Fri, 14 Aug 2009 11:24:28 +0200
404
405 debian.org (19) stable; urgency=low
406
407   * Move dialog to debian.org (for debconf).
408   * New dependencies of debian.org:
409     - libterm-readline-gnu-perl (for readline debconf)
410     - logrotate
411   * New dependencies of debian.org-recommended:
412     - netcat-openbsd, socat, telnet
413     - irqbalance
414     - strace
415     - wget, curl
416   * Start a debian.org-www-master.debian.org.
417
418  -- Peter Palfrader <weasel@debian.org>  Thu, 23 Jul 2009 11:23:14 +0200
419
420 debian.org (18) stable; urgency=low
421
422   * I wanted psmisc, not psutils.
423
424  -- Peter Palfrader <weasel@debian.org>  Sat, 27 Jun 2009 03:21:06 +0200
425
426 debian.org (17) stable; urgency=low
427
428   * Recommends depends deborphan, dialog.
429   * Recommends depends dsa-nagios-checks.
430   * Recommends depends bsd-mailx.
431   * Recommends depends timeout.
432   * Recommends depends bzr.
433   * Recommends depends mmv.
434   * Recommends depends moreutils.
435   * Recommends depends patchutils.
436   * Recommends depends psutils.
437
438  -- Peter Palfrader <weasel@debian.org>  Sat, 27 Jun 2009 03:10:49 +0200
439
440 debian.org (16.1) stable; urgency=low
441
442   * Packages need an Arch in debian/control.
443
444  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Jun 2009 16:53:01 +0200
445
446 debian.org (16) stable; urgency=low
447
448   * Make debian.org-recommended depend on mcelog on archs that provide it.
449   * Add debian.org-bugs.debian.org.
450   * Add debian.org-packages.debian.org.
451
452  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Jun 2009 16:51:43 +0200
453
454 debian.org (15) stable; urgency=low
455
456   * dmidecode only exists on amd64, i386, ia64.
457
458  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Jun 2009 15:09:34 +0200
459
460 debian.org (14) stable; urgency=low
461
462   * upgrade-porter-chroots: Do the chroots on pergolesi also.
463   * upgrade-porter-chroots: Print which chroot we're working on.
464   * Add debian.org-recommended meta package.
465   * Remove neuro from Uploaders.
466   * Switch to debhelper.
467   * Change descriptions a bit so lintian shuts up.
468   * Standards-Version: 3.7.2 -> 3.8.1.
469   * Add molly-guard to recommended packages list.
470   * Remove Recommends: on dsa-nagios-nrpe-config.
471
472  -- Peter Palfrader <weasel@debian.org>  Sun, 21 Jun 2009 14:37:55 +0200
473
474 debian.org (13) stable; urgency=low
475
476   * upgrade-porter-chroots: Spell testing differently.
477
478  -- Peter Palfrader <weasel@debian.org>  Mon, 16 Mar 2009 21:28:46 +0100
479
480 debian.org (12) stable; urgency=low
481
482   * emacs22 and emacs22-nox are perfectly fine emacsen.
483
484  -- Peter Palfrader <weasel@debian.org>  Tue, 10 Mar 2009 23:25:10 +0100
485
486 debian.org (11) stable; urgency=low
487
488   * Fix comment in apache2-vhost-update.
489
490  -- Peter Palfrader <weasel@debian.org>  Sat, 10 Jan 2009 16:27:55 +0100
491
492 debian.org (10) stable; urgency=low
493
494   * Do not allow include statements.
495
496  -- Peter Palfrader <weasel@debian.org>  Sat, 10 Jan 2009 14:54:34 +0100
497
498 debian.org (9) stable; urgency=low
499
500   * Make restart-apache way more powerful.
501   * Rename restart-apache to apache2-vhost-update.
502
503  -- Peter Palfrader <weasel@debian.org>  Sat, 10 Jan 2009 14:42:52 +0100
504
505 debian.org (8) stable; urgency=low
506
507   * Install restart-apache script.
508
509  -- Martin Zobel-Helas <zobel@debian.org>  Sun, 07 Dec 2008 15:35:45 +0100
510
511 debian.org (7) stable; urgency=low
512
513   * Depend on libpam-pwdfile.
514   * Install upgrade-porter-chroots script.
515
516  -- Peter Palfrader <weasel@debian.org>  Wed, 17 Sep 2008 00:23:38 +0200
517
518 debian.org (6) stable; urgency=low
519
520   * Instead of cacert-spi we can also have ca-certificates (>> 20080411).
521     That's required for lenny.
522
523  -- Peter Palfrader <weasel@debian.org>  Fri, 29 Aug 2008 00:01:03 +0200
524
525 debian.org (5) stable; urgency=low
526
527   * Depend on ed.  We like ed.
528
529  -- Peter Palfrader <weasel@debian.org>  Sun, 13 Jul 2008 10:51:40 +0200
530
531 debian.org (4) stable; urgency=low
532
533   * No longer install spi's CA into /etc/ssl/certs,
534   * instead depend on the cacert-spi package.
535
536  -- Peter Palfrader <weasel@debian.org>  Sun, 25 May 2008 19:46:20 +0200
537
538 debian.org (3) stable; urgency=low
539
540   * Add bzip2 and less to depends.
541
542  -- Peter Palfrader <weasel@debian.org>  Sun, 25 May 2008 00:48:58 +0200
543
544 debian.org (2) stable; urgency=low
545
546   * Get rid of ssh (>= 10:3) dependency.
547   * Add myself to uploaders.
548   * Remove bind9 and famke from Recommends.
549   * Remove vile, clamav-freshclam, clamav-daemon from Depends.
550   * Recommend dsa-nagios-nrpe-config.
551   * Change section to local/admin.
552   * Install spi's CA into /etc/ssl/certs
553
554  -- Peter Palfrader <weasel@debian.org>  Sun, 25 May 2008 00:30:01 +0200
555
556 debian.org (0.1) stable; urgency=low
557
558   * Initial creation of metapackage.
559
560  -- Ryan Murray <rmurray@debian.org>  Fri,  9 Nov 2007 15:55:26 -0700